Orange Module running MULTI protocol

Choosing an RF Module? What modules work? What is compatible with the 9x?
sircrashalot
Posts: 13
Joined: Thu Mar 26, 2015 2:14 am
Country: -

Re: Orange Module running MULTI protocol

Post by sircrashalot » Tue Jul 17, 2018 12:20 pm

I tried the com port both ways, along with holding the bins button while booting. I have also watched the led to see what it does while booting and it does not flash either, in fact it does not even light up. I am suppoased to be using the file for the green board correct?


User avatar
MikeB
9x Developer
Posts: 16545
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Orange Module running MULTI protocol

Post by MikeB » Tue Jul 17, 2018 1:16 pm

What file did you use when you flashed the bootloader?

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

sircrashalot
Posts: 13
Joined: Thu Mar 26, 2015 2:14 am
Country: -

Re: Orange Module running MULTI protocol

Post by sircrashalot » Tue Jul 17, 2018 1:39 pm

MultiOrangeBoot.bin is the file I used. The firmware i used in the Tx is ersky9xProvR222b4.

sircrashalot
Posts: 13
Joined: Thu Mar 26, 2015 2:14 am
Country: -

Re: Orange Module running MULTI protocol

Post by sircrashalot » Tue Jul 17, 2018 1:59 pm

i was careful but did end up lifting the pads. Do those traces run to another component? So far it looks like they just run to the other side of the board to a pad that is not connected to anything but I don't know if there is a layer in the middle of the board.

sircrashalot
Posts: 13
Joined: Thu Mar 26, 2015 2:14 am
Country: -

Re: Orange Module running MULTI protocol

Post by sircrashalot » Tue Jul 17, 2018 2:00 pm

I am still trying to find where the two missing resistors are that I need to solder a jumper across


sircrashalot
Posts: 13
Joined: Thu Mar 26, 2015 2:14 am
Country: -

Re: Orange Module running MULTI protocol

Post by sircrashalot » Tue Jul 17, 2018 2:20 pm

I am going to bust out the soldering iron and start over and try flashing the bootloader with the pro mini instead of flashing it with the Tx.

User avatar
MikeB
9x Developer
Posts: 16545
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Orange Module running MULTI protocol

Post by MikeB » Tue Jul 17, 2018 2:27 pm

That board doesn't have/need those "missing" resistors.

I have one of those boards, but I don't think I ever put the bootloader onto it. I'll try going through the process with it, but it will be tomorrow before I have time to do so. I had the board for a different project, and that fell through, so I haven't used it since I flashed it using my AVRISP-II programmer.

When you flashed "MultiOrangeBoot.bin", please confirm you powered the board through the main, 5-way connector.

Good idea to try with the Pro Mini.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

sircrashalot
Posts: 13
Joined: Thu Mar 26, 2015 2:14 am
Country: -

Re: Orange Module running MULTI protocol

Post by sircrashalot » Tue Jul 17, 2018 2:42 pm

Yes I did power the board through the 5 pin connector from the radio while I flashed it.

sircrashalot
Posts: 13
Joined: Thu Mar 26, 2015 2:14 am
Country: -

Re: Orange Module running MULTI protocol

Post by sircrashalot » Tue Jul 17, 2018 4:18 pm

And... somehow I cooked the 3.3v regulator on the module.I have another regulator floating around somewhere so I might replace it,

sircrashalot
Posts: 13
Joined: Thu Mar 26, 2015 2:14 am
Country: -

Re: Orange Module running MULTI protocol

Post by sircrashalot » Tue Jul 17, 2018 5:45 pm

After taking some measurements with my meter, the 3.3v reg and the xmega are fried. time to order another module lol

lucidchaos
Posts: 2
Joined: Fri Feb 01, 2019 2:15 pm
Country: -

Re: Orange Module running MULTI protocol

Post by lucidchaos » Fri Feb 01, 2019 2:30 pm

Hi there,

Sorry in advance for the necro. Have been combing this thread and the work being done here is awesome.

I have a unique case. Would greatly like to flash my V1.2 ORX module, but I'm using it in a Jeti DS-16. No access to any FRSky or OpenTX hardware.
Any way to flash mine? I have access to a PC, Jeti internal PPM (PPM8+,ppm8-,ppm16), and Arduino Uno.

Image

Image

User avatar
MikeB
9x Developer
Posts: 16545
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Orange Module running MULTI protocol

Post by MikeB » Fri Feb 01, 2019 11:24 pm

The firmware build for the Orange module does NOT include support for PPM, only the serial protocol. I didn't implement the PPM input when I ported the code to the Orange module.
This means, currently, the module would not work with PPM from the Jeti.

Be aware also that the Orange module only supports those protocols that run on the Cypress RF chip:
DEVO
DSM
J6PRO
WFLY
WK2x01

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

lucidchaos
Posts: 2
Joined: Fri Feb 01, 2019 2:15 pm
Country: -

Re: Orange Module running MULTI protocol

Post by lucidchaos » Sat Feb 02, 2019 1:20 am

Good looking out. Thanks!

antlerhanger
Posts: 124
Joined: Tue Dec 25, 2018 3:19 am
Country: United States

Re: Orange Module running MULTI protocol

Post by antlerhanger » Tue Mar 05, 2019 4:41 am

I an running the latest fw on my 9xr pro .I used a mini and was able to get the bootloader onto the green module ,,The module is like the one on page 2 . I cut the lead and attached the pro mini to the 4 pads and the mini blinked once a second when finished loading, installed module into the pro and and tried to flash the green and blue hex files ..failed each time I tried it..I tried inverting still the same,,proto is set on mult dsm dsm222 ,,auto bind ,it is blank after the word blind ,,I think I read there should b something there

Anyway if you can help me again I would appreciate it

Allen


Post Reply

Return to “RF MODULES”