Taranis Q X7 with X8R not binding

Hardware help and support for the FrSky Taranis
Post Reply
User avatar
vorstfpv
Posts: 5
Joined: Sat Jun 27, 2020 2:24 pm
Country: Sweden

Taranis Q X7 with X8R not binding

Post by vorstfpv » Sat Jun 27, 2020 2:45 pm

Hey and thanks for reading my post!

I know, this problem is full-out on the internet. And I wouldn't be posting this if I didn't try it all.
So hereby my sequence of things I have been going through.

First my settings:
Taranis Q X7
  • Firmware: opentx-x7, version 2.3.9-otx, options crossfire,EU,multimodule,lua,luac
  • Binding: mode XJT D16, CH 1-8 (9ms)
X8R firmware: X8R_ACCST_2.1.0_LBT

I need to power up my receiver via a LIPO, so I press bind on my transmitter, hold in the F/S button on the X8R and then plug in my LIPO and get 2 solid lights. I have both on EU as you see and even bought a second X8R with EU software last week to try again, also 2 solid, even after updating the firmware. No jumper pins installed as I need D16 with telemetry. Tried putting the Taranis at minimum 1m distance as well, but still nothing. I really tried everything that I read and I really don't know anymore what I can be doing wrong. I don't know if it matters but I power it up via my 4-1 QBrain 4x25A ESC that powers up my Illuminati 32 FC (which blinks blue), which in turn powers up the receiver. If I plug in the LIPO without pressing the F/S button it blinks red.

I have attached a messy picture of the setup, maybe someone sees something weird in all the mess. It needs a big clean-up, but first, it needs to work in case I need to re-solder. :) I also added a video of what happens after I press bind, hold the F/S and plugged in the LIPO.

I do really hope that someone sees what I am doing wrong as I have been spending 100€ on receivers and nothing seems to work... I just want this build to be working now before getting another one with the tango 2 pro and crossfire.

IMG_0251.MOV
(6.75 MiB) Downloaded 71 times
IMG_8989.JPG


User avatar
Kilrah
Posts: 10600
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Taranis Q X7 with X8R not binding

Post by Kilrah » Sat Jun 27, 2020 6:26 pm

You probably don't have EU firmware on the radio's IXJT internal module.

User avatar
vorstfpv
Posts: 5
Joined: Sat Jun 27, 2020 2:24 pm
Country: Sweden

Re: Taranis Q X7 with X8R not binding

Post by vorstfpv » Sat Jun 27, 2020 8:46 pm

.
Last edited by vorstfpv on Sat Jun 27, 2020 8:48 pm, edited 2 times in total.

User avatar
vorstfpv
Posts: 5
Joined: Sat Jun 27, 2020 2:24 pm
Country: Sweden

Re: Taranis Q X7 with X8R not binding

Post by vorstfpv » Sat Jun 27, 2020 8:47 pm

Kilrah wrote:
Sat Jun 27, 2020 6:26 pm
You probably don't have EU firmware on the radio's IXJT internal module.
In fact, I have, in the firmware of the X7 I mentioned EU at the options.
I double-checked this by scrolling through the binding modes.
Since D8 is not there it is EU, so I do have EU firmware on the Taranis internal module.

User avatar
MikeB
9x Developer
Posts: 16975
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Taranis Q X7 with X8R not binding

Post by MikeB » Sat Jun 27, 2020 8:54 pm

You have flashed 2.1.0 firmware to the X8R. Have you updated the internal XJT module in the Tx to 2.1.0?

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!


User avatar
vorstfpv
Posts: 5
Joined: Sat Jun 27, 2020 2:24 pm
Country: Sweden

Re: Taranis Q X7 with X8R not binding

Post by vorstfpv » Sat Jun 27, 2020 9:49 pm

MikeB wrote:
Sat Jun 27, 2020 8:54 pm
You have flashed 2.1.0 firmware to the X8R. Have you updated the internal XJT module in the Tx to 2.1.0?

Mike
Ah thanks, but I finally understand it, Kilrah said the same. So I thought flashing the firmware on the Taranis was all but now I see that you should and can also flash the XJT module itself. I totally oversaw that... I am going to try it tomorrow and let you know! But assume indeed my XJT has an old firmware.

User avatar
Kilrah
Posts: 10600
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Taranis Q X7 with X8R not binding

Post by Kilrah » Sat Jun 27, 2020 11:01 pm

The eu option in OpenTx does only one thing, hide the D8 setting.
What is sent only depends on module firmware.

User avatar
vorstfpv
Posts: 5
Joined: Sat Jun 27, 2020 2:24 pm
Country: Sweden

Re: Taranis Q X7 with X8R not binding

Post by vorstfpv » Sun Jun 28, 2020 5:56 pm

A million thanks to you 2 Kilrah and Mike!
After putting the newest firmware on my internal module I got an instant bind.
I knew I missed something small and simple but I just couldn't find out what, thanks a lot!

/Sidney


Post Reply

Return to “FrSky Taranis radio”