Frsky RB-20 Amps and Current telemetry bug?

Cant get your radio to work? General Hardware issues?
Post Reply
Posts: 31
Joined: Mon Feb 03, 2014 10:54 pm
Country: -

Frsky RB-20 Amps and Current telemetry bug?

Post by dsa44 » Sat Nov 09, 2019 4:57 pm

I have an Rx8rPro hooked by sbus into the RB20 on Rx1. I have the S-Port connected to Rx1 SP. I have 2 same LiFe batteries hooked in. Using X10s and openTx 2.2.3

When I discover the telemetry, it discovers all the voltage, amps, currents, etc.

But no matter what I do, swapping batteries, swapping Rx1 and Rx2 inputs, I get bizarre readouts from RB1. As you can see in the little video, it claims RB1 Amps is hitting 23 and the mAh consumed rises astronomically! However, RB2 is showing appropriate usage. I have tried deleting and rediscovering.

There is no servo activity! When I move the servos, RB2 shows the minimal appropriate current, but RB1 looks like it is running like a faucet!!

Tried a different rx also, same thing with X8R. All FW is the latest version.

Any clue here??

Post Reply

Return to “Hardware”