Flow rate correction factors - restart required after modification?

Development & General Chat for the superb openxvario project.

Moderator: rainer

Post Reply
onki
Posts: 39
Joined: Tue May 14, 2013 8:34 am
Country: -

Flow rate correction factors - restart required after modification?

Post by onki » Tue Oct 08, 2019 6:22 am

Hi,

I have done some OXS based flow meters with BMP280 pressure sensor for my friends towplanes.
Now he is trying to adjust the correction factors.
To give you an idea about the real flow rates he has done a series of tests with his two motors.
Idle run was 10 minutes, full power 5 mins to get better statistics:
  • King 100 RV: idle run (150mL) 15 mL/min; Full power: (320mL) 64 mL/min.
  • 3W 80: idle run (150mL) 15 mL/min; Full power (280mL) 56 mL/min.
He made a correction factor set like this:
  • King: 30, 40, 55, 70 mL/min with this factors: 20%, 10%, 0%, -10%
  • 3W: 30, 40, 50, 60 mL/min with the same factors: 20%, 10%, 0%, -10%
He cannot observe changes in the flow rate display after modifying the factors. idle run shows zero, full power flow values is always too high.
Is there a sensor restart required to take over the new correction factors?
Any ideas how to improve the results?

Is there an affordable sensor available with a more suitable, lower measurement range. The current 15-800ml/min sensor (BIOTek) is not really optimal for this application.

Best regards
Onki


Post Reply

Return to “OpenXVario - an open source vario supported by the open source firmwares!!”