flashed X7Q, and now its a brick Help.....

Help with any software/desktop related issues. e.g. companion9x, eePe, etc
Post Reply
homey65
Posts: 7
Joined: Fri Mar 08, 2019 7:34 pm
Country: -

flashed X7Q, and now its a brick Help.....

Post by homey65 » Fri Mar 08, 2019 7:50 pm

Hello to all. I am new to the hobby and already frustrated lol. I have a new X7Q it worked fine out the box. But when I tried to updated it from 2.2.0 to 2.2.3 using the companion via USB, The controller know will not come on or come on in boot mode. in boot mode it shows a blank white screen. When I performed the update, I checked the box check compatibility and waited until it said flashing finished before I disconnected it. Is there a way that I can reset the controller or is it know a brick. Thanks to anyone that can help in advance.


User avatar
Kilrah
Posts: 9882
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: flashed X7Q, and now its a brick Help.....

Post by Kilrah » Fri Mar 08, 2019 8:15 pm

What's the name of the file you flashed?

Are you holding the power button for 2 seconds or so? There was a bug with 2.2.0 where it turned on instantly, but now you need to hold the button for a while to prevent accidental turn on.

homey65
Posts: 7
Joined: Fri Mar 08, 2019 7:34 pm
Country: -

Re: flashed X7Q, and now its a brick Help.....

Post by homey65 » Fri Mar 08, 2019 8:54 pm

open-x7-noheli-lua-en-2.2.3.bin yes I held it for over 20 sec.

homey65
Posts: 7
Joined: Fri Mar 08, 2019 7:34 pm
Country: -

Re: flashed X7Q, and now its a brick Help.....

Post by homey65 » Fri Mar 08, 2019 10:43 pm

OK I figured it out. For those newbies like myself here is what happened and how I fixed it. The mistake that I made was trying to update the X7Q using the companion via usb cable, WITHOUT downloading the computer drivers first. After that mistake the X7Q would not come on, just a blank screen. My computer could not find the drivers online. So I found a copy of the driver on OpenTX. Once I installed the drivers I re flashed the X7Q now every thing is fine, well for now lol. My first lesson in my very very short RC career.

homey65
Posts: 7
Joined: Fri Mar 08, 2019 7:34 pm
Country: -

Re: flashed X7Q, and now its a brick Help.....

Post by homey65 » Sat Mar 09, 2019 5:25 am

OK, that didn't last long lol. Now I just noticed that when I attempt to access the boot loader by holding both trim buttons and then powering on, I only get a blank screen. Is there another download that I need to make? Thanks again in advance for any help.


User avatar
Kilrah
Posts: 9882
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: flashed X7Q, and now its a brick Help.....

Post by Kilrah » Sat Mar 09, 2019 8:09 am

Copy the same firmware file to the radio's SD card, then from the radio's SD browser in the radio settings menu go to it, select it and "flash bootloader".

homey65
Posts: 7
Joined: Fri Mar 08, 2019 7:34 pm
Country: -

Re: flashed X7Q, and now its a brick Help.....

Post by homey65 » Sat Mar 09, 2019 7:26 pm

OK got it , Thank you very much.


Post Reply

Return to “Software”