R9M and R9mm issues

ersky9xr is the port of the er9x firmware to the 9XRPRO radio.
Post Reply
agarabaghi
Posts: 10
Joined: Fri Dec 28, 2018 8:42 pm
Country: -

R9M and R9mm issues

Post by agarabaghi » Sun Dec 30, 2018 5:31 pm

Im having some issues with my R9mm and R9M where its randomly failsafing or disconnecting or getting a voltage spike.

We are just using SBUS + - to hook it up

Here are somethings i have noticed:
1) In betaflight the AUX12 the bar jumps from 1000 to 2400 contantly

https://www.youtube.com/watch?v=x18ET0OlVW4

2) When quad is armed we are hearing a twitch / seeing a voltage spike in the OSD:

https://www.youtube.com/watch?v=Yul-n0kqM1Y

3) The RX leds seems to be doing something weird while binded to the remote (as i can arm and kinda fly until it failsafes or twitched)

https://www.youtube.com/watch?v=kgy2IjB2xko

Im kinda lost as to what the issue could be so any help would be greatly appreciated

EdwardMcRichy
Posts: 34
Joined: Sat Dec 09, 2017 4:31 am
Country: -
Location: Sahuarita Arizona

Re: R9M and R9mm issues

Post by EdwardMcRichy » Fri Jan 04, 2019 3:16 pm

The first thing I would do is update the firmware on the module and the receiver, then report back.
When I'm not flying I'm dreaming of flying, when I'm not dreaming of flying.....I'm asleep

User avatar
Kilrah
Posts: 9786
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: R9M and R9mm issues

Post by Kilrah » Fri Jan 04, 2019 3:37 pm

Seems you have a power problem in your setup and the receiver repeatedly loses power.

agarabaghi
Posts: 10
Joined: Fri Dec 28, 2018 8:42 pm
Country: -

Re: R9M and R9mm issues

Post by agarabaghi » Sat Jan 05, 2019 12:14 pm

It was the firmware. Once we updated everything seems fine now.

I was not able to figure out how to flash the external module using opentx or ersky9xr though and had to use my friends x9d+

In ersky9xr it was saying finding devices but never moved on.

User avatar
MikeB
9x Developer
Posts: 16063
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: R9M and R9mm issues

Post by MikeB » Sat Jan 05, 2019 1:02 pm

When flashing a module you need to keep the module powered off until you get to the finding devices stage. The X9D+ has a software controlled module power switch that does this for you, but the 'PRO does not.
A way of doing this is to start the 'PRO in "maintenance mode", then plug in a 3.5mm jack plug to the trainer socket, then switch the power off. This will keep the radio running, but turn the power to the module off.
Now get to the finding devices stage, then switch the power on and the module will then get powered.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!


agarabaghi
Posts: 10
Joined: Fri Dec 28, 2018 8:42 pm
Country: -

Re: R9M and R9mm issues

Post by agarabaghi » Sat Jan 05, 2019 1:39 pm

ah! i will have to try that. Right now everything is running well but ill be sure to try this next time. Again thank you for your hard work MikeB.

Ive posted in a few other places but is there any bas script for the crossfire micro?

Post Reply

Return to “ersky9xr”