XJT A1 beeping warning setting

erskyTx runs on many radios and upgrade boards
ersky9x was a port of er9x for use on the sky9x board.
Post Reply
vodkabears
Posts: 47
Joined: Thu Aug 23, 2018 5:37 am
Country: Russian Federation
Contact:

XJT A1 beeping warning setting

Post by vodkabears » Fri Dec 28, 2018 8:14 am

Hello everyone. Yesterday I discovered that XJT has a warning beeping if recieved A1 is lower than some threshold, XJT will start annoyingly beeping. https://github.com/betaflight/betaflight/issues/7297 There's a FrSky xSSI menu in radio settings which as far as i understood changes default beeping thresholds for RSSI and TSSI values if set. Is it possible to add a setting for A1 beeping threshold?


User avatar
jhsa
Posts: 18814
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: XJT A1 beeping warning setting

Post by jhsa » Fri Dec 28, 2018 10:03 am

What version oh Ersky9x are you using?
João

Sent from my BLN-L21 using Tapatalk

My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

vodkabears
Posts: 47
Joined: Thu Aug 23, 2018 5:37 am
Country: Russian Federation
Contact:

Re: XJT A1 beeping warning setting

Post by vodkabears » Fri Dec 28, 2018 10:49 am

jhsa wrote:
Fri Dec 28, 2018 10:03 am
What version oh Ersky9x are you using?
João
r221

User avatar
jhsa
Posts: 18814
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: XJT A1 beeping warning setting

Post by jhsa » Fri Dec 28, 2018 2:28 pm

vodkabears wrote:
Fri Dec 28, 2018 8:14 am
There's a FrSky xSSI menu in radio settings which as far as i understood changes default beeping thresholds for RSSI and TSSI values if set
I think those thresholds are only valid for the DJT and DHT modules..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

vodkabears
Posts: 47
Joined: Thu Aug 23, 2018 5:37 am
Country: Russian Federation
Contact:

Re: XJT A1 beeping warning setting

Post by vodkabears » Fri Dec 28, 2018 6:48 pm



User avatar
MikeB
9x Developer
Posts: 16472
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: XJT A1 beeping warning setting

Post by MikeB » Sat Dec 29, 2018 10:01 am

Do you have eepskye on your PC? If so, you could try the following:
Set the XJT into "D" mode using the DIP switches.
Make up a cable to connect a serial port (USB adapter type?) from the PC to the non-Sport telemetry connector on the XJT.
Connect the serial port to the connector and power the XJT on (in the radio is OK).
Run eepskye, select the "Telemetry" menu, then select the "Module" tab. At the bottom right are option to read and set alarm levels. These all work for the DJT module and I thought they did work, or at least some of them, on the XJT module.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
MikeB
9x Developer
Posts: 16472
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: XJT A1 beeping warning setting

Post by MikeB » Sat Dec 29, 2018 8:53 pm

I just tested this and was able to change the alarm setting in the XJT for A1 from eepskye (I didn't try the others).

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

vodkabears
Posts: 47
Joined: Thu Aug 23, 2018 5:37 am
Country: Russian Federation
Contact:

Re: XJT A1 beeping warning setting

Post by vodkabears » Sun Dec 30, 2018 2:52 pm

I couldn't get anything from the module with any state of dip switches powered from either radio or uart adapter 5v. The serial link is working, on the "Screen" tab one of the counters below the "screen" increments when the bound model is on and doesn't when it's off.

P.S. Do I do everything right? I run eePe, open Telemetry -> Telemetry.

User avatar
MikeB
9x Developer
Posts: 16472
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: XJT A1 beeping warning setting

Post by MikeB » Sun Dec 30, 2018 4:28 pm

Yes, open Telemetry->Telemetry, then select the Module tab.
Click the "Start" button, then the "Read Alarms" button. When I did this, nothing appeared to happen as everything was already disabled. To test it was working, I set the A1 value to 6, clicked the "Set Alarms" button, then set the A1 value back to 0 and clicked the "Read Alarms" button, the A1 value went to 6, showing a new value had been written and read back. I then set the A1 value back to 0 and clicked the "Set Alarms" button to put the value to 0 in the module.

It is possible there is an alarm for the RxV value. This is actually different from the A1 value, although the main radio firmware does map RxV to A1 unless there is a real A1 value appearing.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

vodkabears
Posts: 47
Joined: Thu Aug 23, 2018 5:37 am
Country: Russian Federation
Contact:

Re: XJT A1 beeping warning setting

Post by vodkabears » Mon Dec 31, 2018 12:42 pm

Is this setting stored when the module is unpowered? Does this work only for D8 mode? My setup beeps only in D16 mode. Expreimenting with Betaflight Frsky SPI code I found out that it beeps only in D16 mode, when A1 is below 72 out of 255 or 3.7v with 13.3V scaling setting. Is it possible to solve the beeping problem on the TX side? I solved it on the RX side but i don't know when (if) it will be in some release.

User avatar
MikeB
9x Developer
Posts: 16472
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: XJT A1 beeping warning setting

Post by MikeB » Tue Jan 01, 2019 7:38 pm

Those settings are stored in EEPROM.
I just tested my XJT using a bench power supply for a X8R receiver. As soon as the supply for the Rx dropped below about 3.7V the XJT started beeping. We probably need to ask FrSky if there is a way to disable it. Internal modules don't have a beeper so don't show the feature!

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

vodkabears
Posts: 47
Joined: Thu Aug 23, 2018 5:37 am
Country: Russian Federation
Contact:

Re: XJT A1 beeping warning setting

Post by vodkabears » Tue Apr 16, 2019 8:24 pm

Sorry for necro-posting. If there's anybody wondering, the new Betaflight release (4.0) has a fix for this problem. Set frsky_spi_a1_source = CONST and A1 will _always_ be 100 or "5v". This mainly applies for "tiny whoop class" 1S brushed quadcopters for which VBat < 3.7v is a normal operation mode. Never power any genuine frsky hardware with less than 3.7v.


Post Reply

Return to “erskyTx (was ersky9x)”