Assistance with alarm setup

Post Reply
Andywpg
Posts: 5
Joined: Mon Sep 10, 2018 12:29 pm
Country: -

Assistance with alarm setup

Post by Andywpg » Mon Sep 10, 2018 12:40 pm

I recently bought a 9X that I have flashed with ER9X (I’m a little late to this party 🙂) and I need some help setting up an alarm.

For my 2m glider, I use the throttle as spoiler control. Throttle all the way forward is spoilers down (go fast) and all the way back is spoilers up (go slow).

I have setup L1 to be triggered when the throttle is less than 100 AND the throttle switch is on. I then use that to trigger a beep (no voice module).

I have a voice alarm setup for V<VAL with throttle as the input. I have no voice module in the radio. (sorry for the edit, when I wrote the post, I was not at home and was going on memory)

It SORT OF works. I get a double beep when I pass through midpoint in either direction with the throttle. I have figured out how to make it beep on the way down, the way up, or both. The throttle switch controls whether it happens or not.

What I really want is the beep to happen AS SOON as the throttle moves down off 100%. Ideally, while the condition continues, the beep would repeat every 10 seconds.

I realize that none of this may be possible, but I’m hopeful.

Anyone have any ideas?

Thanks for any help.

Andy
Last edited by Andywpg on Mon Sep 10, 2018 11:33 pm, edited 1 time in total.

User avatar
jhsa
Posts: 18022
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Assistance with alarm setup

Post by jhsa » Mon Sep 10, 2018 11:01 pm

I'm not sure I understand your problem. If you want the radio to beep when the throttle is under 100%, then set a voice alarm as
Source - Thr
Function - v<val
Value - +100%
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Andywpg
Posts: 5
Joined: Mon Sep 10, 2018 12:29 pm
Country: -

Re: Assistance with alarm setup

Post by Andywpg » Mon Sep 10, 2018 11:22 pm

jhsa wrote:
Mon Sep 10, 2018 11:01 pm
I'm not sure I understand your problem. If you want the radio to beep when the throttle is under 100%, then set a voice alarm as
Source - Thr
Function - v<val
Value - +100%
That's pretty much exactly what I did. I misspoke about using L1 - I was going from memory. I'm in front of the computer now. I had L1 set up the same way to try to have it trigger the alert. Only problem is, apparently you can't use a logical switch for that. L1 is still in there, its just not used.

Remember, I do not have a voice module.

I have set up voice alarm exactly as you said. The only problem is that the alert doesn't happen when the throttle comes off 100%, it happens as it crosses the midpoint. That's the problem, it's not doing what I expected.

I have attached the model file to this message, if that helps.
Attachments
Spirit.eepm
(1.45 KiB) Downloaded 6 times

User avatar
jhsa
Posts: 18022
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Assistance with alarm setup

Post by jhsa » Mon Sep 10, 2018 11:40 pm

Try setting rate to "10" as you want it played every 10 seconds. do not use BOTH in this case
Also set "Play Source" to "No", as you do not have a voice module.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Andywpg
Posts: 5
Joined: Mon Sep 10, 2018 12:29 pm
Country: -

Re: Assistance with alarm setup

Post by Andywpg » Tue Sep 11, 2018 1:12 am

jhsa wrote:
Mon Sep 10, 2018 11:40 pm
Try setting rate to "10" as you want it played every 10 seconds. do not use BOTH in this case
Also set "Play Source" to "No", as you do not have a voice module.

João
Thanks for your help.

This is getting weird.

I did as you say, and the problem is the same. The alert only happens when the throttle is at the midpoint OR LOWER - I guess the value is zero then. If I have a rate selected (say 3) and I leave the stick at midpoint or lower- it repeats every three seconds.

I also tried setting the value to compare to at 90, just to see if the throttle is being evaluated as less than 100, but same result.

I even tried: |V|<val to see if the absolute value would make any difference - it didn't.

Any other ideas? I've been trying various things, but have come to the conclusion that its not evaluating the expression correctly. Im open to any ideas anyone may have. This is frustrating me.

Thanks again for the help


User avatar
jhsa
Posts: 18022
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Assistance with alarm setup

Post by jhsa » Tue Sep 11, 2018 7:51 am

Ok, let me have a look at your file again, and run a test on my own radio.

By the way, what firmware did you flash to your radio?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
jhsa
Posts: 18022
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Assistance with alarm setup

Post by jhsa » Tue Sep 11, 2018 8:46 am

Ahhhhh, I think I know what is happening. I keep forgetting that some sources in the voice alarms are not displayed in percentage, but in digital steps ranging from -1024 (-100%) to +1024 (100%).
Please insert a value of +1024 instead of 100.

100 will give you a value just above center stick. this matches what you are seeing..

joão
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Andywpg
Posts: 5
Joined: Mon Sep 10, 2018 12:29 pm
Country: -

Re: Assistance with alarm setup

Post by Andywpg » Tue Sep 11, 2018 12:23 pm

jhsa wrote:
Tue Sep 11, 2018 8:46 am
Ahhhhh, I think I know what is happening. I keep forgetting that some sources in the voice alarms are not displayed in percentage, but in digital steps ranging from -1024 (-100%) to +1024 (100%).
Please insert a value of +1024 instead of 100.

100 will give you a value just above center stick. this matches what you are seeing..
That makes perfect sense! I’ll try that when I get home from work.

Thank you! This was driving me crazy.

Andy

User avatar
jhsa
Posts: 18022
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Assistance with alarm setup

Post by jhsa » Tue Sep 11, 2018 12:53 pm

Please let us know if it fixed the issue..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Andywpg
Posts: 5
Joined: Mon Sep 10, 2018 12:29 pm
Country: -

Re: Assistance with alarm setup

Post by Andywpg » Tue Sep 11, 2018 11:15 pm

jhsa wrote:
Tue Sep 11, 2018 12:53 pm
Please let us know if it fixed the issue..

João
Works perfectly! Thank you so much.

Weirdly, though, it doesn't work on the simulator. Not that it matters, because it works where it counts - on the radio.

Thanks again!

Andy

User avatar
jhsa
Posts: 18022
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Assistance with alarm setup

Post by jhsa » Tue Sep 11, 2018 11:28 pm

Good that is working :)
I don't think the simulator can simulate the voice alarms yet

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Post Reply

Return to “er9x model setup”