Pairing RC receiver with FrSky X9E OpenTx 2.2.1

Post Reply
rdesgagn
Posts: 2
Joined: Tue Jul 03, 2018 7:44 pm
Country: -

Pairing RC receiver with FrSky X9E OpenTx 2.2.1

Post by rdesgagn » Tue Jul 03, 2018 8:10 pm

Hello everyone,

I'm trying to pair either a x6r or x8r with my FrSky X9E OpentTX 2.2.1 radio. The only way I can get a successful pairing is if I pair using the D8 mode only instead of D16. Even if I try to pair in D16 with or without telemetry on (CH1-8), the RC receiver red light is solid so no success. I have updated both x6r and x8r to the latest firmware (non-eu of course) from the FrsKy website but still doesn't work.

Does anyone have any idea what could cause that particular issue ?

Thanks,

René

Carbo
Posts: 328
Joined: Fri Aug 02, 2013 6:55 pm
Country: Germany
Location: Freinsheim RP

Re: Pairing RC receiver with FrSky X9E OpenTx 2.2.1

Post by Carbo » Wed Jul 04, 2018 8:45 am

Seems you have different D16 protocols in TX and RX, D8 works, because there is only one. If devices are from Europe, there is a good chance to have LBT firmware installed. To be sure, update your TX (internal XJT) to 170317 FCC (=NoEU).

rdesgagn
Posts: 2
Joined: Tue Jul 03, 2018 7:44 pm
Country: -

Re: Pairing RC receiver with FrSky X9E OpenTx 2.2.1

Post by rdesgagn » Thu Jul 05, 2018 9:31 pm

I've tried pretty much everything (reverting to opentx 2.2.0, trying to pair with eu and non-eu rc receivers, etc...) and didn't work. I had one unopened X9E and I flashed it to opentx2.2.0 and it paired the first time with the non-eu rc receivers I had. I concluded that there is an issue with that Taranis radio and retired it.

Post Reply

Return to “openTx for FrSky radios”