flashing eurgle 9x

The original alternative firmware. Suitable for all 9x based radio control transmitters.
Post Reply
User avatar
stotty1111
Posts: 120
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

flashing eurgle 9x

Post by stotty1111 » Mon Apr 16, 2018 11:38 am

Ok, another modeller approached me yesterday to flash his eurgle 9x, so am currently trying to do it, have downloaded the latest eepe software and mounted it along with a download of er9x m64. cleaned up the pcb pads and the spring loaded contacts on a smartieparts rev 2.1 prog.. board mounted same ran the program to get

=================================================================================
Started AVRDUDE
C:/Program Files (x86)/eePe/avrdude.exe -c usbasp -p m64 -P usb -U eeprom:r:C:/Users/Tony/AppData/Local/Temp/eebackup.hex:i
=================================================================================
avrdude.exe: error: could not find USB device "USBasp" with vid=0x16c0 pid=0x5dc

=================================================================================
AVRDUDE done - exit code 1
=================================================================================
tried other usb leads always the same message

the mainboard is a v14 and I don't think the sck pin and pad line up, presumably a wire link would work?

looking for a little guidance please and sorry to appear to be a 'numpty'

User avatar
jhsa
Posts: 18027
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: flashing eurgle 9x

Post by jhsa » Mon Apr 16, 2018 12:03 pm

It looks like your computer is not seeing the smartieparts programmer. Perhaps you didn't install the drivers for it?
What operating system are you running on your pc?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
stotty1111
Posts: 120
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

Re: flashing eurgle 9x

Post by stotty1111 » Mon Apr 16, 2018 1:13 pm

windows 10 in device manager I have a firmware file, would that be usb driver I seem to remember years ago it was listed as lisub or something similar

have reloaded the smartieparts usb driver again, still get the above message -- with regard to the pc not seeing the board, could that be because the sck pin isn't aligned with the pad?

User avatar
jhsa
Posts: 18027
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: flashing eurgle 9x

Post by jhsa » Mon Apr 16, 2018 1:21 pm

No, that would be another problem.. :(

perhaps you have a so called V1 9x mainboard that has the SCK pad on the wrong pin??
if that is the case then you will have to do some soldering.

Did you try to power the radio ON while trying to read the firmware? if not, please try and see if that error goes away..
Do not try to write anything at this point. try to read the firmware to a file.. Like this it is unlikely that the radio could get bricked.
Only try to write the fw once you are sure all is working

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
stotty1111
Posts: 120
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

Re: flashing eurgle 9x

Post by stotty1111 » Mon Apr 16, 2018 4:31 pm

treied that both off and on, same message as above


User avatar
jhsa
Posts: 18027
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: flashing eurgle 9x

Post by jhsa » Mon Apr 16, 2018 4:46 pm

I don't have windows 10, and I don't want to have it :) so I don't know how to install drivers on it. Apparently, it seems to be an headache. Unfortunately I don't know how to help you with that :(

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
stotty1111
Posts: 120
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

Re: flashing eurgle 9x

Post by stotty1111 » Mon Apr 16, 2018 4:47 pm

Ok, also going to try with an old win 7 laptop, currently charging and updating.

User avatar
jhsa
Posts: 18027
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: flashing eurgle 9x

Post by jhsa » Mon Apr 16, 2018 5:12 pm

Good idea.. Please get the drivers from the smartieparts website..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
stotty1111
Posts: 120
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

Re: flashing eurgle 9x

Post by stotty1111 » Mon Apr 16, 2018 7:35 pm

well that was spectacularly unsuccessfull usb connection not recognised having now retried a small interface as well as the larger version, the small unit is recognised but the large throws up a malfunction warning -- why would that be?I will replace the board tomorrow am and see what happens.
Thanks for suggestions so far!

User avatar
stotty1111
Posts: 120
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

Re: flashing eurgle 9x

Post by stotty1111 » Mon Apr 16, 2018 7:46 pm

ok quickly mounted small board and tried it reading firmware, get this message which is slightly different to the original

=================================================================================
Started AVRDUDE
C:/Program Files (x86)/eePe/avrdude.exe -c usbasp -p m64 -P usb -U flash:r:C:/Users/Tony/Pictures/Scans/abc.hex:i
=================================================================================

avrdude.exe: error: programm enable: target doesn't answer. 1
avrdude.exe: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.


avrdude.exe done. Thank you.


=================================================================================
AVRDUDE done - exit code 1
=================================================================================

this really is it tonight!

User avatar
jhsa
Posts: 18027
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: flashing eurgle 9x

Post by jhsa » Mon Apr 16, 2018 11:17 pm

Ok, progress.. this error tells me that the USBASP is recognized, but the radio doesn't. probably because of that SCK pad being in the wrong place.
We will need a good picture from your radio's mainboard. we need to see to which pin that SCK pad is connected to :o
One other thing. NEVER, BUT NEVER use the -F option as AvrDude suggests.. This can brick your radio.. and we do not want that :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
stotty1111
Posts: 120
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

Re: flashing eurgle 9x

Post by stotty1111 » Tue Apr 17, 2018 6:36 am

Ok, now compared this board with a later version and the sck pad on this board connects to pin 9 when numbered from right hand side, a later board with fried regulator has sck pad connected to pin 6 -- presumably I need to solder a fly lead from pin 6 to the pad sck pad on the smar... board?
Whilst I'm sorting this can you give me a link to the regulator/capacitor repair as well please?
I will get a photo later this morning, the camera is in the car which is currently out shopping!

User avatar
stotty1111
Posts: 120
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

Re: flashing eurgle 9x

Post by stotty1111 » Tue Apr 17, 2018 11:50 am

ok, good enough?
DSCF8140.JPG

User avatar
jhsa
Posts: 18027
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: flashing eurgle 9x

Post by jhsa » Tue Apr 17, 2018 12:42 pm

Yep, pad is on the wrong pin :( This explains the second problem "target doesn't answer".. You will probably need to solder a wire between the resistor connecting to the correct pin, and the smartieparts board.

About the regulator and cap, try Ebay or aliexpress..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
stotty1111
Posts: 120
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

Re: flashing eurgle 9x

Post by stotty1111 » Tue Apr 17, 2018 4:59 pm

Ok that worked - my buddy will be happy come Friday night!
Re the regulator and cap, I already have a selection of each, I am looking for a link to the original repair posting for the locations of the replacement reg and cap, I had it stored on my laptop but a hdd failure meant it has been lost. Would a 0.5amp reg fit the bill for boat based work with the tx or do I need to install a 1.0 - 1.5amp piece

User avatar
jhsa
Posts: 18027
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: flashing eurgle 9x

Post by jhsa » Tue Apr 17, 2018 6:36 pm

I believe the 0.5A regulator is more than enough.. the radio shouldn't take even 100mA :)
Be careful with the pinout of the new regulator. If it was me I would try to find a low dropout regulator. I attached the datasheet for the L4940..
L4940_LDO_Regulator.pdf
(1.51 MiB) Downloaded 31 times

This could also be useful to you.. it is the schematic of the 9x radio.. :)
Turnigy 9X Service Manual.pdf
(179.45 KiB) Downloaded 36 times
João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Post Reply

Return to “th9x”