Horus x12s 'Bricked

Cant get your radio to work? General Hardware issues?
Post Reply
25wood25
Posts: 28
Joined: Sat Aug 11, 2018 5:24 pm
Country: -

Horus x12s 'Bricked

Post by 25wood25 »

A member of my flying club has asked me to try to mend a Frsky x12s that he bought new only about six months ago. From what I understand he tried to load OpenTX onto the radio but did not make a backup of the original FROS system. The transmitter is completely ‘black screened’ only the charging light is on when charger plugged in. I have managed to ‘wake up’ the tranny by downloading the Open TX firmware to an SD card using Companion software. Any help to return the tranny to the frsky original software would be appreciated .

I have managed to upload a dfu file to the tranny using companion. Held the power button down, Updating started, Note- Flash done, 'welcome to HorUs'. Then downloaded the latest bin file eu1503 frtx to an sd card did an update so the tranny is now reporting
Hardware X12S EU14
Software 1.5.03
Unfortunately the opening screen is not the expected HORUS splash screen but when the tranny is switched on it goes straight to 'create model'. When I try to create the first model it asks me to load and then displays a dialog box 'config file is not exist' . CANNOT GET PAST THIS. I can get into the 'SYSTEM' 'MODEL' And 'Telemetry' screens but cannot get past 'config file is not exist' message. Help I've been on this for too long!

User avatar
Kilrah
Posts: 11109
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Horus x12s 'Bricked

Post by Kilrah »

Connect the radio via USB and copy the flash files from the FrSky website onto the internal memory drive.
User avatar
OctavioS
Posts: 660
Joined: Sun Aug 17, 2014 11:54 pm
Country: Portugal
Location: Madeira

Re: Horus x12s 'Bricked

Post by OctavioS »

HI, today when installing edgetx 2.10 on my x12s the flash process stoped showing the progress bar ojn the same place for some 3 hours, then it went black due to empty battery, so i thnik, and now its completly dead. Not even detect by pc. Any help would be appreciated, thx.
2x - Turnigy 9X with 9xtreme board;
2x - Turnigy 9XRpro ;
Frsky Taranis & Taranis +;
Horus x10s;
Horus x12s;
Radiomaster TX16S Max mark II.
User avatar
MikeB
9x Developer
Posts: 18014
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Horus x12s 'Bricked

Post by MikeB »

I assume you have now charged the battery!
Are you saying that if you plug the USB in with power off, the PC does not detect a DFU device?

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!
User avatar
OctavioS
Posts: 660
Joined: Sun Aug 17, 2014 11:54 pm
Country: Portugal
Location: Madeira

Re: Horus x12s 'Bricked

Post by OctavioS »

Yes Mike, that's the case. Battery charged now. Tried different cables now and still the same. Disassembled the radio and removed the battery, plugged back in and its still dead.
2x - Turnigy 9X with 9xtreme board;
2x - Turnigy 9XRpro ;
Frsky Taranis & Taranis +;
Horus x10s;
Horus x12s;
Radiomaster TX16S Max mark II.

User avatar
MikeB
9x Developer
Posts: 18014
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Horus x12s 'Bricked

Post by MikeB »

My guess is there is a broken connection from the USB connector, most likely the 5V power from the USB as this should power the Tx when in bootloader mode, so when you were flashing it should not have gone off due to a flat battery.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!
User avatar
OctavioS
Posts: 660
Joined: Sun Aug 17, 2014 11:54 pm
Country: Portugal
Location: Madeira

Re: Horus x12s 'Bricked

Post by OctavioS »

Hopefully you are right. Just ordered one usb board. Ill update, as soon as i get it, in 1 to 2 months, most likely.
2x - Turnigy 9X with 9xtreme board;
2x - Turnigy 9XRpro ;
Frsky Taranis & Taranis +;
Horus x10s;
Horus x12s;
Radiomaster TX16S Max mark II.

Post Reply

Return to “Hardware”