ERSKYTx (was ersky9x) Questions

erskyTx runs on many radios and upgrade boards
ersky9x was a port of er9x for use on the sky9x board.
User avatar
MikeB
9x Developer
Posts: 17978
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: ERSKYTx (was ersky9x) Questions

Post by MikeB »

I've posted a new test version for all radios.
There are now 8 flight modes available (was 7).
New feature: INPUTS. These are like the inputs of openTx/edgeTx. You still have the DR/EXPO menu, and this still functions and is an easy way to handle triple rates and expo on the sticks. INPUTS provides similar functionality for the sticks, but also provides the same for other sources (e.g. pots/sliders).
INPUTS are accessed from the mixer option. The popup that showed Mixer and Templates now also shows Inputs.
Inputs are not implemented on the original SKY board as there isn't enough flash space.

On radios with an encoder wheel, there is some acceleration when changing values, so moving the encoder fast results in larger changes.

Because each model memory is now larger, eepskye has changed to handle the larger size, as well as handling the INPUTS functionality. A new eepskye.exe is included.

Before using this test version, please backup your existing models and make sure you have a copy of the existing firmware in case you need to replace that. Also, please keep a copy of the existing eepskye.exe before you overwrite it with the one here.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

sammieB
Posts: 4
Joined: Tue Feb 06, 2024 4:24 pm
Country: -

Re: ERSKYTx (was ersky9x) Questions

Post by sammieB »

Hi all!

I hope this is the right location to ask my question.

I have a 9XR PRO and flashed r225, and I have issues running scripts. I tried to run ELRSv2.bas from the main "Run Script" menu, and it seems it resets as I can hear the welcome voice again. (the file was put in /SCRIPTS)

Then I tried inav2.bas (that I put in /SCRIPTS/TELEMETRY): from Telemetry->Custom->Display2->Script, as soon as I enter the name and want to close the menu, then it resets, I hear the welcome voice and I'm back to the default menu.

Is there something I'm doing wrong?

Thanks!

SammieB
User avatar
MikeB
9x Developer
Posts: 17978
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: ERSKYTx (was ersky9x) Questions

Post by MikeB »

I've released r226 that should fix the problem.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!
sammieB
Posts: 4
Joined: Tue Feb 06, 2024 4:24 pm
Country: -

Re: ERSKYTx (was ersky9x) Questions

Post by sammieB »

Hi Mike, thank you very much for your prompt answer.

I tried r226 and observed the following:

-for some reason now there's no binding anymore between the RX and the TX! (the light on the RX keeps blinking slowly until it eventually ends in WiFi mode)
-when I run the ELRSv2.bas script, the display shows "Waiting for other devices..." or something like that, then nothing else happens

Is there something I need to try or do to be able to use that r226?

Thank you again!
User avatar
MikeB
9x Developer
Posts: 17978
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: ERSKYTx (was ersky9x) Questions

Post by MikeB »

Do you know what version you had before you flashed r225?
Did r225 bind OK?

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

sammieB
Posts: 4
Joined: Tue Feb 06, 2024 4:24 pm
Country: -

Re: ERSKYTx (was ersky9x) Questions

Post by sammieB »

Yes, r225 was binding OK, and when I rolled back to r225 it still binds ok.

And indeed I had r225 before I flashed r226.

Edit: reading your question again, before r225 I most likely had a r220 (and no ELRS module by then, I just changed the external module)
User avatar
MikeB
9x Developer
Posts: 17978
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: ERSKYTx (was ersky9x) Questions

Post by MikeB »

This is very odd. I've compared the two, ersky9xr_rom.bin files (r225 and r226) and the only differences are in the version text and two places containing the fix for the script not running.
So the executable code for everything else, like binding, is exactly the same, the files are exactly the same length and just 13 bytes are different.
I've also downloaded the release file and checked that only has the changes I describe.
Perhaps just download ersky9xr_rom.bin again and re-flash it.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!
sammieB
Posts: 4
Joined: Tue Feb 06, 2024 4:24 pm
Country: -

Re: ERSKYTx (was ersky9x) Questions

Post by sammieB »

It's working! I downloaded manually the file from er9x.com instead of flashing the file that got suggested by eepskye, and it's now working. Don't know finally which file got flashed prior to this....

Well, anyway, happy ending. Thank you so much!

Edit: I opened the previous bin downloaded by eepskye (r425) and it also indicates r226 in the binary itself (I was looking for the string "VERS:"). That's confusing ... maybe something fishy in eepskye?

Post Reply

Return to “erskyTx (was ersky9x)”