New X10s Express giving very low power

Hardware help and support for the FrSky Horus. (not yet released)
Post Reply
jwcalvert
Posts: 3
Joined: Thu Jul 05, 2018 3:35 pm
Country: -

New X10s Express giving very low power

Post by jwcalvert »

I just bought a new FrSky X10S Express to replace my aging Taranis X9D+.

I flashed the new radio with EdgeTX 2.8.4 using x10-access-v2.8.4.bin
I also flashed its RF module with ISRM-S-X10E_2.1.6.frsk

When I do a " range " check on a favourite airplane, I get very poor power and signal loss of signal at about 36 m distance.
By loss of signal, I mean the control surface actually stop moving intermittently.
I tested using both the internal and external antennas, no difference.

My airplane uses an X8R flashed with X8R_ACCST_2.1.0.bin

Then, I bound the same airplane to my old Taranis X9D+, I get great signal out to almost 50 m distance and never any loss of signal.
Both radios bind to the airplane instantly, no issues.

So, my new X10s Express has some sort of signal power issue.
Can anyone give me some tips as to remedy this.

I can't fly with this new radio.
Thanks

User avatar
Kilrah
Posts: 11105
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: New X10s Express giving very low power

Post by Kilrah »

Since it's new I'd get it replaced under warranty.
jwcalvert
Posts: 3
Joined: Thu Jul 05, 2018 3:35 pm
Country: -

Re: New X10s Express giving very low power

Post by jwcalvert »

Problem solved: Receiver was faulty but did not look like that at first.

Post Reply

Return to “FRSky Horus radio”