9xr and Xjt not communicating

Hardware Support for the 9XR
Post Reply
cbronson
Posts: 13
Joined: Sun Nov 06, 2016 6:56 pm
Country: -

9xr and Xjt not communicating

Post by cbronson » Sun Nov 06, 2016 7:13 pm

I have been reading all day and i cant find the answer so if this seems like a "dumb" question please forgive me but i am only trying to save time and not sit in front of the PC for endless hours pouring through posts that lead me nowhere or have nothing to do with my problem in particular.

I have a 9xr (not pro)(running opentx-r2940) with a xjt module. On my craft i have a x4r sb RX and i cannot get the two to communicate. I have found a few videos and followed them to the point where the guide says to put my radio into pxx mode. My 9xr does not have that option. I only see ppm,ppm sim and ppm16, no of which seem to work . So it seems that I need to change firmware.( I ordered the Usb asp device today). At this point i am just wondering if there is a recommended or "best" firmware . I have read that ER9x works but I am not sure about OpenTx and which version works best.

If I am right and i do need to change firmware please give me your recommendation of which you suggest. TIA -C.F.Bronson

PS. IF I am wrong and missing something obvious please feel free to flame me until your little heart is content (as long as you include a solution in your rant) :roll:

User avatar
Kilrah
Posts: 9602
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: 9xr and Xjt not communicating

Post by Kilrah » Sun Nov 06, 2016 7:16 pm

Your receiver should work with what you currently have. BUT you might have mismatched firmwares on the XJT and receiver. Where and when did you buy them from? Devices bought in the EU and in the rest of the world are not compatible out of the box.

cbronson
Posts: 13
Joined: Sun Nov 06, 2016 6:56 pm
Country: -

Re: 9xr and Xjt not communicating

Post by cbronson » Sun Nov 06, 2016 7:29 pm

Hi there... thanks for the fast reply. I bought them separately both from american dealers. Both this year though i guess its hard to say where they originated. Which mode should i have the TX in if PXX is not available?

User avatar
Kilrah
Posts: 9602
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: 9xr and Xjt not communicating

Post by Kilrah » Sun Nov 06, 2016 7:36 pm

PPM would at least work, as long as the DIP switches on the module are set right and you use the button for binding.

cbronson
Posts: 13
Joined: Sun Nov 06, 2016 6:56 pm
Country: -

Re: 9xr and Xjt not communicating

Post by cbronson » Sun Nov 06, 2016 8:12 pm

I have tried all day and cannot get it. I Have systematically tried every combination of settings on the TX, module , and configurator. I guess Ill just have to wait for the asp tool and try new firmware.


cbronson
Posts: 13
Joined: Sun Nov 06, 2016 6:56 pm
Country: -

Re: 9xr and Xjt not communicating

Post by cbronson » Sun Nov 06, 2016 8:13 pm

Kilrah wrote:PPM would at least work, as long as the DIP switches on the module are set right and you use the button for binding.
PPM doesnt work at all. I dont know what dip settings should to make this RX read ppm,so i tried all three and got nothing.

User avatar
Kilrah
Posts: 9602
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: 9xr and Xjt not communicating

Post by Kilrah » Mon Nov 07, 2016 5:56 am

DIPs are set depending on receiver type, not input signal type. For an X4R that's both DIPs down.

You can try to flash er9x, since OpenTX does not support PXX on the 9XR. Note that no models or settings can be carried over if you do so, and if the module does not work with PPM it is likely not to change anything, the problem must be somewhere else.

cbronson
Posts: 13
Joined: Sun Nov 06, 2016 6:56 pm
Country: -

Re: 9xr and Xjt not communicating

Post by cbronson » Sat Nov 19, 2016 1:18 am

OK so i found out a few new things and i tried a few things. First of all my FC doesn't support ppm at all so thats out. So i got the usbasp tool stick and downloaded eepe and the drivers and the er9x firmware. The driver installation went ok but when I tried to read the flash memory from the TX nothing happens. A window pops up and it is titled avrdude- read eprom from tx and its blank. I tried writing the new firmware too ..same thing . A window pops up but nothing happens. What did i miss?

User avatar
jhsa
Posts: 18007
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9xr and Xjt not communicating

Post by jhsa » Sat Nov 19, 2016 1:32 am

Check the path to Avrdude.exe in the "Burn Menu/configure/avrdude location".
Point it to eepe's installation folder.. That is where avrdude is installed.
Do a read before you try to write.. Do not write anything if the read wasn't successful.
João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

cbronson
Posts: 13
Joined: Sun Nov 06, 2016 6:56 pm
Country: -

Re: 9xr and Xjt not communicating

Post by cbronson » Sat Nov 19, 2016 1:47 am

checked that definitely stumbled across that problem already. The path was incorrect and I received an error message that AVR dude was not found. I fixed that issue still no joy

User avatar
jhsa
Posts: 18007
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9xr and Xjt not communicating

Post by jhsa » Sat Nov 19, 2016 1:56 am

What settings do you have in the burn menu?
What chip does the radio have? Atmega 64 or 128?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

cbronson
Posts: 13
Joined: Sun Nov 06, 2016 6:56 pm
Country: -

Re: 9xr and Xjt not communicating

Post by cbronson » Sat Nov 19, 2016 2:45 am

its the 9xr not pro so i think that they are all 64 chips (think). In the menu i set it up like a video suggested. Port :usb - MCU:m64 programmer: usbasp and my avrdude pathway. The only thing that bothers me is that NOTHING happens when the read window pops up. No warnings or errors or anything. I guess i could have the drivers messed up ? thanks for the help sir.

User avatar
jhsa
Posts: 18007
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9xr and Xjt not communicating

Post by jhsa » Sat Nov 19, 2016 8:14 am

As far as I remember, only the very first 9XR radios had the m64. Then they started making them with the m128.

I have seen that problem before but can't remember what the solution was :(

Please go to http://www.er9x.com and download and install the latest eepe

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

cbronson
Posts: 13
Joined: Sun Nov 06, 2016 6:56 pm
Country: -

Re: 9xr and Xjt not communicating

Post by cbronson » Sat Nov 19, 2016 1:03 pm

I'm definitely running the latest version of eepe. I already Uninstalled and reinstalled. Double checked driver..I'm at a loss for what else it could be. . I will check and see which mcu I have. We'll see if changing that option helps. Thanks for trying. I hope someone remembers sooner or later. I really don't wanna buy a new tx just because I can't get this to flash.

User avatar
MikeB
9x Developer
Posts: 15709
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: 9xr and Xjt not communicating

Post by MikeB » Sat Nov 19, 2016 1:54 pm

When you select "Read Memory from Tx", do you still get a window popup that stays blank?
If not, what does it report?
If it disappears before you can read it, go to the "Burn" menu and select "Review Output" to see it.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

cbronson
Posts: 13
Joined: Sun Nov 06, 2016 6:56 pm
Country: -

Re: 9xr and Xjt not communicating

Post by cbronson » Sat Nov 19, 2016 2:18 pm

Hey Mike, thanks for the reply. If I select read or write to/from tx, the window pops open but nothing happens. The window stays open indefinitely I suppose. I've left it alone for ten minutes or so while searching and reading and there was no change. No text or anything inside the window.

User avatar
MikeB
9x Developer
Posts: 15709
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: 9xr and Xjt not communicating

Post by MikeB » Sat Nov 19, 2016 7:01 pm

What settings do you have in the "Burn|Configure menu for:
AVRDUDE location?
Programmer?
mcu?
Port?

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

cbronson
Posts: 13
Joined: Sun Nov 06, 2016 6:56 pm
Country: -

Re: 9xr and Xjt not communicating

Post by cbronson » Sat Nov 19, 2016 9:02 pm

cbronson wrote:its the 9xr not pro so i think that they are all 64 chips (think). In the menu i set it up like a video suggested. Port :usb - MCU:m64 programmer: usbasp and my avrdude pathway. The only thing that bothers me is that NOTHING happens when the read window pops up. No warnings or errors or anything. I guess i could have the drivers messed up ? thanks for the help sir.

cbronson
Posts: 13
Joined: Sun Nov 06, 2016 6:56 pm
Country: -

Re: 9xr and Xjt not communicating

Post by cbronson » Sat Nov 19, 2016 9:03 pm

I'm at work atm but when I get home I'm going to try the 128 setting. I thought I had a m64 but I could definitely be wrong.

cbronson
Posts: 13
Joined: Sun Nov 06, 2016 6:56 pm
Country: -

Re: 9xr and Xjt not communicating

Post by cbronson » Sun Nov 20, 2016 12:14 am

Update: Switched settings to 128 ..no joy

User avatar
MikeB
9x Developer
Posts: 15709
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: 9xr and Xjt not communicating

Post by MikeB » Sun Nov 20, 2016 9:16 am

The setting for the Avrdude location should include the filename e.g.
C:/Progs/eepe/avrdude.exe
If you just have something like:
C:/Progs/eepe
You get the result you are describing.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

cbronson
Posts: 13
Joined: Sun Nov 06, 2016 6:56 pm
Country: -

Re: 9xr and Xjt not communicating

Post by cbronson » Sun Nov 20, 2016 1:37 pm

I had the pathway to an avrdude file in my blheli folder because I didnt think I should have to move it. wrong. I moved it , it works. Thanks a ton for the help guys.

User avatar
jhsa
Posts: 18007
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9xr and Xjt not communicating

Post by jhsa » Sun Nov 20, 2016 3:08 pm

;) :)
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Post Reply

Return to “Turnigy 9XR radio”