LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Hardware Support for the 9XR
Post Reply
gisjoe
Posts: 8
Joined: Mon Feb 01, 2016 7:08 pm
Country: -

LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Post by gisjoe » Thu Feb 11, 2016 8:24 pm

I am experiencing an issue with my Turnigy 9XR PRO, in so much as the radio battery low audible warning keeps repeating and the voltage displayed is 0.6V (see attached photo). At first I thought the battery needed recharging, but having recharged the battery I am still experiencing the problem even though 11V is being recorded with a multimeter.

I have trawled the internet and have been unable to find any information as to what may be causing this.

I have made tests based on feedback from else where (Ruling out the battery then one of the voltage regulators may of failed - this is also
very common particularly with the older 9X when the battery is accidentally reversed (I have not reversed the battery as the plug connection does not allow this). I have not come across such a problem with the Pro and to be honest I 'd have to look at a board to see where the regs are). I have now tested the voltage onto the first board of my 9XR to eliminate possible battery issues and I am getting over 11 volts.

I have now checked the voltage regulator and getting 4.53 volts and there is no sign of overheating or damage (see attached file). This leads me the think that maybe an IC has become faulty on the mother board that checks the voltage of the battery.

Any ideas what would cause the unit to only display 0.6V on the display - Hobby King help was limited so I now feel I am screwed with this
transmitter.
Attachments
Voltage_Regulator_Check.png
Battery warning Low 0.6V.png

User avatar
MikeB
9x Developer
Posts: 15716
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Post by MikeB » Thu Feb 11, 2016 11:39 pm

Please go to the DIAGANA menu and let us know what the two values are beside the A8 label.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

gisjoe
Posts: 8
Joined: Mon Feb 01, 2016 7:08 pm
Country: -

Re: LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Post by gisjoe » Fri Feb 12, 2016 7:04 am

Hi Mike The display shows the following - A8 05D2 0.6v

User avatar
jhsa
Posts: 18013
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Post by jhsa » Fri Feb 12, 2016 8:40 am

If any of the regulators had failed your radio wouldn't work..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
MikeB
9x Developer
Posts: 15716
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Post by MikeB » Fri Feb 12, 2016 9:01 am

The 05D2 indicates all the internal measurements are OK.
I'll look into why it reports 0.6V.
As a test, while on the DIAGANA display, press DOWN so the 0.6v is highlighted, then press MENU so the 0.6v highlight is flashing.
Now press and hold LEFT. This will adjust the calibration and may get the voltage displayed correctly.

Also, what version of the firmware are you using?

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!


gisjoe
Posts: 8
Joined: Mon Feb 01, 2016 7:08 pm
Country: -

Re: LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Post by gisjoe » Sat Feb 13, 2016 9:38 pm

When the 0.6v hightlight is flashing it is not possible to adjust the display from 0.6V. However I notice the the digits next to A8 changes to 05CF then when the display back light automatically turns of it then changes to 05D1. hope this helps.

User avatar
MikeB
9x Developer
Posts: 15716
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Post by MikeB » Sat Feb 13, 2016 9:49 pm

Please tell us which version of the firmware you are using (see the VERSION menu).

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

gisjoe
Posts: 8
Joined: Mon Feb 01, 2016 7:08 pm
Country: -

Re: LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Post by gisjoe » Sun Feb 14, 2016 9:06 pm

version = V.3309-Mike

User avatar
MikeB
9x Developer
Posts: 15716
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Post by MikeB » Sun Feb 14, 2016 9:21 pm

What's on the SVN line please? Currently er9x is at r820. (Edit: I should have said ersky9x is at r218).
I believe there was a version that had an arithmetic overflow that caused the sort of problem you describe. The 05CF/05D1 are the raw measurement of the voltage and look correct.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

gisjoe
Posts: 8
Joined: Mon Feb 01, 2016 7:08 pm
Country: -

Re: LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Post by gisjoe » Mon Feb 15, 2016 8:49 am

SVN: ersky9x-r202
If the arithmetic overflow is causing this, is there a fix for it?

User avatar
jhsa
Posts: 18013
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Post by jhsa » Mon Feb 15, 2016 9:01 am

You have a quite old version. Please update to the latest. Go to www.er9x.com and download the latest and install..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

gisjoe
Posts: 8
Joined: Mon Feb 01, 2016 7:08 pm
Country: -

Re: LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Post by gisjoe » Mon Feb 15, 2016 8:14 pm

I am now getting issues that when I try and connect the TX to the USB of my PC and try to read the memory from the TX I get the message 'Tx Disk Not Mounted'. I have checked the card is fully inserted into the card holder of the TX and rebouted PC (just in case) and the issue is still there. Also the screen of the TX just says 'Connecting..' and doesn't change from this.

Any ideas why the TX will not finish connecting?
Attachments
Tx Disk Not mounted.png

gisjoe
Posts: 8
Joined: Mon Feb 01, 2016 7:08 pm
Country: -

Re: LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Post by gisjoe » Mon Feb 15, 2016 8:37 pm

Finally managed to connect - the plug in the bottom of the TX needed to be held in tight to make connection.
it is now at version V.3527 - Mike and SUN: ersky9x-r218
The voltage now displaying on the ANA screen against A8 0652 3.6v - so its an improvement.
I am now going to charge battery overnight to full charge and see what reading I get tomorrow.

Think I might finally be getting somewhere.

User avatar
MikeB
9x Developer
Posts: 15716
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Post by MikeB » Mon Feb 15, 2016 10:37 pm

Try adjusting the setting as described above, except this time use the RIGHT key to increase the reading. You probably have left it at the lowest setting. There is quite a large range of adjustment.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

gisjoe
Posts: 8
Joined: Mon Feb 01, 2016 7:08 pm
Country: -

Re: LOOKING FOR HELP AND ADVICE ABOUT MY TURNIGY 9XR PRO RADIO TRANSMITTER MODE 2

Post by gisjoe » Tue Feb 16, 2016 8:18 pm

Success - With the battery fully charged I have now adjusted the voltage reading on the TX to the same as the voltage measured on my multi-meter (12.3 V). Many thanks Mike & João for all the support in getting my TX back in working order. :)

Post Reply

Return to “Turnigy 9XR radio”