Weird Programming problems....

Hardware Support for the 9XR
Post Reply
jt41time
Posts: 4
Joined: Sat Sep 20, 2014 5:19 am
Country: -

Weird Programming problems....

Post by jt41time » Wed Sep 06, 2017 3:47 am

So I'm trying to upgrade to opentx 2.2...... I have a newish usbasp. So, i hook it up. and try to flash. It starts to read. reads great. Then it goes into the next step.... target failed to answer...... So i unplug the usb, plug it back in, and try again. it reads just fine..... then again, it fails to answer. i have tried many different things using my usbasp on, and it works on the first try, but never again till i unplug it. and plug it back in.
So it will not program right and im getting eeprom errors. I had to force the hex file using command line.... I have searched and searched, no one else seems to have this problem...... Help me plz.....

Thank you
justin

User avatar
bob195558
Posts: 1891
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: Weird Programming problems....

Post by bob195558 » Tue Nov 21, 2017 11:23 pm

I do not think you can use opentx 2.2 on an old 9xr radio.

Look here for er9x firmware: (http://www.er9x.com/).

Bob B.
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
3D Printing: (http://openrcforums.com/forum/viewforum.php?f=85)

User avatar
MikeB
9x Developer
Posts: 15716
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Weird Programming problems....

Post by MikeB » Tue Nov 21, 2017 11:38 pm

This is a problem that has been seen before.
If you use eepe to flash firmware (it may be er9x or openTx), there is an option to "Disable Pre-Read", to get round the problem.
I just had a look in Companion 2.2, but I couldn't find a similar setting, there might be one though.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

Post Reply

Return to “Turnigy 9XR radio”