Binding issue: 9XR + IRX4+ + Flysky Quad

Hardware Support for the 9XR
Post Reply
Posts: 2
Joined: Sat Jan 15, 2022 7:35 am
Country: -

Binding issue: 9XR + IRX4+ + Flysky Quad

Post by AntaresAdroit » Sat Jan 15, 2022 8:11 am

Hey there. I'm having trouble binding a Flysky receiver to my transmitter. The setup is as follows:

Eachine Trashcan75 (Flysky version)
CrazyBee Pro V2.0 F4FS Flight Controller With Integrated receiver
Betaflight / CRAZYBEEF4FS (C4FS) 4.0.6 Sep 1 2019 / 00:27:23 (2a64051a2) MSP API: 1.41
SPI Bus Receiver Provider Setting: A7105_FLYSKY

Radio TX Module: iRangeX IRX4+
Firmware Info (I just updated it):
Multi Firmware Version: (STM32F1)
Firmware Target: STM32F103CB (128KB)
Expected Channel Order: AETR
Telemetry Type: OpenTX or erSkyTx (MULTI_TELEMETRY)
Invert Telemetry Enabled: True
Flash from Radio Enabled: True
Bootloader Enabled: True
USB Serial Support: False
Serial Debug Enabled: False
EEPROM Global ID: 0x323E3E92

Controller: Turnigy 9XR with ATMEGA128A microcontroller
Vers: V1.1748-Mike
Date: 30.11.2016
Time: 13:41:21
Sun: er9x-r820
Mod: FRSKY 128
(It's been a while since I installed it, but I'm pretty sure I got it from

When I put the quad into bind mode (I've used both its bind button and the betaflight cli command to do this), the indicator LEDs begin blinking as expected. In the Protocol menu for the model on the radio, I have the protocol and type options both set to "Flysky" and then I select the "Bind" option. When I do this, the indicator LEDs on the quad immediately return to the unbound blinking state (rather turning solid as they should when properly bound) and the controller just sits there with "BINDING" on the screen. I've tried all 4 "Type" options on my radio ("Flysky", "V9x9", "V6x6", and "V912") and they all behave the same way. I'm out of ideas to try at this point. I've used this radio with an Radiomaster R81 FrSky compatible receiver on another quad, and I vaguely remember having some similar issues trying to get it to bind the first time until it finally just worked. Short of sacrificing a chicken, does anyone have any suggestions? This is a used drone and I presume it was previously bound to another radio. Is there some unbind procedure I needed?

Posts: 2
Joined: Sat Jan 15, 2022 7:35 am
Country: -

Re: Binding issue: 9XR + IRX4+ + Flysky Quad

Post by AntaresAdroit » Sun Jan 16, 2022 2:23 am

I couldn't get regular Flysky to work, but the firmware and flight controller board support "FlySky AFHDS 2A" (which uses the same RF chip, apparently), so I selected that in the BetaFlight configurator and I finally found it in the radio options in ER9x (it's called "AFHD2S" and is the last named option on the list). That seems to be working well.

This might be obvious to a lot of people, but I wasn't aware of the documentation here, which was helpful: ... ky-afhds2a

Post Reply

Return to “Turnigy 9XR radio”