Linux Taranis x9d plus dont work

Hardware help and support for the FrSky Taranis
Post Reply
skami
Posts: 4
Joined: Tue Feb 09, 2016 4:58 pm
Country: -

Linux Taranis x9d plus dont work

Post by skami » Tue Feb 09, 2016 5:08 pm

Hello! I've came to buy a frsky x9d+.

I would like to connect it to my PC to set up it with companion21. But impossible to make the connection ok...

with a lsusb :

Code: Select all

Bus 003 Device 009: ID 0483:5720 STMicroelectronics STM microSD Flash Device
and my problem with dmesg:

Code: Select all

[ 4651.951644] usb 3-1.6: new full-speed USB device number 9 using ehci-pci
[ 4652.046675] usb 3-1.6: New USB device found, idVendor=0483, idProduct=5720
[ 4652.046680] usb 3-1.6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4652.046682] usb 3-1.6: Product: FrSky Taranis Bootloader
[ 4652.046684] usb 3-1.6: Manufacturer: FrSky
[ 4652.046686] usb 3-1.6: SerialNumber: 00000000001B
[ 4652.048445] usb-storage 3-1.6:1.0: USB Mass Storage device detected
[ 4652.048663] scsi host12: usb-storage 3-1.6:1.0
[ 4674.182780] usb 3-1.6: reset full-speed USB device number 9 using ehci-pci
[ 4689.262323] usb 3-1.6: device descriptor read/64, error -110
[ 4704.445913] usb 3-1.6: device descriptor read/64, error -110
[ 4704.622008] usb 3-1.6: reset full-speed USB device number 9 using ehci-pci
[ 4719.701556] usb 3-1.6: device descriptor read/64, error -110
[ 4734.885127] usb 3-1.6: device descriptor read/64, error -110
[ 4735.061221] usb 3-1.6: reset full-speed USB device number 9 using ehci-pci
[ 4740.471899] usb 3-1.6: device not accepting address 9, error -32
And when i run C21, i try to read setting from radio, but nothing happen.

A last thing, my radio block on USB connected page same when i unplug it :/ I must unplug lipo and reboot ...

Any help ? udev rules?


skami
Posts: 4
Joined: Tue Feb 09, 2016 4:58 pm
Country: -

Re: Linux Taranis x9d plus dont work

Post by skami » Tue Feb 09, 2016 5:35 pm

After add user to dialout group and set udev rules..

Code: Select all

[   83.053893] usb 3-1.5: new full-speed USB device number 3 using ehci-pci
[   83.148984] usb 3-1.5: New USB device found, idVendor=0483, idProduct=5720
[   83.148989] usb 3-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[   83.148991] usb 3-1.5: Product: FrSky Taranis Bootloader
[   83.148993] usb 3-1.5: Manufacturer: FrSky
[   83.148995] usb 3-1.5: SerialNumber: 00000000001B
[   83.173153] usb-storage 3-1.5:1.0: USB Mass Storage device detected
[   83.173254] scsi host10: usb-storage 3-1.5:1.0
[   83.173781] usbcore: registered new interface driver usb-storage
[   83.175943] usbcore: registered new interface driver uas
[  104.803025] usb 3-1.5: reset full-speed USB device number 3 using ehci-pci
[  119.881620] usb 3-1.5: device descriptor read/64, error -110
allways not working :x

User avatar
kalle123
Posts: 831
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: Linux Taranis x9d plus dont work

Post by kalle123 » Tue Feb 09, 2016 5:50 pm

WHAT LINUX ???? WHAT HARDWARE ????

skami
Posts: 4
Joined: Tue Feb 09, 2016 4:58 pm
Country: -

Re: Linux Taranis x9d plus dont work

Post by skami » Tue Feb 09, 2016 6:21 pm

Sorry for less infos...

Im running ubuntu 15.04 but i've try also on a arch system. My mb is an intel dz77ga 70k.

i tried this without results... https://paulphilippov.com/articles/how- ... ress-error

User avatar
kalle123
Posts: 831
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: Linux Taranis x9d plus dont work

Post by kalle123 » Tue Feb 09, 2016 6:39 pm

No other problem? USB stick, external HDD working?
Try other usb port, try other USB cable.

Can you try on other computer, to see, if there is a problem with Taranis or with Ubuntu? Or do you have dual boot?

Man, you have to give (MUCH!) information. No information = no help possible

br


skami
Posts: 4
Joined: Tue Feb 09, 2016 4:58 pm
Country: -

Re: Linux Taranis x9d plus dont work

Post by skami » Tue Feb 09, 2016 6:49 pm

Usb works good any problems like this..

I'm running a multi boot linux, a lot of distro :)
on all my distro, and change usb port but its the same thing i get this error msg: device descriptor read/64, error -110.

I've just one cable with the correct one usb connector. Might there is a good cable to buy?

I'll try it on a W7 PC we'll see!

User avatar
kalle123
Posts: 831
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: Linux Taranis x9d plus dont work

Post by kalle123 » Tue Feb 09, 2016 7:25 pm

skami wrote: I'm running a multi boot linux, a lot of distro :)
on all my distro, and change usb port but its the same thing i get this error msg: device descriptor read/64, error -110.
THAT does NOT sound good! Hardware problem?! Either motherboard, cable or Taranis

Running Debian Jessie 64bit KDE and did not have to make any adjustment for companion and Taranis ....

xavtronic
Posts: 15
Joined: Fri Aug 03, 2012 8:29 am
Country: -

Re: Linux Taranis x9d plus dont work

Post by xavtronic » Thu Feb 11, 2016 7:02 pm

Hi,

It works also good for me without any adjustment for companion and Taranis.

Do you have install the right version (32 or 64 bits) AND also the dfu util ?
64BITS : http://www.open-tx.org/2013/09/25/dfu-u ... 204-64bit/
OR
32BITS : http://www.open-tx.org/2013/09/25/dfu-u ... 204-32bit/

BR
Xavier

User avatar
kalle123
Posts: 831
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: Linux Taranis x9d plus dont work

Post by kalle123 » Thu Feb 11, 2016 7:08 pm

I don't have dfu utility installed. It is working here without it!

br KH

xavtronic
Posts: 15
Joined: Fri Aug 03, 2012 8:29 am
Country: -

Re: Linux Taranis x9d plus dont work

Post by xavtronic » Thu Feb 11, 2016 7:24 pm

Hi,

OK I don't know about that.
The first once without DFU it has not work on my computer.
I'll know for the next time, I don't use it and save me 10 sec to not install it!

BR
Xavier

User avatar
dinamich
Posts: 288
Joined: Mon Apr 01, 2013 1:21 pm
Country: Slovenia
Location: Ljubljana

Re: Linux Taranis x9d plus dont work

Post by dinamich » Thu Feb 11, 2016 8:27 pm

Dfu-util is only needed for flashing with radio in off state. Try other usb ports. Try on another computer, if it works then the radio is OK.

User avatar
rperkins
Posts: 1422
Joined: Sun Jan 08, 2012 12:51 pm
Country: -

Re: Linux Taranis x9d plus dont work

Post by rperkins » Sat Feb 20, 2016 1:28 am

Whenever I see these types of error upon inserting a usb device, it is always hardware related.

1. usb device failed.
2. cable bad.
3. usb port defective.

the computer has not completely enumerated the device. It is not an issue of the software you are going to use to communicate with the device.
error -110 is a timeout error. I did see instances where people said it was related to drawing too much current, but I doubt that is the only reason that error -110 is generated

rdeanchurch
Posts: 702
Joined: Tue Dec 27, 2011 11:22 pm
Country: United States
Location: Carson City, Nv

Re: Linux Taranis x9d plus dont work

Post by rdeanchurch » Sun Feb 21, 2016 11:56 pm

Companiion 2.0.19 and 2.1.7 both work fine on my multi boot Toshiba 64 bit with Unbunto 15.10 and did with 15.04 also. Never had to deal with DFU on Ubuntu.

agree with Rperkins and USB-3 seems to cause many more problems than USB-2. Dell computers also have mor problems than others.
Dean
OldDmbThms: 1. Takeoff, 2. Crash, 3. Repair, GOTO 1


Post Reply

Return to “FrSky Taranis radio”