X9DP and X8R not binding

Hardware help and support for the FrSky Taranis
Post Reply
SundayPurge
Posts: 1
Joined: Tue Apr 06, 2021 7:10 pm
Country: -

X9DP and X8R not binding

Post by SundayPurge » Tue Apr 06, 2021 7:17 pm

Hi, I just bought, second hand, an X9DP (I believe it's from 2016, since, under the cover of the smart port there is 2016/11/11), with a sticker on the back, EU LBT. So..it's an LBT version if I am right. That together with an X8R module. Since I got it, I might have over 8 hours + every video on youtube, yet I haven't been able to bind them. I installed firmware from the OpenTX, nothing, from the FrSky, both EU and non EU, tried every mode, flashed the X8R trough the smart port..nothing. Now they both run the latest firmware but the X8R simply doesn't bind, it keeps showing me both RED and GREEN LEDs on and on, after I start it in the binding mode. The X8R it's getting powered from Pixhawk trough SBUS port, Pixhawk via microUSB cable (I even tried putting the cable on a 2A phonecharger thinking that maybe the module isn't getting enough power.

I don't know what else to try, do you guys have any ideas? It's my first RC set and it's giving me headaches. Thanks in advance.


User avatar
Kilrah
Posts: 10870
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: X9DP and X8R not binding

Post by Kilrah » Tue Apr 06, 2021 8:10 pm

Have you flashed the radio's RF module with the version matching what you flashed on the receiver?

Post Reply

Return to “FrSky Taranis radio”