Q X7S bricked after power off with still connected receiver

Hardware help and support for the FrSky Taranis
Post Reply
jUmPeR
Posts: 10
Joined: Mon Oct 01, 2018 1:23 pm
Country: -

Q X7S bricked after power off with still connected receiver

Post by jUmPeR » Mon Oct 01, 2018 1:35 pm

Hi, all.
My qx7 is 3-4 monthes old. From the begining of use I flashed OpenTX version 2.2.2 with bootloader.
Nothing changed except battery, I'm using 3x18650 = 12.6V. This mod was made one week ago and everything was fine for the last week(I flied every day).
Yesterday, between flights, I powered off my TX while quad was powered on. TX asked me something like that "Receiver is still connected, are you sure?" I accept warning and turned off the TX. And after I changed battery(3-5 min.) in the quad I can't turn on my TX anymore. No led under the power button, no display backlight, nothing but only slight click from speaker when pushing power on button, and another slight click from speaker when pulling finger off.
When I came home tried to connect TX to PC but with no luck. No new devices in Control Panel or in Zadig, just same slight click from the speaker.
After disassembling radio on first two looks) everything is fine and no hot elements(tried to touch with my finger).
Tried to disconnect radio module and power it on, but get no reaction at all - no click sound from the speaker.
Also tried eject, format and use another sd card. Tried different USB ports on notebook. I have only one USB cable now, but I'm sure that it is OK. System is Windows 7. Can't try another PC because I'm in travel, and will be for one week more. Also don't have a multimeter at the moment, will try to find out one soon.

Gramps50
Posts: 1
Joined: Tue Oct 02, 2018 2:29 am
Country: -

Re: Q X7S bricked after power off with still connected receiver

Post by Gramps50 » Tue Oct 02, 2018 3:51 am

Did you by chance charge the TX battery to see if that made a difference?

jUmPeR
Posts: 10
Joined: Mon Oct 01, 2018 1:23 pm
Country: -

Re: Q X7S bricked after power off with still connected receiver

Post by jUmPeR » Tue Oct 02, 2018 7:57 am

Also want to ask about main board - I think that qx7 and qx7s boards are similar, am I right?
And does anyone know where is the power cycle part of the board and what elements I must test at first?
P.s. thank you.

jUmPeR
Posts: 10
Joined: Mon Oct 01, 2018 1:23 pm
Country: -

Re: Q X7S bricked after power off with still connected receiver

Post by jUmPeR » Tue Oct 02, 2018 8:35 am

Gramps50 wrote:
Tue Oct 02, 2018 3:51 am
Did you by chance charge the TX battery to see if that made a difference?
Thanks for answer. Battery is fully charged 12.6V, and also tried battery from my fatshark googles, it has 2s connector with 8.4V but nothing changed.

Carbo
Posts: 336
Joined: Fri Aug 02, 2013 6:55 pm
Country: Germany
Location: Freinsheim RP

Re: Q X7S bricked after power off with still connected receiver

Post by Carbo » Tue Oct 02, 2018 9:02 am

Usually it can not be bricked. What happens, if you disconnect battery and connect TX to PC?


jUmPeR
Posts: 10
Joined: Mon Oct 01, 2018 1:23 pm
Country: -

Re: Q X7S bricked after power off with still connected receiver

Post by jUmPeR » Tue Oct 02, 2018 9:19 am

Carbo wrote:
Tue Oct 02, 2018 9:02 am
Usually it can not be bricked. What happens, if you disconnect battery and connect TX to PC?
Nothing happens. No new devices in Control Panel or Zadig. Also tried with trim buttons in bootloader mode - same story. I just can hear slight click from TX speaker when inserting USB.

jUmPeR
Posts: 10
Joined: Mon Oct 01, 2018 1:23 pm
Country: -

Re: Q X7S bricked after power off with still connected receiver

Post by jUmPeR » Wed Oct 03, 2018 1:21 pm

I'm think about ordering new main board, but not sure about x7s version. Is boards of x7 and x7s same? Asking because fast search on eBay and bangood don't give me any x7s versions, only x7 rev. 0.4

jUmPeR
Posts: 10
Joined: Mon Oct 01, 2018 1:23 pm
Country: -

Re: Q X7S bricked after power off with still connected receiver

Post by jUmPeR » Wed Oct 03, 2018 4:51 pm

I think the only one difference of the main boards of x7 and x7s is soldered Bluetooth module on x7s.

User avatar
Kilrah
Posts: 9663
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Q X7S bricked after power off with still connected receiver

Post by Kilrah » Wed Oct 03, 2018 4:55 pm

That's correct.

jUmPeR
Posts: 10
Joined: Mon Oct 01, 2018 1:23 pm
Country: -

Re: Q X7S bricked after power off with still connected receiver

Post by jUmPeR » Mon Oct 08, 2018 1:48 am

So I'm at home now...
Made some tests:
When plugged from USB MCU power is OK - 3.28V
Tried to connect and flash with stlink, but I can only read and erase memory, but having problem with writing - got an error "Programming error @ 0x08000008!"
And after getting this error I can see that something was written in previously empty flash, but not 100% same content of "opentx-x7-lua-sqt5font-en-2.2.2.bin" - I can see some differences(please see attached screenshots).

Any thoughts about why flash can't be written?
Is it possible that reflowing the MCU can help?


p.s. still no reaction while connecting throug USB...

jUmPeR
Posts: 10
Joined: Mon Oct 01, 2018 1:23 pm
Country: -

Re: Q X7S bricked after power off with still connected receiver

Post by jUmPeR » Mon Oct 08, 2018 1:52 am

Screenshots
Attachments
IMG_20181008_044840.jpg
IMG_20181008_044845.jpg
IMG_20181008_044907.jpg
IMG_20181008_044821.jpg

jUmPeR
Posts: 10
Joined: Mon Oct 01, 2018 1:23 pm
Country: -

Re: Q X7S bricked after power off with still connected receiver

Post by jUmPeR » Mon Oct 08, 2018 2:12 am

Voltage on BOOT0 is 3.3V and it's connected through R418(7.3K) to the ground.

p21marola
Posts: 1
Joined: Sat Oct 13, 2018 8:44 am
Country: -

Re: Q X7S bricked after power off with still connected receiver

Post by p21marola » Sat Oct 13, 2018 9:38 am

Hi all
I have an x7s with a few days of use and exactly the same problem. From what I have been able to see looking for solutions, this problem is quite common in these transmitters and this thread is the closest to a solution I have seen so far.

The proven facts are the following:
The station works correctly, but suddenly at some point it stops working.
Pressing the power button only sounds a click on the speaker and nothing else happens.
When connecting it through the USB port it does not appear on the PC. The only thing that happens is the same click on the speaker, which for me rules out a problem in the cables that feed the main board.
Everyone has verified that the battery is fully charged, so this is ruled out.
Removing the small battery from the main board and the main battery for a few minutes does not give any results.

My assumptions are:
The problem is on the main board, is it a hardware or firmware problem?
It is a cheap transmitter so it is probably more profitable to replace it with a new one than to try to repair it by buying spare parts, so looking for a solution is more a matter of pride. I'd rather have a cheap transmitter than an expensive brick.

The questions are the following:
Is there anyone who has managed to repair this problem in any way?
Replacing the main board?
Reflashing the bricked main board in some way?


Thank you all.
"I apologize for my English, the fault is google translate;)"

jUmPeR
Posts: 10
Joined: Mon Oct 01, 2018 1:23 pm
Country: -

Re: Q X7S bricked after power off with still connected receiver

Post by jUmPeR » Tue Oct 16, 2018 7:47 am

Hi, p21marola.
I think the easy way is to change mainboard, but if you have air rework station and some skills reflowing main MCU( STM32F205VET6) can help. I ordered new stm32 chip and diode(because find out it is dead) and hope that changing main chip will resurrect my radio.

Post Reply

Return to “FrSky Taranis radio”