can't bind s6r with new fw

General Help and support for the Taranis Radio.
Post Reply
User avatar
rwhammer
Posts: 22
Joined: Thu Feb 28, 2019 7:46 pm
Country: United States
Location: MA

can't bind s6r with new fw

Post by rwhammer » Sun Mar 29, 2020 9:57 pm

Ok, I updated to Otx 2.3.5 and firmware for my QX7 to 2.3.5. I updated my s6r to 2.1. Now I can't get it to bind. Maybe I'm not doing the procedure correctly. I put my tx in bind mode (1-16 and 1-8 tel.) Hold the bind button while plugging in power. Green light comes on and a quick red flash, unplug power then release button. Then exit bind mode on tx. Plug power back into rx and I get a flashing red light. This rx was bound to this tx before reflash. I have another s6r that I have already bound to this tx with previous tx firmware (2.2.4) that works still with tx update so I know the tx is good. I hate to go back with rx fw but I might have to. Any help?


User avatar
MikeB
9x Developer
Posts: 16974
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: can't bind s6r with new fw

Post by MikeB » Sun Mar 29, 2020 10:53 pm

Sounds like you haven't updated the Tx module.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
rwhammer
Posts: 22
Joined: Thu Feb 28, 2019 7:46 pm
Country: United States
Location: MA

Re: can't bind s6r with new fw

Post by rwhammer » Sun Mar 29, 2020 10:57 pm

it is 2.3.5.bin

User avatar
Kilrah
Posts: 10598
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: can't bind s6r with new fw

Post by Kilrah » Mon Mar 30, 2020 6:07 am

This is OpenTX firmware, but to use receivers that run 2.1 what you need is to also update the radio's internal RF module. Similar to the receiver, get the firmware for that as an frk file from FrSky's website.

User avatar
rwhammer
Posts: 22
Joined: Thu Feb 28, 2019 7:46 pm
Country: United States
Location: MA

Re: can't bind s6r with new fw

Post by rwhammer » Mon Mar 30, 2020 4:43 pm

OK, now I understand. I have updated tx to 2.1.0 but updated my rx to 2.0.1. If I understand you right they must be the same version. There is no 2.1.0 for the sxr. So do I have to flash my tx back to 2.0.1 to match the rx? I didn't realize the numbers were different sequence.


User avatar
Kilrah
Posts: 10598
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: can't bind s6r with new fw

Post by Kilrah » Mon Mar 30, 2020 5:38 pm

Yes the versions must match. I believe the 2.1.0 for SxR is still under testing.

User avatar
rwhammer
Posts: 22
Joined: Thu Feb 28, 2019 7:46 pm
Country: United States
Location: MA

Re: can't bind s6r with new fw

Post by rwhammer » Mon Mar 30, 2020 5:48 pm

Thank you for your help!!!!


Post Reply

Return to “General help (FrSky Taranis radio)”