X8r binds but no response on motor and servo's

General Help and support for the Taranis Radio.
Post Reply
Frits37
Posts: 10
Joined: Sat Jul 20, 2019 9:10 am
Country: -

X8r binds but no response on motor and servo's

Post by Frits37 » Fri Aug 02, 2019 11:01 am

As in the title: I've succesfully bound an x8r to my X9D (green led and telemetry feedback) but no response at any output channel. Only regular beeps from the motor one by one. What could be the case? Thanks in advance.
Just startin'


User avatar
jhsa
Posts: 19304
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: X8r binds but no response on motor and servo's

Post by jhsa » Fri Aug 02, 2019 3:15 pm

Do you have any mixes set in the mixer page?
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Frits37
Posts: 10
Joined: Sat Jul 20, 2019 9:10 am
Country: -

Re: X8r binds but no response on motor and servo's

Post by Frits37 » Fri Aug 02, 2019 6:32 pm

No, it's a new model, just standard functions to start with (TAER).
Just startin'

User avatar
jhsa
Posts: 19304
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: X8r binds but no response on motor and servo's

Post by jhsa » Fri Aug 02, 2019 6:52 pm

if you don't have any mixes in the mixer menu, than nothing will work.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Frits37
Posts: 10
Joined: Sat Jul 20, 2019 9:10 am
Country: -

Re: X8r binds but no response on motor and servo's

Post by Frits37 » Fri Aug 02, 2019 8:06 pm

Stupid me, I was still in the Spektrum mode.. Of course I have to do the mixes.

Edit: I copied an existing model in the TX which works flawless, but with this receiver the result is the same: it binds, green led, telemetry active, but no signal on the RX pins. It may be a faulty receiver.
Just startin'


User avatar
jhsa
Posts: 19304
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: X8r binds but no response on motor and servo's

Post by jhsa » Fri Aug 02, 2019 10:52 pm

Are you sure it is bound??

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
Kilrah
Posts: 10598
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: X8r binds but no response on motor and servo's

Post by Kilrah » Sat Aug 03, 2019 6:43 am

And bound in 1-8 mode, not 9-16?

Frits37
Posts: 10
Joined: Sat Jul 20, 2019 9:10 am
Country: -

Re: X8r binds but no response on motor and servo's

Post by Frits37 » Sat Aug 03, 2019 9:12 am

It is bound: green led and telemetry readout. And I bound it to 1-8, telemetry on.
Just startin'

User avatar
jhsa
Posts: 19304
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: X8r binds but no response on motor and servo's

Post by jhsa » Sat Aug 03, 2019 11:47 am

At this point I think we should ask you for pictures of your settings in the mixer menu and the inputs menu.

João

Sent from my BLN-L21 using Tapatalk

My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Frits37
Posts: 10
Joined: Sat Jul 20, 2019 9:10 am
Country: -

Re: X8r binds but no response on motor and servo's

Post by Frits37 » Sat Aug 03, 2019 7:11 pm

Here you go.

As I said: this is a copy of a flawless working file for another plane, I only changed the name and the # of the RX.
Attachments
Image3.jpg
Image2.jpg
Image1a.jpg
Just startin'

User avatar
jhsa
Posts: 19304
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: X8r binds but no response on motor and servo's

Post by jhsa » Mon Aug 05, 2019 9:07 am

Do you have another receiver you can test?

João

Sent from my BLN-L21 using Tapatalk

My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Frits37
Posts: 10
Joined: Sat Jul 20, 2019 9:10 am
Country: -

Re: X8r binds but no response on motor and servo's

Post by Frits37 » Tue Aug 06, 2019 2:22 pm

Yes. I tried it and that one (also an X8R) was OK. So it isn't the programming.

Is there any way to reset the receiver to factory settings, other than updating the firmware?
Just startin'

User avatar
Kilrah
Posts: 10598
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: X8r binds but no response on motor and servo's

Post by Kilrah » Tue Aug 06, 2019 3:10 pm

There are no "settings" nor a way to reset any. Try updating the firmware on it, if it still doesn't work it looks like it's just defective.

Frits37
Posts: 10
Joined: Sat Jul 20, 2019 9:10 am
Country: -

Re: X8r binds but no response on motor and servo's

Post by Frits37 » Wed Aug 07, 2019 5:44 am

I have updated the firmware, no change. Unless somebody has a solution, I consider it to be defective indeed.
Just startin'

User avatar
MikeB
9x Developer
Posts: 16974
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: X8r binds but no response on motor and servo's

Post by MikeB » Wed Aug 07, 2019 8:36 am

Try binding using different RxNums. The S6R/S8R receivers have a problem with some Tx modules where only some RxNums work, they bind but don't operate, just possibly this is happening with your X8R.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

Frits37
Posts: 10
Joined: Sat Jul 20, 2019 9:10 am
Country: -

Re: X8r binds but no response on motor and servo's

Post by Frits37 » Thu Aug 08, 2019 4:35 pm

I tried different numbers, unfortunately no difference. I'll contact the webshop.
Just startin'


Post Reply

Return to “General help (FrSky Taranis radio)”