Taranis X9D Bricked. (Solved - hardward problem)

General Help and support for the Taranis Radio.
Post Reply
Endorphin
Posts: 13
Joined: Tue Jan 26, 2016 7:46 pm
Country: -

Taranis X9D Bricked. (Solved - hardward problem)

Post by Endorphin » Wed Apr 17, 2019 9:52 am

I have a new Taranis X9D which I tried to update the firmware.
It will now not turn on.
When I connect it to my computer, it will turn onto the Bootloader screen, but will not respond to input buttons. It will then not turn off when the switch is operated accordingly.
I am using Linux Mint 19. It has dfu util installed.
I have OpenTX Companion 2.2.1 installed.

This is the version of OpenTX that I downloaded and tried to flash:

OpenTX Companion 2.2.3 - Linux DEB Package 64-bit

I am totally stuck with this until someone comes to my assistance.
Any help will be appreciated.

Jim.
Last edited by Endorphin on Fri May 31, 2019 1:56 pm, edited 1 time in total.


jtaylor
Posts: 142
Joined: Fri Nov 01, 2013 1:31 am
Country: -
Location: Wexford (Pittsburgh), PA

Re: Taranis X9D Bricked.

Post by jtaylor » Wed Apr 17, 2019 3:06 pm

I'm confused. You use Companion to download the firmware and flash it to the radio. Which version of Companion did you use to download the firmware, and which version did you use to try to flash it (2.2.1 or 2.2.3). In any case did you perhaps download and flash the wrong version of the firmware (X9D instead of X9D+)? If it is a new Taranis it is a X9D Plus and not a X9D. Exactly which transmitter do you have and what is the filename of the firmware you flashed. If you did flash the wrong version just download the correct version and flash it again, you can't really brick a Taranis with firmware.

Jim

ThompsonJim
Posts: 70
Joined: Thu Aug 30, 2018 10:42 pm
Country: Australia

Re: Taranis X9D Bricked. (Solved).

Post by ThompsonJim » Wed Apr 17, 2019 10:54 pm

jtaylor wrote:
Wed Apr 17, 2019 3:06 pm
I'm confused. You use Companion to download the firmware and flash it to the radio. Which version of Companion did you use to download the firmware, and which version did you use to try to flash it (2.2.1 or 2.2.3). ........................
Please note, I now have two registered identities (thompsonjim and Endorphin)........by mistake. Should I contact the administrators and ask what to do about this, if anything?

I have Companion 2.2.1 installed. I used that to flash the transmitter.
In any case did you perhaps download and flash the wrong version of the firmware (X9D instead of X9D+)? If it is a new Taranis it is a X9D Plus and not a X9D. ................
I have a Taranis X9D Plus.
I looked in the download page for some differentiation between the two version, but I could not find any. If it is there, it was not obvious to me. Can you please direct me to a link with the correct file for the Taranis X9D Plus.
My apologies for this, I did look for some time for this.
Exactly which transmitter do you have and what is the filename of the firmware you flashed...................
The file name is: opentx-x9d+-noheli-lua-luac-en.bin

Edit:
I now see where the correct file is selected: in Companion and not on the download page. This is where I was confused. Apologies for this.
As it turns out, I did select, download and install the correct file for the tx.
If you did flash the wrong version just download the correct version and flash it again, you can't really brick a Taranis with firmware. ..........
That is comforting..............thanks for the reply.

I will attach a couple of screenshots. Companion is not recognising the USB connection to the tx now. I tried two different leads.........same result.

Jim.
Attachments
Tx not connected.png
could not check firmware.png
Last edited by ThompsonJim on Sat May 11, 2019 11:45 am, edited 2 times in total.

jtaylor
Posts: 142
Joined: Fri Nov 01, 2013 1:31 am
Country: -
Location: Wexford (Pittsburgh), PA

Re: Taranis X9D Bricked.

Post by jtaylor » Wed Apr 17, 2019 11:24 pm

There is no difference in Companion between the X9D and the X9D+ but there is a difference in the firmware that it downloads for them. You tell it which you have under settings. I was questioning it because you said X9D bricked and not X9D Plus bricked. In any case since you have a Plus you downloaded and flashed the correct firmware because it has x9d+ in the filename. Did you flash with power on using the boot manager or with power off? If with power on try flashing with power off. You can also try to uncheck the check firmware compatibility box.

ThompsonJim
Posts: 70
Joined: Thu Aug 30, 2018 10:42 pm
Country: Australia

Re: Taranis X9D Bricked.

Post by ThompsonJim » Wed Apr 17, 2019 11:59 pm

jtaylor wrote:
Wed Apr 17, 2019 11:24 pm
..................... I was questioning it because you said X9D bricked and not X9D Plus bricked. ............
Yes, my mistake there........apologies for the confusion.
Did you flash with power on using the boot manager or with power off? .................
I flashed with the power on.
You can also try to uncheck the check firmware compatibility box.
I will, but it won't do any good (I think) because now Companion will not recognise the USB connection of the tx. to computer.
Attachments
Tx not connected.png


ThompsonJim
Posts: 70
Joined: Thu Aug 30, 2018 10:42 pm
Country: Australia

Re: Taranis X9D Bricked.

Post by ThompsonJim » Thu Apr 18, 2019 12:06 am

What function does the SD card do in the Taranis X9D plus do?
Sorry about this silly question.

ThompsonJim
Posts: 70
Joined: Thu Aug 30, 2018 10:42 pm
Country: Australia

Re: Taranis X9D Bricked.

Post by ThompsonJim » Thu Apr 18, 2019 12:12 am

I got a sort of answer here when I did a search: http://rcdiy.ca/opentx-transmitter-firm ... s/sd-card/

But it is still not clear to me. Is it for extra model memories?

User avatar
Kilrah
Posts: 10041
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Taranis X9D Bricked.

Post by Kilrah » Thu Apr 18, 2019 3:47 am

SD is there for sounds, images and logs mostly. Nothing essential and you can run without one.

ThompsonJim
Posts: 70
Joined: Thu Aug 30, 2018 10:42 pm
Country: Australia

Re: Taranis X9D Bricked.

Post by ThompsonJim » Thu Apr 18, 2019 5:35 am

Kilrah wrote:
Thu Apr 18, 2019 3:47 am
SD is there for sounds, images and logs mostly. Nothing essential and you can run without one.
Ok. Thanks Kilrah.

jtaylor
Posts: 142
Joined: Fri Nov 01, 2013 1:31 am
Country: -
Location: Wexford (Pittsburgh), PA

Re: Taranis X9D Bricked.

Post by jtaylor » Thu Apr 18, 2019 10:24 am

Try it powered off, it uses completely different methods powered on and powered off. Powered off uses the dfu loader burned into the processor and not openTX bootloader and can't be bricked by a bad load. It also reloads the openTX bootloader. Try a different cable too.

ThompsonJim
Posts: 70
Joined: Thu Aug 30, 2018 10:42 pm
Country: Australia

Re: Taranis X9D Bricked.

Post by ThompsonJim » Thu Apr 18, 2019 11:52 am

jtaylor wrote:
Thu Apr 18, 2019 10:24 am
Try it powered off, it uses completely different methods powered on and powered off. Powered off uses the dfu loader burned into the processor and not openTX bootloader and can't be bricked by a bad load. It also reloads the openTX bootloader. Try a different cable too.
I tried those. Both did not change anything. The connection is not recognised.

ThompsonJim
Posts: 70
Joined: Thu Aug 30, 2018 10:42 pm
Country: Australia

Re: Taranis X9D Bricked.

Post by ThompsonJim » Fri Apr 19, 2019 8:41 am

I have just realised that I have cross posted here in this thread.
I have a similar thread running on rcgroups.com

Apologies to all.

Jim.

ThompsonJim
Posts: 70
Joined: Thu Aug 30, 2018 10:42 pm
Country: Australia

Re: Taranis X9D Bricked. - Hardware fault confirmed.

Post by ThompsonJim » Mon Apr 22, 2019 9:49 pm

A flying buddy with a working installation of Companion in Win7 or Win10 connected my Taranis and confirmed that it has a hardware fault.
It will be sent back to HobbyKing for a replacement today.
I already have a return/refund/replacement ticket from them; they were very prompt in processing it.
Thanks HobbyKing!

Jim.

ThompsonJim
Posts: 70
Joined: Thu Aug 30, 2018 10:42 pm
Country: Australia

Re: Taranis X9D Bricked.

Post by ThompsonJim » Sat May 11, 2019 11:44 am

HobbyKing sent me a replacement transmitter promptly.
I am happy to report that I have it communicating with my installation of Companion in Linux Mint 19, and so far, all seems perfectly ok.
Also, I have made good progress with learning some basic set ups.
I will edit this thread as solved.
Thanks to all respondents.
Jim.

ThompsonJim
Posts: 70
Joined: Thu Aug 30, 2018 10:42 pm
Country: Australia

Re: Taranis X9D Bricked. (solved)

Post by ThompsonJim » Mon May 13, 2019 8:57 am

Endorphin wrote:
Wed Apr 17, 2019 9:52 am
I have a new Taranis X9D which I tried to update the firmware.
It will now not turn on.
When I connect it to my computer, it will turn onto the Bootloader screen, but will not respond to input buttons. It will then not turn off when the switch is operated accordingly.
I am using Linux Mint 19. It has dfu util installed.
I have OpenTX Companion 2.2.1 installed.

This is the version of OpenTX that I downloaded and tried to flash:

OpenTX Companion 2.2.3 - Linux DEB Package 64-bit

I am totally stuck with this until someone comes to my assistance.
Any help will be appreciated.

Jim.


Post Reply

Return to “General help (FrSky Taranis radio)”