Not valid firmware file on TaranisX9D+ 2019

General Help and support for the Taranis Radio.
Post Reply
xander1990
Posts: 1
Joined: Sun Jun 06, 2021 10:10 pm
Country: -

Not valid firmware file on TaranisX9D+ 2019

Post by xander1990 » Sun Jun 06, 2021 10:17 pm

Hello guys

I was wondering if you could help me solve a problem that I have.

My Taranis x9d+ 2019 bricked after updated the firmware and the bootloader to version 2.3.11.
After a while I managed to turn it on in bootloader mode, but when I try to re-flash the firmware and I select the file, it tells me "invalid firmware file" even though the file is the right one for my radio model. Do you know how can I solve this problem? Is there somebody who can give me the .bin file for version 2.3.9 (which previously worked fine?)
I already tried to flash in DFU mode but it didn't work.


User avatar
Kilrah
Posts: 10895
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Not valid firmware file on TaranisX9D+ 2019

Post by Kilrah » Mon Jun 07, 2021 10:42 am

What's the exact name of the file you're trying to flash? Are you flashing it from the bootloader after having put it on the SD card?

Post Reply

Return to “General help (FrSky Taranis radio)”