Taranis X9D Plus - Damage to mainboard/backboard?

Cant get your radio to work? General Hardware issues?
chargerdude70
Posts: 2
Joined: Tue Aug 15, 2017 1:39 am
Country: -

Re: Taranis X9D Plus - Damage to mainboard/backboard?

Post by chargerdude70 » Wed Sep 06, 2017 7:14 am

Resserecting an old thread here...had to replace stm32 in my Taranis 9+ and lost C3 in the process. MikeB, can you please tell me the value and size?👀

User avatar
MikeB
9x Developer
Posts: 15802
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Taranis X9D Plus - Damage to mainboard/backboard?

Post by MikeB » Wed Sep 06, 2017 8:11 am

C3 is 100nF (0.1uF).
Looking at it, I think it is 0402 size.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

chargerdude70
Posts: 2
Joined: Tue Aug 15, 2017 1:39 am
Country: -

Re: Taranis X9D Plus - Damage to mainboard/backboard?

Post by chargerdude70 » Wed Sep 06, 2017 10:00 am

Thank You kind Sir

ajghor
Posts: 11
Joined: Thu Mar 14, 2013 2:44 pm
Country: -

Re: Taranis X9D Plus - Damage to mainboard/backboard?

Post by ajghor » Mon Oct 02, 2017 9:55 pm

Sorry if this is off topic.

Today I installed a six position switch in my Taranis x9d plus as a new s3 pot.
Everything looked fine, the switch worked ok, and I did the calibration.

But, when I started configuring the Taranis, it just shut off in the middle of the process and now it won't turn on.
I am suspecting that I made a short, but on the other side it worked for an half our or so and then went bezerk :-(
I am not an electronic experts, but if I made a short, it would instantly release the white smoke and go where dead RC's go.

What can I do to diagnose what has gone wrong.
I tried the to connect it with USB, and my PC recognizes the STM processor in DFU mode, so it seems that the proc is ok.
The x9d did act somewhat strange before as it loose the S3 setting of multi switch and revert it to the default none, but I was able to set it again.

User avatar
MikeB
9x Developer
Posts: 15802
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Taranis X9D Plus - Damage to mainboard/backboard?

Post by MikeB » Fri Oct 06, 2017 2:53 pm

Have you removed the connections you added for S3 and tried powering on then?

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!


happyrc1
Posts: 15
Joined: Wed Oct 11, 2017 1:54 am
Country: -

Re: Taranis X9D Plus - Damage to mainboard/backboard?

Post by happyrc1 » Wed Oct 11, 2017 2:03 am

hello mnementh

how to flash firmware for Stm32f2 ? You use a stlink ? and where is firmware ?

i have a big problem with taranis and have flash again firmware for stm32f2

ajghor
Posts: 11
Joined: Thu Mar 14, 2013 2:44 pm
Country: -

Re: Taranis X9D Plus - Damage to mainboard/backboard?

Post by ajghor » Mon Oct 16, 2017 2:47 pm

MikeB wrote:
Fri Oct 06, 2017 2:53 pm
Have you removed the connections you added for S3 and tried powering on then?

Mike.
Hi Mike,

Sorry for the late answer.
The problem has solved by itself.
This very weekend I decided to give another look to the connections I soldered, and before even opening the case I unintentionally switched the Taranis on, and to my surprise it was working as it never had the problem. It was working thru all of the weekend without any problems.
Weird!
The question is should I trust it from now on?
Hope it will not switch off when I'm flying...

Zeddan78
Posts: 2
Joined: Wed Jul 18, 2018 6:56 am
Country: -

Re: Taranis X9D Plus - Damage to mainboard/backboard?

Post by Zeddan78 » Wed Jul 18, 2018 10:52 am

Hi. I need some help. I recently replaced my taranis x9d plus processor (stm32f205vet6). How do i get the bootloader and firmware flash to a fresh new chip?. Ive tried everything still fail. Tried with radio off and plug usb to dfu mode still comes with error..dfu suffix error while flashing. Tried dfuse flashing also error.

Please help

Thanks

User avatar
Kilrah
Posts: 9664
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Taranis X9D Plus - Damage to mainboard/backboard?

Post by Kilrah » Wed Jul 18, 2018 12:07 pm

Power off and dfu. The suffix "error" is normal.

Zeddan78
Posts: 2
Joined: Wed Jul 18, 2018 6:56 am
Country: -

Re: Taranis X9D Plus - Damage to mainboard/backboard?

Post by Zeddan78 » Thu Jul 19, 2018 3:00 am

Kilrah wrote:
Wed Jul 18, 2018 12:07 pm
Power off and dfu. The suffix "error" is normal.
Thank you for ur reply..i tried still fail...
Can i know whats the resistor value of R76 & R77 on a x9d plus?.. on my friends taranis x9d non plus his value is 2k4 & 12k while mine reads different value

Post Reply

Return to “Hardware”