Replace 5V regulator

Cant get your radio to work? General Hardware issues?
User avatar
bob195558
Posts: 1977
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: Replace 5V regulator (Display Screen has stopped working)

Post by bob195558 » Tue Feb 11, 2014 10:15 am

Hi Mike and Joao,

With Multimeter selector set to 20K ohm:
The brown resistor caps next to the larger yellow Capacitor where I soldered the Red wire, reads: 7.8 ohm
and checked the resistance from the "via" hole at the end of the resistor to grounds
and the readings were from left to right: 1: 10.1 / 2: 10.4 / 3: 10.1 / 4: 9.9 / 5: 9.7 / 6: 9.9 / 7: 9.9 / 8: 10.2 / 9: 10.3 / 10: 9.9 / 11: 10.0 / 12: 9.9 / 13: 10.1 ohm.

The small resistor to the right of the 3.3V Regulator, small yellow Capacitor, has a reading of .38 ohm.
And the resistor above it reads 19.4 ohm.

If you think I need to check more, Please let me know.

I think next I should replace the burned 5.12 ohm 512 labelled Safety Fuse Resistor which is 5.1K ohm.
And then Recheck and Clean and Recheck Again for any possible shorts.

I think I am starting to understand your emphasizing to me, that I need to be very particular
and thorough when inspecting for any possible Shorts and Debris on the circuit board.

Bob
Last edited by bob195558 on Wed Feb 20, 2019 1:57 pm, edited 5 times in total.
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
3D Printing: (http://openrcforums.com/forum/viewforum.php?f=85)


User avatar
jhsa
Posts: 18499
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Replace 5V regulator

Post by jhsa » Tue Feb 11, 2014 10:48 am

When I get to my pc I will read this post again but the little brown thing is a capacitor, not a resistor.

Joao

Sent from my GT-I9195 using Tapatalk
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
Hoovernaut
Posts: 42
Joined: Wed Aug 01, 2012 8:42 am
Country: Germany
Location: Tönisvorst

Re: Replace 5V regulator

Post by Hoovernaut » Tue Feb 11, 2014 11:50 am

Bob, have you checked the ribbon cable from the PCB to the display, or its connector?
Turnigy 9X with er9x, FrSky DHT DIY, Haptic mod, Smatiparts board with backlight, Smartiparts TelemtrEZ board, Painted white, Flying with Mode 2

User avatar
Flaps 30
Posts: 1490
Joined: Tue Dec 27, 2011 6:04 pm
Country: -
Location: Wokingham Berkshire

Re: Replace 5V regulator

Post by Flaps 30 » Tue Feb 11, 2014 3:19 pm

bob195558 wrote:I think next I should replace the burned 5.12 ohm Safety Fuse Resistor.
As far as I'm aware, there is no safety fused resistors in the TX. By your comment regarding the resistor being burned. Do you mean that it measured open circuit? If it is the other way around, it is a rare thing to find a resistor that measures short circuit (zero Ohms) unless it is actually a zero ohm resistor. Take another measurement of it and if it measures zero Ohms and it has '512' stamped on it, it should read something close to 5.1 K Ohm NOT 5.12 Ohm. I would then proceed to look for something that is causing this, rather than suspect the resistor.
bob195558 wrote:I think I am starting to understand your emphasizing to me, that I need to be very particular and thorough when inspecting for any possible Shorts and Debris on the circuit board.
Yup. Most faults can be found with the Mk1 Eyeball or the Nose or a heat seeking finger.

One thing that you haven't mentioned or seem to have done. The display doesn't work but have you actually tried the transmitter out to see if it is still capable of working as it did before? That test would tell us if the processor is working as before and that the problem is only with the display.

User avatar
bob195558
Posts: 1977
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: Replace 5V regulator (Display Screen has stopped working)

Post by bob195558 » Tue Feb 11, 2014 6:36 pm

Hi Hooveraut and Flaps 30,

Thank you for your suggestion, I have looked at this and have another LCD Screen which I did try and had same negative results.

My hope is, that this Open Circuit 5.12 5.1K Resistor labelled 512 on the top of it, is the problem.
Using a different Digital Multimeter (Cat. # 22-168A) with the Selector Switch set at 20K ohm and placing the probes at each end of this Resistor
I have a reading of: 0.L before and after taking the readings. (I should have used the words, Open Circuit and Short Circuit)
The other 12 Resistor in this row going to the right, that are labeled 512 read 5.10 to 5.04 ohms.
Also I checked the corresponding 512 Resistors on my other Stock 9x Fuse Brick Mainboard and it reads: 5.11 ohms.
Some of the other Resistor do measures zero Ohms (Short Circuit) and two are labeled with a 0 on them and have a reading of: 0.00 ohms
and when the 9x Mainboard is power up, both side of both Resistors, read 3.3V.
100_4007.JPG
Far left 512 Resistor on my corresponding Stock 9x Fuse Brick Mainboard and it reads: 5.11 ohms. (Pic 07)
100_4011.JPG
Far left 512 Resistor with an Open Circuit on my 9x FlySky Radio. (Pic 11)
100_4020.JPG
Ground to Ground. (Pic 20)
100_4016.JPG
Probe to top of Brown Resistor next to 3.3V Regulator and small yellow capacitor reading. (Pic 16)
100_4015.JPG
Probe to top of Brown Resistor above the previous Brown Resistor.( Pic 15)
100_4014.JPG
Probe to top of row of 9 Brown Resistors. (Pic 14)
100_4013.JPG
Far Right of Row of 9 Brown Resistors Probe at top of Resistor. (Pic 13)
100_4009.JPG
Far Left Resistors Labeled 0 (Pic 09)
100_4008.JPG
Checking the resistance from the "via" hole at the end of the resistor to ground and the reading is about 10K.
This same applies to all 13 vias. (Pic 08)
Flaps 30 wrote: One thing that you haven't mentioned or seem to have done. The display doesn't work but have you actually tried the transmitter out to see if it is still capable of working as it did before? That test would tell us if the processor is working as before and that the problem is only with the display.
This 9x Radio with no screen info being displayed, dose seem to be booting up correctly.
Though I am not completely sure about this, everything dose seems to support this view so far.
The Beep Sound seem correct, when buttons are pressed.
When I have the SmartiesParts Board installed I am able to connect with eepe
and READ FUSES worked with Companion9x (viewtopic.php?f=95&t=3819&start=30#p70825).
With eepe I have flashed back and forth the Eprom models List and er9x-FrSky firmware with no problems.
Not being Technical, it feel like it is working correctly.

(Add Edit) Hi Flaps 30, I do not have a Model and Receiver setup on my FlySky 9x Radio that is working
and not being able to see the display data, its to difficult, to try to blind a receive to it.
I just would not know where I was in er9x-FrSky firmware.
Good suggestion, I do not see how I could do it.
It maybe better to fix what we know is broken first.

Bob
Last edited by bob195558 on Wed Feb 20, 2019 1:59 pm, edited 4 times in total.
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
3D Printing: (http://openrcforums.com/forum/viewforum.php?f=85)


User avatar
jhsa
Posts: 18499
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Replace 5V regulator

Post by jhsa » Tue Feb 11, 2014 6:51 pm

According to your second picture, that resistor seems to be open.. maybe change it..
A second opinion here please ;)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
MikeB
9x Developer
Posts: 16139
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Replace 5V regulator

Post by MikeB » Tue Feb 11, 2014 7:03 pm

The first picture shows probes either side of the resistor, the second shows only 1 probe on the resistor, where is the other probe?

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
bob195558
Posts: 1977
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: Replace 5V regulator (Display Screen has stopped working)

Post by bob195558 » Tue Feb 11, 2014 8:15 pm

Hi Mike,

I know, I do not have pictures for all of the Multimeter Readings, I wish I had more.
Difficult to hold the Probes and take the picture at the same time, was able to do some of them.
The pictures showing the Red Probe only, is reading to Ground, which is the Black Connector with the White Out paint on it
and is connected to the Horizontal Trim board to its new Digital Ground connection.

These next pictures show the same Multimeter Readings as when the probes are on each side of the Resistor.
100_4018.JPG
Brown Resistor next to the larger yellow Capacitor where I soldered the Red wire, is Reading: 7.81 ohm
100_4017.JPG
Small Brown Resistor to the Right of the 3.3V Regulator and then the Small Yellow Capacitor, has a reading of .38 ohm.
I wish the probes were Clear so to show where they are connected, to much distance between Multimeter and probes.

Bob
Last edited by bob195558 on Wed Feb 20, 2019 2:00 pm, edited 1 time in total.
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
3D Printing: (http://openrcforums.com/forum/viewforum.php?f=85)

User avatar
MikeB
9x Developer
Posts: 16139
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Replace 5V regulator

Post by MikeB » Tue Feb 11, 2014 9:44 pm

Suggestion, since it is possible the 5.1K resistor at the left is open circuit, try a temporary repair. Solder a thin wire to each end, and connect the other ends of the wires to a replacement resistor. This may be an ordinary, wire ended resistor. Don't go less then 5.1K, but 5.6K should work.
This replaces the problem resistor without the complication of dealing with the surface mount.
If this fixes the problem, then proceed to a 'proper' repair job.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
Flaps 30
Posts: 1490
Joined: Tue Dec 27, 2011 6:04 pm
Country: -
Location: Wokingham Berkshire

Re: Replace 5V regulator

Post by Flaps 30 » Tue Feb 11, 2014 10:11 pm

I agree with what Mike has said.

The resistor circled (which is hopefully the one that you were measuring that showed to be open circuit) should measure 5.1 K Ohm.
5K1 Resistor.JPG
The brown/yellow items are capacitors and what you were measuring there looks fine.

User avatar
bob195558
Posts: 1977
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: Replace 5V regulator (display now working !) (Display Screen had stopped working)

Post by bob195558 » Wed Feb 12, 2014 6:31 pm

Hi Everyone, :|

I have completed the Temp Fix and by using a combination of three resisters which I obtained from an old 1984 microwave over circuit board.
The ohms reading, equals 5.27 ohms with the Multimeter selector switch set to 20K.
100_4030.JPG
Combination of three resisters = 5.27 ohms
100_4039.JPG
Ready to do the power on testing, of the Temp Fix.
When I slid 9x Radio's Power Switch to the ON position,
the results was YES! the Display Screen is Now Working! :D :D :D :D :D




Very Happy, :D Thank You ! Joao, Flaps 30, Mike and everyone
who helped with guiding me through this repair.
:D
100_4035.JPG
This now working display screen indicates with the Temp Fix, has verified the problem
is with the far top left labeled 512 resister which had become an Open Circuit.
;)

So I think the next thing to do, is to do the permanent fix of replacing the 512 Labeled Resister.

Bob :D
Last edited by bob195558 on Wed Feb 20, 2019 2:01 pm, edited 4 times in total.
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
3D Printing: (http://openrcforums.com/forum/viewforum.php?f=85)

User avatar
jhsa
Posts: 18499
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Replace 5V regulator

Post by jhsa » Wed Feb 12, 2014 6:54 pm

YEEEESSSSS!! Well done..

I had a friend a while ago that had the same problem.. And it was also the resistor.. that is why I mentioned it..
After changing that resistor and when the radio is working you deserve a nice beer. Or maybe have one now, and the rest of the crate later :mrgreen:
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
Flaps 30
Posts: 1490
Joined: Tue Dec 27, 2011 6:04 pm
Country: -
Location: Wokingham Berkshire

Re: Replace 5V regulator

Post by Flaps 30 » Wed Feb 12, 2014 7:16 pm

Great news,.... The resistor that you are looking for has a case size type 0603 SMD with a value of 5K1 Ohms.

So type in '0603 SMD 5K1' into Ebay and you will get a number of hits. Of course you may find it cheaper somewhere else..

User avatar
jhsa
Posts: 18499
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Replace 5V regulator

Post by jhsa » Wed Feb 12, 2014 8:08 pm

he has another board that is damaged and will try to use one of it's resistors..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
Flaps 30
Posts: 1490
Joined: Tue Dec 27, 2011 6:04 pm
Country: -
Location: Wokingham Berkshire

Re: Replace 5V regulator

Post by Flaps 30 » Wed Feb 12, 2014 9:30 pm

jhsa wrote:he has another board that is damaged and will try to use one of it's resistors..
I missed that.. IMO that isn't such a good idea as the chances of getting the resistor off the other board and then soldered onto the other board without overheating or damaging the SMD resistor is slim.

User avatar
jhsa
Posts: 18499
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Replace 5V regulator

Post by jhsa » Wed Feb 12, 2014 9:41 pm

Don't know if you remember reading this but when I did the telemetry mod on one of my radios, instead of removing the right resistors, I had the board upside down and ended up removing 2 of the top right 512 resistors :D
Soldered them back and all good.. I do agree that is not an easy task to work with them. I think it is doable though..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
bob195558
Posts: 1977
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: Replace 5V regulator (wrong voltage regulator, smoked cpu)

Post by bob195558 » Fri Feb 14, 2014 7:55 am

Hi
Good News and BAD News.

First the Good news: I was able to remove and replace the very small 5K1 Ohms (Labeled 512) Resister.
So everything is together working great with my 9x Radio. Very Happy with it! :D :D :D :D :D


:( Now the BAD News: :cry:
(Add edit: high voltage smoked (burned) the m64 chip, but replace burned m64 chip with the m2561 chip for the fix :D )
I have two more (other people) 9x Radios to do the 5V Regulator Upgrade to.
I was given two Voltage Regulators for the 5V Regulator Upgrade and I grabbed one of the packages that contained one of the Regulator's and installed it.
Plug in all the cables for Both SmartiesParts boards, everything I thought was looking good to go.
BUT! ..... ...... When I powered up the 9x Radio, there was no display and the beeper did not sound correctly.
Powered off the 9x Radio and opened it up.
Could smell (small amount) something has burned, But there is nothing that looks like it has burned.
I started the troubleshoot procedure as I have been instructed with my previous 9x Radio display failure.
The resisters check out OK, But when I checked the small Capacitors for the 3.3V Regulator, (it should read about 3.2 ohms as compared with a working 9x mainboard)
is now reading 1.1 ohms.
I then started thinking :idea: , ...... was the 7805 5V Regulator the correct Regulator? :?:
I found the package that this one came in and it is labeled 7812 +12VDC Voltage Regulator (RadioShack). :shock: :o :x :oops: :( :|
It is an incorrect Voltage Regulator, But it looks the same as the correct Voltage Regulator( it is the same physical size).

This HURTS! :( ..... I did not check to make sure both packages had the same Voltage Regulator. The other package has the correct Voltage Regulator (7805).

So far it looks like the 3.3V regulator Capacitors are cooked and I do not know what else maybe broken. I hope both SmartiesParts boards are OK.

What components do you speculate maybe damage?

Bob
Last edited by bob195558 on Wed Feb 20, 2019 2:18 pm, edited 6 times in total.
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
3D Printing: (http://openrcforums.com/forum/viewforum.php?f=85)

User avatar
Kilrah
Posts: 9832
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Replace 5V regulator

Post by Kilrah » Fri Feb 14, 2014 8:19 am

bob195558 wrote:I have two more (other people) 9x Radios to do the 5V Regulator Upgrade to.
What is it with all these regulator changes?

It IS NOT necessary to replace the regulator on a "standard" 9x that has not received hacks that draw significant additional power on the regulated rail, from your photos yours seem not to have been modified in any way that requires it. There are dozens of thousands of 9xs around that have always worked perfectly fine.

Stop losing your time and frying those poor boards... :(

User avatar
Hoovernaut
Posts: 42
Joined: Wed Aug 01, 2012 8:42 am
Country: Germany
Location: Tönisvorst

Re: Replace 5V regulator

Post by Hoovernaut » Fri Feb 14, 2014 8:32 am

When is it necessary to change the regulator? I have the Smartiparts board with back light, the TelemetrEZ, the internal FrSky module, the haptic mod and in a short time the Taranis gimblas with amplifier. Is the standard regulator still okay for that or already on the knifes edge?
Turnigy 9X with er9x, FrSky DHT DIY, Haptic mod, Smatiparts board with backlight, Smartiparts TelemtrEZ board, Painted white, Flying with Mode 2

User avatar
Kilrah
Posts: 9832
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Replace 5V regulator

Post by Kilrah » Fri Feb 14, 2014 8:52 am

I don't know how the smartieparts stuff powers itself, so it's a bit hard to know. Normally it should power itself off the battery voltage, so no issues. None of the "standard" mods published on here draw extra on the mainboard's 5V rail either.

My radio runs at 50mA standard (with an atmega128A), and I have an integrated USBASP I power from the mainboard's 5V that adds 20mA continuous draw. At 70mA, even with 13V input, the stock reg barely heats up. To me one can go to 100mA without issues i.e. none of the mods would require replacement.

User avatar
jhsa
Posts: 18499
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Replace 5V regulator

Post by jhsa » Fri Feb 14, 2014 9:02 am

Bob, sorry to read that. :( The capacitors might have been fried, the 3.3v regulator could be ok as you didn't reverse the polarity, but the really bad news is that you could have fried the CPU. I guess the poor thing can't cope with such high voltage. I gess it is time for the ultimate mod. Replacing the CPU. If you decide to do it, just go for the atmega2561 as it has more flash and eeprom capacity. Check also for burnt traces near the LCD connector and switch board just in case. You need to check also the IC that handles the PPM. is it a 4066? I don't remember. Will have to look in the datasheet to see the max specs. Sometimes this is the price of DIY. Lots of fun, but can also be lots of pain. First of all you have to decide if it is worth trying to fix it.

Sent from my GT-I9195 using Tapatalk
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
MikeB
9x Developer
Posts: 16139
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Replace 5V regulator

Post by MikeB » Fri Feb 14, 2014 10:05 am

João is very likely correct. You will have powered the radio with much more than 5V, anything up to 12V.
What battery did you use (what voltage). If it was significantly less than 12V, the regulator would just have dropped some more volts so you might be lucky.
The 4066 should handle 12V OK, and the 3.3V regulator should also be OK. The most likely items to have failed are some of the capacitors, and the CPU.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 18499
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Replace 5V regulator

Post by jhsa » Fri Feb 14, 2014 10:14 am

Mike, I think he could solder the correct regulator, replace the caps that are damaged, check for shorts, and if there are any, power the cpu? Even if it works I don't think I'd trust it anymore. :(

Joao

Sent from my GT-I9195 using Tapatalk
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
MikeB
9x Developer
Posts: 16139
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Replace 5V regulator

Post by MikeB » Fri Feb 14, 2014 12:16 pm

Quite likely! The spec. shows a max. operating voltage for the CPU of 6.0 volts.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
bob195558
Posts: 1977
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: Replace 5V regulator

Post by bob195558 » Fri Feb 14, 2014 3:47 pm

Thank you for the info about what components maybe damage.
I want to fix the MainBoard and/or this 9x Radio.
Its my error, not to have install the correct component into this 5V Regulator Upgrade Mod.

I like Joao's suggestion process to troubleshoot the damaged 9x MainBoard and see where and what has been damage.

Mike, the Lipo battery voltage is 11.6 Volts. I wish it was lower too.
Also can I use other Caps to temp-replace the damage ones, like your suggestion with the temp resisters, in place of the open circuit 512 Resister?
100_4194.JPG
Wrong Voltage Regulator Damaged 9x MainBoard
Some other info and/or options to think about:

I have the Fuse Brick Stock 9x Mainboard that I barrowed the 512 Resister from and maybe it would be better board to upgrade with a new CPU.

I also have a New 9XR-Mainboard (Invoice Date: 6/6/2013) (http://www.hobbyking.com/hobbyking/stor ... duct=39501) which may have parts that could be used.
I do not have a 9XR Radio and I have it because, I had an order with Hobby-King and to add it to the order, did not increase the shipping cost
and the 9XR-Mainboard cost is Low so I was thinking it mite be useful some day.

This is a new opportunity to do another good Mod.
Thank you for your help.

Bob
100_4141.JPG
New 9XR Mainboard Front Side. PRICE about: $6.22 to $7.39.
100_4143.JPG
New 9XR Mainboard Back Side.
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
3D Printing: (http://openrcforums.com/forum/viewforum.php?f=85)

User avatar
MikeB
9x Developer
Posts: 16139
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Replace 5V regulator

Post by MikeB » Fri Feb 14, 2014 6:25 pm

Yes you can use other caps, but for them, keep the wires as short as you can.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
bob195558
Posts: 1977
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: Replace 5V regulator

Post by bob195558 » Sat Feb 15, 2014 5:07 pm

Hi,

I was looking at the 9XR Mainboard and I see it has a KIA 78D05F (213) 5V Regulator and checking on-line it says it has 1 amp output.
KIA 78D05F Regulator datasheet.pdf
KIA 78D05F 5V Regulator Data Info.
(405.32 KiB) Downloaded 75 times
So I was thinking I could use this 78D05F Regulator for one the 5V Regulator Upgrades.

Another question I have, could I use the 9XR CPU (ATMEGA128A / AU 1248) to replace the stock 9x CPU ? (ATMEGA64A / AU 1139)
If and when I do the CPU upgrade I would follow Joao's suggestion that its better to use the atmega2561 CPU.
Bob :)
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
3D Printing: (http://openrcforums.com/forum/viewforum.php?f=85)

User avatar
MikeB
9x Developer
Posts: 16139
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Replace 5V regulator

Post by MikeB » Sat Feb 15, 2014 6:38 pm

You could use the '128, but it is very difficult to safely remove it from the 9XR board in a fit state to solder back in.

The KIA78D05F looks like a good device to use. Check the pinout carefully, but it is specified to have only 0.5V dropout which is MUCH better than a 'standard' 7805.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
bob195558
Posts: 1977
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re:Upgrade chip 2561 for 9x , Atmel ATMEGA2561-16AU (Replace 5V Regulator)

Post by bob195558 » Mon Feb 17, 2014 1:50 am

Is this a good price and place to order the atmega2561 ?
(https://www.arrow.com/en/products/atmeg ... technology) click on "Continue to Arrow.com".
and (http://components.arrow.com/part/detail ... n=octopart)

Atmel - ATMEGA2561-16AU: (http://download.siliconexpert.com/pdfs/ ... oc2549.pdf) / Pricing: $12.50


Bob :)
Last edited by bob195558 on Mon Dec 11, 2017 1:51 pm, edited 2 times in total.
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
3D Printing: (http://openrcforums.com/forum/viewforum.php?f=85)

User avatar
bob195558
Posts: 1977
Joined: Sun Dec 16, 2012 7:24 pm
Country: United States
Location: New England, Vermont
Contact:

Re: Replace 5V regulator

Post by bob195558 » Fri Feb 21, 2014 7:28 am

Hi
Is there a Schismatic for the 9XR Mainboard :?:

I have not been able to find it.:)

Bob
ErSky9x on Taranis, Sky9x, 9Xtreme, Er9x on 9x with Smartieparts Programmer with TelemetrEZ Board
3D Printing: (http://openrcforums.com/forum/viewforum.php?f=85)


Post Reply

Return to “Hardware”