SOLVED - Taranis plus - Problem with wave files

Cant get your radio to work? General Hardware issues?
Post Reply
rcgyuk
Posts: 338
Joined: Sat Sep 15, 2012 2:51 pm
Country: -

SOLVED - Taranis plus - Problem with wave files

Post by rcgyuk » Mon May 13, 2019 7:27 am

Hi all,

I just acquired a warranty return mint condition X9D+ for next to nothing because "It won't bind to a receiver"

As I suspected, it had the wrong firmware in the internal module, so it binds perfectly.

I flashed to the latest Open TX 2.2.3 version, formatted the SD card, and downloaded latest version. I copied all my models from my original X9D (non plus version, very old, first batch that came into UK at launch date)

I then copied the custom wave files I had on my original X9D to the X9D+. Things like Aileron Rates High / Medium / Low etc.

These work fine on the QX7 once I shortened names to 6 characters, but the X9D+ doesn't seem to like them.

When I use the special function Play Track and assign one of these custom wav files, it either plays the wrong one or does nothing at all.

The one that are part of the SD card download work fine (at least the ones I tried at random all worked)

Any clues what is wrong ?

Separate question, the on / off switch seems too easy to move, my X9D is much stiffer so less likely to be accidentally turned off. Can this be fixed ?

Robert.
Last edited by rcgyuk on Sun May 26, 2019 1:06 pm, edited 1 time in total.


tonnie78
Posts: 97
Joined: Mon Jan 12, 2015 9:33 am
Country: -

Re: Taranis plus - Problem with wave files and on/off switch

Post by tonnie78 » Mon May 13, 2019 8:15 am

Most important in regards to the switch is that when connected to a receiver, even if you try to switch of the transmitter asks for confirmation before even switching off. So no big risk here I think.

Verstuurd vanaf mijn SM-G973F met Tapatalk


rcgyuk
Posts: 338
Joined: Sat Sep 15, 2012 2:51 pm
Country: -

Re: Taranis plus - Problem with wave files and on/off switch

Post by rcgyuk » Mon May 13, 2019 8:22 am

QX7 work like that as on / off is push button but X9D+ is slide switch and just turns off with warning.

rcgyuk
Posts: 338
Joined: Sat Sep 15, 2012 2:51 pm
Country: -

Re: Taranis plus - Problem with wave files and on/off switch

Post by rcgyuk » Sun May 26, 2019 8:48 am

Update to my wave file problem. My original X9D bought in 2013 has the original 1GB SD card. It contains custom phrases like "Aileron Rates High" created in 2013.

My new (second hand) X9D+ bought last month as a warranty return (binding issue, just had wrong firmware) has a 2GB SD card.

Both have been reflashed to 2.2.3 at the same time. Both SD Cards have the correct sound pack downloaded. Both play all the supplied wave files correctly. The 2GB SD card has had my 2013 custom wave files copied to it.

Both TX's will play my custom files and the standard files from the 1GB SD card. Neither will play the custom files from the 2GB SD card, only the standard files.

Where do I go from here to get the X9D+ to play my 2013 wav files? (I want to leave the original SD card in the original TX)

Robert.

User avatar
Kilrah
Posts: 10232
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Taranis plus - Problem with wave files and on/off switch

Post by Kilrah » Sun May 26, 2019 9:01 am

Obviously points to a card problem... Copy files off the 2GB card, format it, put them back. If still no good trash the card and replace it.


rcgyuk
Posts: 338
Joined: Sat Sep 15, 2012 2:51 pm
Country: -

Re: Taranis plus - Problem with wave files and on/off switch

Post by rcgyuk » Sun May 26, 2019 10:19 am

I have already done a full format. Is 2GB ok or do I need 1GB ?

User avatar
Kilrah
Posts: 10232
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Taranis plus - Problem with wave files and on/off switch

Post by Kilrah » Sun May 26, 2019 11:23 am

Anything works up to 32.

rcgyuk
Posts: 338
Joined: Sat Sep 15, 2012 2:51 pm
Country: -

Re: Taranis plus - Problem with wave files and on/off switch

Post by rcgyuk » Sun May 26, 2019 11:25 am

Thanks. Trying one last format, using a port in my printer, instead of formatting inside the radio via USB.

rcgyuk
Posts: 338
Joined: Sat Sep 15, 2012 2:51 pm
Country: -

Re: Taranis plus - Problem with wave files and on/off switch

Post by rcgyuk » Sun May 26, 2019 1:05 pm

SOLVED - That has fixed it, don't know why, but works now.


Post Reply

Return to “Hardware”