9XR Pro probs

Cant get your radio to work? General Hardware issues?
User avatar
stotty1111
Posts: 185
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

Re: 9XR Pro probs

Post by stotty1111 » Thu May 09, 2019 8:32 am

Ok, another problem cropped up yesterday whilst sailing the boat in my avatar.
The boat has 2 propulsion motors, the are mixed with the V-tail mix, these channels are then setup on the L H gimbal for ease of control. It has worked well like this for a long time, yesterday the straight up/down stick movement used for twin forward/twin revers stopped working although moving stick diagonally in the 4 directions controls the relevant motors as did horizontal stick movement.
Programming prob? gimbal prob? corruption of some other programming?
I ask before I open up the tx and start fiddling!
Need to add, same situation with other single motored boats , ie up/down movements don't work!


User avatar
jhsa
Posts: 19314
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9XR Pro probs

Post by jhsa » Thu May 09, 2019 9:13 am

Let's find out if it is a gimbal problem.
Please go to Radio Setup / DiagAna menu..
The first four lines are the gimbals. Do they work there?

João

Sent from my BLN-L21 using Tapatalk


My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
stotty1111
Posts: 185
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

Re: 9XR Pro probs

Post by stotty1111 » Thu May 09, 2019 9:20 am

Yeap on that gimbal the readings change with stick movement!

User avatar
jhsa
Posts: 19314
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9XR Pro probs

Post by jhsa » Thu May 09, 2019 9:53 am

Then you might have changed something on the model's programming :)
Try downloading your model to your computer via Eepskye, and post it here please.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
stotty1111
Posts: 185
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

Re: 9XR Pro probs

Post by stotty1111 » Thu May 09, 2019 1:26 pm

afs1eeprom.zip
(2.17 KiB) Downloaded 54 times
OK, HOPE IT WORKS


User avatar
jhsa
Posts: 19314
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9XR Pro probs

Post by jhsa » Thu May 09, 2019 11:28 pm

Hmm, don't know if I understand your programming, but it looks like you have the motors forward /Backwards on the left horizontal stick (Rud), and left/right on the right vertical stick :o That doesn't look right?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
stotty1111
Posts: 185
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

Re: 9XR Pro probs

Post by stotty1111 » Fri May 10, 2019 6:29 am

Ok, I installed a v tail mix, configured the tx so that the mix was on the left hand stick. Hooked up the motors and speed controllers to the relevant channels on the rx, the props are, when viewed from back of the boat, left turning on right hand side and right turning on left hand side, cannot remember offhand but had to change some of the weights from -ve to +ve and vice versa to achieve the correct prop rotations to give stick upwards for forwards and down to reverse and horizontal stick to the left the right hand prop going forward left hand in reverse etc.
I hope this clarifies the situation.
This system was outlined in a model boating magazine several years ago.
I have also installed this system in in/for other club members and their boats.
I suppose later today I could create another model using this system to see if it creates the same problem/situation.

User avatar
stotty1111
Posts: 185
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

Re: 9XR Pro probs

Post by stotty1111 » Fri May 10, 2019 3:42 pm

Ok, having just spent an hour fiddling with the tx etc I setup another model with the same mix and characteristics as the problematic one, and with some changes to the +ve and -ve aspects of the two mix channels its all working fine again. I then returned to the original problematic model, re installed the mix, changed the characteristics and there you go it works as it should again. Don't know how the mix was corrupted but there you go, try the simple solution first! and thats yet another learning curve!!
Thanks for your efforts Jaoa, its time for me to adopt the KISS system, KEEP IT SIMPLE STUPID!! : - ()

User avatar
jhsa
Posts: 19314
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9XR Pro probs

Post by jhsa » Sat May 11, 2019 3:02 am

Good that is all working. Could it be that'you copied the models from another radio?

João

Sent from my BLN-L21 using Tapatalk

My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
stotty1111
Posts: 185
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

Re: 9XR Pro probs

Post by stotty1111 » Sat May 11, 2019 7:11 am

No , the model was created on the radio.
I suppose it could be that at the sailing competition last Sunday someone had been 'fiddling' with the radio as all the models taking part were on display for the public to look at, and the radios were at the side of the respective models, there being a period when the display was unattended (apero time! ; - ) ) -- who knows?
Next time a little more caution perhaps!!

User avatar
jhsa
Posts: 19314
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9XR Pro probs

Post by jhsa » Sat May 11, 2019 11:40 am

Weird, the only thing I could think that it could mess up the programming like that is if someone changed the stick mode in the Radio Setup, but even that wouldn't change a control that was on a vertical stick to an horizontal stick.. this is what doesn't make sense to me :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
stotty1111
Posts: 185
Joined: Mon Aug 11, 2014 5:56 pm
Country: France
Location: overlooking Douarnenez Bay Finistere

Re: 9XR Pro probs

Post by stotty1111 » Sun May 12, 2019 4:32 pm

Me neither, will know in the future to try a new model first though!!
again, thanks


Post Reply

Return to “Hardware”