Pitfalls in flashing Turnigy 9X

Cant get your radio to work? General Hardware issues?
Post Reply
Posts: 1
Joined: Mon Mar 05, 2018 7:08 pm
Country: -

Pitfalls in flashing Turnigy 9X

Post by keithehenry » Mon Mar 05, 2018 8:35 pm

After a few days of aggravation I have what appears to be a working Turnigy 9X with ER9X firmware. This post is for those searching on keywords and looking for inspiration. No problem to be solved at this point. Just thanks to all of you and your posts I've read to get this far.

Here's the story:
- Ordered SmartieParts Basic Rev 1.1 solderless 9X specific programming board from China. Waited several weeks (as I recall). Cute little thing. Installed without incident. Realized that the hard part would be getting the software to work.
- Er9x.com had eepe-i386.deb for linux. Tried it on my Ubuntu 14.04 running on a Chromebox with crouton. Debian package installer seemed to work. No desktop icon but the Application Finder found it and voila! It started up with its welcome screen.
- Downloaded the er9x.hex file (from ER9X.com) and/or had eepe download and verify it. In any case, eepe seemed to be working.
- Plugged in the 9X SP programmer into my Chromebox and tried to read the existing 9x programming for backup. Eepe reports "AVRDude not found at AVRDude". Had to set the location with Preferences... Mine was at "/usr/bin/avrdude". I don't know when avrdude was installed. I think the eepe-i386.deb installation did it.
- Eepe reports: "avrdude: error: could not find USB device with vid=0x16c0 pid=0x5dc vendor='www.fischl.de' product='USBasp'". Verified that Linux "lsusb" didn't see it either. Figured it was my crouton setup. Thought the SP Basic was DOA. Uninstalled it. Debugged. Turns out it was just the USB cable I was using. Same cable works for other stuff? Take away: Check that your host computer can see the SP Basic even before installing it.
- Numerous problems. Somewhere along the way I added the line 'SUBSYSTEM=="usb", ATTR{idVendor}=="16c0", ATTR{idProduct}=="05dc", GROUP="adm", MODE="0666"' to '/etc/udev/rules.d/10-usbasp.rules' as you'll see to do at the old google code website. I'm not sure if this was necessary or not.
- Now Eepe reports:
avrdude: error: programm enable: target doesn't answer. 1
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.
I had read that the 9X power switch did not need to be on. My power switch did need to be on. Now I see "Eeprom Error" and loud continuous beep from the 9x. Looks like I have already hosed the original firmware.
- Tried to read the existing firmware again. Avrdude appeared to be reading but then bombed out on the filename I had given. I added a ".bin" to the filename and it was much happier. Still, I'm pretty sure the file I just read is already corrupted and useless.
- Decided I may has well try writing er9x.hex to the 9x. It seems to be working but during the readback / verify cycle avrdude reports "first mismatch at location 0x0100" (paraphrasing). Tried the "-B 4" and "-B 100" options with the same results. The flash has definitely been erased. I'm screwed.
- Research finds that this problem appears to be from a bad version of avrdude. Reports were that 6.0 was not good but the 5.11 worked. Considered installing 5.11 but found that avrdude was now at 6.3. I'm hoping whatever the problem it is fixed by now. Found out how to install the latest version at "ubuntuhandbook.org". Installed it. For some reason it removes eepe. Don't know why.
- Reinstalled eepc the same as before. Pretty sure it will wipe out avrdude 6.3 and install 6.0 again but it doesn't.
- Meanwhile, the 9x no longer even beeps at me. Nothing on the screen. I'm sure it's dead. Decided to recharge the batteries, sleep on it, and hope everything would work the next morning now that avrdude is updated.
- Super depressed when even with newly recharged batteries the 9x was dead. No beep. No nothin'.
- Plugged in the USB cable, fired up eepe, and OK'd programming. The -B 20 option is still set so. It is a horrendously long 400s. But, in the end it programs OK and ER9X is installed. Yeah!

Thank you all for the past posting with problems and solutions which have made this possible. So many brick walls, eventually fall away.

Post Reply

Return to “Hardware”