Horus x10s permanantly thinks its plugged in to USB

Cant get your radio to work? General Hardware issues?
Post Reply
palrv
Posts: 2
Joined: Sat Jun 11, 2022 10:48 pm
Country: -

Horus x10s permanantly thinks its plugged in to USB

Post by palrv » Sat Jun 11, 2022 11:31 pm

After charging my TX today the next time I switched it on it thinks it connected to usb and asks to select a mode. USB symbol is always showing on the screen when not connected. The usb appears to work fine I can connect to companion, see the disks if I select usb storage mode.
If I switch off and plug in I can see the boot loader and can flash firmware in that mode with Companion.
If I power off and back on and select joystick mode the radio appears to work as a radio (USB symbol still shows)
I cannot flash firmware from SD or enter boot loader mode by powering up with trims to center as I get a usb connected message. The only way to power off in this mode is to unplug the battery.
When I power on I always get asked what mode to select.
If I select usb storage mode when I switch off I get 4 horizontal dots instead of the usual circular dots display.
If I try to flash firmware in storage mode I get an error cannot write F://FIRMWARE.BIN

I have tried power cycling with no battery
Powering up with no sd
Removing nvram battery and leaving for a while
Upgrading to 2.3.15 with radio off and companion - I was on opentx-x10express-2.3.14

TX is only a few months old only used to set up some planes. Have searched but not yet found any one else with the same issue.

IIs it a problem with the boot loader or hardware? what should I do next? The radio appears to be usable but its not working as it should / was when I first got it.
Appreciate any more suggestions - thanks in advance.


User avatar
Kilrah
Posts: 11031
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Horus x10s permanantly thinks its plugged in to USB

Post by Kilrah » Sun Jun 12, 2022 5:13 am

Likely hardware, the USB connection is detected by the 5V from the computer being present on the relevant pin. Might be a short / screwed up connection inside.

palrv
Posts: 2
Joined: Sat Jun 11, 2022 10:48 pm
Country: -

Re: Horus x10s permanantly thinks its plugged in to USB

Post by palrv » Mon Jun 13, 2022 7:37 am

OK thanks for your input, I'll take a closer look at that. Once I've figured it out I'll post back.


Post Reply

Return to “Hardware”