Build Compile amod [Please help]

Help with any software/desktop related issues. e.g. companion9x, eePe, etc
darozas
Posts: 59
Joined: Fri Feb 17, 2017 10:56 pm
Country: -

Build Compile amod [Please help]

Post by darozas » Fri Feb 17, 2017 11:04 pm

Hi all im new here

So i spend 2 weeks on Megasound project so far

Got Oliver PCB build flashed bootloader and firmware successfully

All i trying to do is to compile TEST hex to test board of radio without success

Keep getting "No rules to make target ../amod328.c , needed by amod328.o"

Can any one clarify me what im doing wrong????

Using Win 7 falowed tut viewtopic.php?f=5&t=143&p=5141#p5141

without joy Avr studio giving me same error please help

Thanks
Regards


User avatar
MikeB
9x Developer
Posts: 16586
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Build Compile amod [Please help]

Post by MikeB » Fri Feb 17, 2017 11:47 pm

You have the amod directory. This needs a sub-directory called "obj".
Then change directory to this sub directory and use:
MAKE -f ..\makefile
to do the compile.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

darozas
Posts: 59
Joined: Fri Feb 17, 2017 10:56 pm
Country: -

Re: Build Compile amod [Please help]

Post by darozas » Sat Feb 18, 2017 11:45 am

Big thanks MIKE

Got it compiled

Flashed but speaker only ticking?? is that due volume input not being made??? or wrong speaker???

And it seams to locking bootloader to reflash i have to reflash bootloader ???

Is that me doing something wrong here???

Thanks
Regards

User avatar
MikeB
9x Developer
Posts: 16586
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Build Compile amod [Please help]

Post by MikeB » Sat Feb 18, 2017 2:38 pm

Are you using the bootloader to do the flashing?
There is a compiled version of amod_last.hex here: viewtopic.php?f=5&t=2&p=116264&hilit=amod_last#p116264.
You might like to try flashing this.
Or do you want a test version that sends output without needing the Megasound in the radio?

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

darozas
Posts: 59
Joined: Fri Feb 17, 2017 10:56 pm
Country: -

Re: Build Compile amod [Please help]

Post by darozas » Sat Feb 18, 2017 4:24 pm

Thanks for your time MIKE

Yes i have flashed bootloader via ISP and uploaded amod_last.hex via serial

And compiled Test version to test all without radio just make sure all works ok.

So i compiled TEST hex uploaded to board using serial but then board hangs (When trying reupload sketch tx led never stops fast blinking)

If i reflash bootloader all ok again then i can upload Stock amod_last.hex as many times i want without issue.

Can i get TEST hex file by any chance please????

The one i compiled dont seams to work ok and it makes speaker to make ticking noise verry low volume level.

And if i try to upload audio file from EEPE it uploads file (Well thinks it doese it) without sd card attached.If i use Stock amod_last.hex and try to upload audio file i get "Not in sinc"

Regards


User avatar
jhsa
Posts: 18982
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Build Compile amod [Please help]

Post by jhsa » Sat Feb 18, 2017 4:44 pm

Did you program the correct fuses on the atmega??

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

darozas
Posts: 59
Joined: Fri Feb 17, 2017 10:56 pm
Country: -

Re: Build Compile amod [Please help]

Post by darozas » Sat Feb 18, 2017 4:48 pm

Thats what i did

Code: Select all

## Arduino Pro or Pro Mini (5V, 16 MHz) w/ ATmega328
## -------------------------------------------------
pro.menu.cpu.16MHzatmega328=ATmega328 (5V, 16 MHz)

pro.menu.cpu.16MHzatmega328.upload.maximum_size=30720
pro.menu.cpu.16MHzatmega328.upload.maximum_data_size=2048
pro.menu.cpu.16MHzatmega328.upload.speed=57600

pro.menu.cpu.16MHzatmega328.bootloader.low_fuses=0xFF
pro.menu.cpu.16MHzatmega328.bootloader.high_fuses=0xD6
pro.menu.cpu.16MHzatmega328.bootloader.extended_fuses=0xFD
pro.menu.cpu.16MHzatmega328.bootloader.file=atmega/optiboot_atmega328.hex

pro.menu.cpu.16MHzatmega328.build.mcu=atmega328p
pro.menu.cpu.16MHzatmega328.build.f_cpu=16000000L

User avatar
jhsa
Posts: 18982
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Build Compile amod [Please help]

Post by jhsa » Sat Feb 18, 2017 4:51 pm

What voice files do you have in the SD Card?

Try downloading the one from the first post here:

viewtopic.php?f=5&t=7717

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

darozas
Posts: 59
Joined: Fri Feb 17, 2017 10:56 pm
Country: -

Re: Build Compile amod [Please help]

Post by darozas » Sat Feb 18, 2017 5:30 pm

I have "British Female - 22KHz 16 Bit" ????

Regards

User avatar
MikeB
9x Developer
Posts: 16586
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Build Compile amod [Please help]

Post by MikeB » Sat Feb 18, 2017 9:41 pm

It is some time since I looked at this!
How will you be connecting the Megasound to your radio? Will you be using the serial connection that uses two of the trim switches?
If so, it requires a specific option on the make command?

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

darozas
Posts: 59
Joined: Fri Feb 17, 2017 10:56 pm
Country: -

Re: Build Compile amod [Please help]

Post by darozas » Sat Feb 18, 2017 10:03 pm

Thanks For reply Mike

I would love to use Serial connection instead of LCD lines

Regards

User avatar
MikeB
9x Developer
Posts: 16586
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Build Compile amod [Please help]

Post by MikeB » Sat Feb 18, 2017 11:14 pm

The compile line you need is:
MAKE -f ..\makefile SERIAL=1
For testing, edit amod328.c and change:
#define TESTING 0
to
#define TESTING 1

It is possible, I can't remember, that in testing mode, the bootloader doesn't get to run.
The serial port should be running at 38400 baud.
If you send a digit from '1' to '9' in on the serial port, the voice file 0001.wav to 0009.wav should be played.
Sending '0' followed by a space should drop out to the bootloader.

What bootloader are you using? Are you using a default Arduino one or the Optiboot bootloader written specifically for the Megasound?

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

darozas
Posts: 59
Joined: Fri Feb 17, 2017 10:56 pm
Country: -

Re: Build Compile amod [Please help]

Post by darozas » Sat Feb 18, 2017 11:45 pm

Thanks again

i running OptiBoot bootloader

Ill try to compile that way

Ill back soon to let you know outcome

So with this code amod_lastSer.hex i should be able if im on TESTING 0 to use serial trim pins instead of LCD lines just to connect PD2 &PD3 is that correct?

Regards

User avatar
MikeB
9x Developer
Posts: 16586
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Build Compile amod [Please help]

Post by MikeB » Sun Feb 19, 2017 10:08 am

Yes, but you need to disconnect the trim switches from the processor and connect them to the Megasound so the trims still work.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

darozas
Posts: 59
Joined: Fri Feb 17, 2017 10:56 pm
Country: -

Re: Build Compile amod [Please help]

Post by darozas » Sun Feb 19, 2017 11:25 am

So like this ??\

Image

But where do you connect trim lines to megasound???


Regards

User avatar
MikeB
9x Developer
Posts: 16586
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Build Compile amod [Please help]

Post by MikeB » Sun Feb 19, 2017 12:03 pm

Yes like that. The trims connect to Port D bit 3 and 4 I believe, on the Megasound.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

darozas
Posts: 59
Joined: Fri Feb 17, 2017 10:56 pm
Country: -

Re: Build Compile amod [Please help]

Post by darozas » Sun Feb 19, 2017 6:23 pm

Thanks for your time again

Ok i back to testing again

Did all as above flashed "amod_lastSer.hex" TEST 1

But still got nothing on speaker just ticking (like old watch)

Tested sd card adapter on arduino all fine detects it creates file delete file all good.

If i try to upload sound file trough serial in eepe i get error "Communication Fail(2)"

And some times it shows that all uploaded but nothing gets on sd card (Fully formatted to FAT32)

And serial giving me this "XXXXXXXXXXX$XXXXXXXXXXXXX$" and so on

If i type 1 to 9 nothing happens but if i do "0 space it drops bootloader"

Thanks again
Regards

User avatar
MikeB
9x Developer
Posts: 16586
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Build Compile amod [Please help]

Post by MikeB » Sun Feb 19, 2017 7:52 pm

When you type 1 to 9, does the 1 to 9 get sent back?
TESTING mode probably makes the upload fail due to sending the 'X' characters.
Also, in TESTING mode, the file 0040.WAV is played repeatedly. Put a 0040.WAV file on and see what happens then.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

darozas
Posts: 59
Joined: Fri Feb 17, 2017 10:56 pm
Country: -

Re: Build Compile amod [Please help]

Post by darozas » Sun Feb 19, 2017 8:06 pm

Thanks for reply again

File 0040.waw there but nothing changes if i type 1 to 9 and all files from 0001 to 0009 is there

it just make ticking noise constant like old watch "tick tick tick tick" really fast and its so quiet aswell i have to put speaker right to my ear to hear it?

I have double checked all resistors and all good

Loosing world to live here

Regards

User avatar
MikeB
9x Developer
Posts: 16586
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Build Compile amod [Please help]

Post by MikeB » Sun Feb 19, 2017 9:48 pm

Please try flashing this file. It is the normal (not TESTING) serial version.
With this, try accessing the SD card from eepe.

Mike.
Attachments
amod_lastSer.zip
(26.94 KiB) Downloaded 39 times
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

darozas
Posts: 59
Joined: Fri Feb 17, 2017 10:56 pm
Country: -

Re: Build Compile amod [Please help]

Post by darozas » Sun Feb 19, 2017 10:02 pm

Thanks again for your time

Flashed with file you just send

And i get Image

But if i remove SD card it finish upload without error

Image

And adapter works fine with arduino sketch

Regards

User avatar
jhsa
Posts: 18982
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Build Compile amod [Please help]

Post by jhsa » Sun Feb 19, 2017 11:43 pm

Ok, maybe some good pictures of your setup, including the serial connection to pins 27 and 28 on the radio (former trims).

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
MikeB
9x Developer
Posts: 16586
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Build Compile amod [Please help]

Post by MikeB » Sun Feb 19, 2017 11:48 pm

What size is your SD card?
Do you have another SD card you could try (1Gb or 2Gb if possible)?

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

darozas
Posts: 59
Joined: Fri Feb 17, 2017 10:56 pm
Country: -

Re: Build Compile amod [Please help]

Post by darozas » Mon Feb 20, 2017 8:07 am

Thanks you both for your time again

Here is my setup pictures

Image

And

Image

Sd card im using is 2gb

And dont have anything else that small to test with

Regards

User avatar
jhsa
Posts: 18982
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Build Compile amod [Please help]

Post by jhsa » Mon Feb 20, 2017 9:24 am

What is the voltage input of your SD card reader? Mine are 5V
If yours is also 5v and you supply it with the 3.3v from the board, it might not work because the voltage is too low for its internal regulator?
I will check how I did power it on my ArduSound board, which is a voice module for the 9x using an Arduino Pro-Mini..
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

darozas
Posts: 59
Joined: Fri Feb 17, 2017 10:56 pm
Country: -

Re: Build Compile amod [Please help]

Post by darozas » Mon Feb 20, 2017 10:33 am

Hi again and thanks for your time

I have rewired Vin to FTDI 5V sd card reads 3.3 and input to adapters is 5V

Still no go "Buzz tick tick" No audio coming out

Should i just install module to Radio???

Regards

User avatar
MikeB
9x Developer
Posts: 16586
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Build Compile amod [Please help]

Post by MikeB » Mon Feb 20, 2017 10:43 am

There should be a connection to the board for the original beeper signal. Please try connecting this in (with a ground connection), and see if the beeper (set to "pispkr") sounds come out. This will test some of the audio amplifier circuit.

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 18982
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Build Compile amod [Please help]

Post by jhsa » Mon Feb 20, 2017 11:09 am

Also, in Radio "Setup/AudioHaptic" you need to set "Sound Mode" to "Megasound" for the serial communication to work, I think. It's been a while. Also a link to the ArduVoice project. It might help.

viewtopic.php?f=5&t=6831

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

darozas
Posts: 59
Joined: Fri Feb 17, 2017 10:56 pm
Country: -

Re: Build Compile amod [Please help]

Post by darozas » Mon Feb 20, 2017 3:00 pm

Thanks again

What kind on output do i need expect with "pispkr

I get like truluup when i turn it on

Regards

User avatar
MikeB
9x Developer
Posts: 16586
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Build Compile amod [Please help]

Post by MikeB » Mon Feb 20, 2017 3:14 pm

Probably correct. Do you get "beeps" when you use a trim switch?

I think most things are working, but there is a problem accessing the SD card.
What software did you use to format the card?
It is recommended to use the "SDFormatter" program from the Sd Association (https://www.sdcard.org/downloads/formatter_4/).

Mike.
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!


Post Reply

Return to “Software”