gruvin9x board no buzzer in opentx

Help with any software/desktop related issues. e.g. companion9x, eePe, etc
Post Reply
Koarl
Posts: 203
Joined: Sun Jul 01, 2012 5:08 pm
Country: -

gruvin9x board no buzzer in opentx

Post by Koarl » Thu Nov 12, 2015 10:12 am

Greetings gents,

After some trouble and a lot of help here I got it managed to flash my Turnigy 9x with gruvin board with opentx. But now the buzzer doesn´t work anymore. When I reflash with gruvin9x it works fine.
I have a buzzer from a old pair of headphones installed so no stock piezo.
Is there a bug in opentx?

Thanks!


User avatar
Kilrah
Posts: 10416
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: gruvin9x board no buzzer in opentx

Post by Kilrah » Thu Nov 12, 2015 1:43 pm

As you replaced the stock piezo you might need to check the "audio" firmware option in companion and re-download the appropriate firmware.

Envoyé de mon SM-G920F en utilisant Tapatalk

Koarl
Posts: 203
Joined: Sun Jul 01, 2012 5:08 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by Koarl » Thu Nov 12, 2015 1:59 pm

Thanks kilrah,

That was my first thought too. But. In companion. I couldn't find such an option.
Where can I find or how do I download this certain firmware?

Thanks

Koarl
Posts: 203
Joined: Sun Jul 01, 2012 5:08 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by Koarl » Thu Nov 12, 2015 11:38 pm

I have searched through companion very long and googled a lot. But I can't find an option were I can choose a firmware that supports the replaced buzzer.
Where can I find this setting or is this configuration not supported?

Thanks!

User avatar
rperkins
Posts: 1422
Joined: Sun Jan 08, 2012 12:51 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by rperkins » Fri Nov 13, 2015 3:07 am

Here is the Makefile if you were going to compile your own version of opentx. within this file is a section titled 'build options'. I am not familiar with these options but upon a glance did not see what I think you are looking for. I would imagine every option possible for opentx would be listed in this file.

https://github.com/opentx/opentx/blob/m ... c/Makefile

Maybe a developer of opentx can confirm or deny this option. Maybe it is something that can be easily added to the opentx source.


User avatar
rperkins
Posts: 1422
Joined: Sun Jan 08, 2012 12:51 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by rperkins » Fri Nov 13, 2015 3:12 am

Here is the gruvin src makefile which has this option

# gruvin: BEEPER. Values = BUZZER, BUZZER_MOD or SPEAKER
# (without a mod, BUZZER can make PPM jack output switch from output to input at random)
# SPEAKER mode actually works on the stock radio, using the stock beeper. Sort of sound OK(ish).
BEEPER = SPEAKER

https://code.google.com/p/gruvin9x/sour ... efile.dist

I imagine someone would have to see what changes are made for these various options and incorporate them into opentx. I have no idea how many gruvin boards were produced , still in use, using opentx, and have this mod, that would make this a priority improvement to opentx

User avatar
gruvin
9x Developer
Posts: 131
Joined: Tue Jul 24, 2012 10:02 pm
Country: New Zealand
Location: Auckland
Contact:

Re: gruvin9x board no buzzer in opentx

Post by gruvin » Fri Nov 13, 2015 3:42 am

Please see my reply PM.

If it's the G9X 4.x board, then you just need to wire your speaker to the speaker socket, instead of where the piezo used to be. You can put the piezo back if you still have it. Then you can have loud beeps for some things (say alarms) and the speaker for others, like trim-up down and menu nav sounds, for example. That's what I had on mine, I think. (I've been using a Taranis for some time now.)

Gruvin.

User avatar
rperkins
Posts: 1422
Joined: Sun Jan 08, 2012 12:51 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by rperkins » Fri Nov 13, 2015 3:45 am

Here he said he has a version 4.2, so sounds like this should work for him

viewtopic.php?t=7804#p104322

Koarl
Posts: 203
Joined: Sun Jul 01, 2012 5:08 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by Koarl » Fri Nov 13, 2015 11:53 pm

Thanks for your answers!

How do I compile such a file?

I have connected speaker to the port on the board which is 4.2

I'm outa town again but I let you know when I have tested anything.

Thanks!

User avatar
rperkins
Posts: 1422
Joined: Sun Jan 08, 2012 12:51 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by rperkins » Sat Nov 14, 2015 12:27 am

gruvin wrote: If it's the G9X 4.x board, then you just need to wire your speaker to the speaker socket, instead of where the piezo used to be. You can put the piezo back if you still have it. Then you can have loud beeps for some things (say alarms) and the speaker for others, like trim-up down and menu nav sounds, for example. That's what I had on mine, I think.
Gruvin.
Gruvin gave you the best advice. It isnt just a matter of compiling, it would require modifications of the firmware. Opentx does not provide an option for your current hardware configuration.

User avatar
gruvin
9x Developer
Posts: 131
Joined: Tue Jul 24, 2012 10:02 pm
Country: New Zealand
Location: Auckland
Contact:

Re: gruvin9x board no buzzer in opentx

Post by gruvin » Sat Nov 14, 2015 12:31 am

rperkins wrote:Opentx does not provide an option for your current hardware configuration.
Did I miss something? He says his speaker is connected to the speaker port on the G9 board. That should just work, sound options in the menu not withstanding.

User avatar
rperkins
Posts: 1422
Joined: Sun Jan 08, 2012 12:51 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by rperkins » Sat Nov 14, 2015 12:37 am

gruvin wrote: Did I miss something? He says his speaker is connected to the speaker port on the G9 board. That should just work, sound options in the menu not withstanding.
I dont know the details of his mod. He just said it didnt work in the first post. Then I found the options for gruvin9x and also viewed this picture
https://code.google.com/p/gruvin9x/sour ... nstall.jpg
https://gruvin9x.googlecode.com/svn/tru ... nstall.jpg

So really it was just my guess that it was a hardware modification that isnt supported. I am probably mistaken
Last edited by rperkins on Sat Nov 14, 2015 1:10 am, edited 1 time in total.

User avatar
gruvin
9x Developer
Posts: 131
Joined: Tue Jul 24, 2012 10:02 pm
Country: New Zealand
Location: Auckland
Contact:

Re: gruvin9x board no buzzer in opentx

Post by gruvin » Sat Nov 14, 2015 1:01 am

OK. Fair enough. I guess we'll know soon enough. :-) (The pic arrived broken for me, sorry.)

User avatar
rperkins
Posts: 1422
Joined: Sun Jan 08, 2012 12:51 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by rperkins » Sat Nov 14, 2015 1:13 am

gruvin wrote:The pic arrived broken for me, sorry.)
sorry, you had to click 'view raw file'. I fixed the link above so it will work. But I have no idea what type of mod he has on his radio or if it was one of the mods listed in the gruvin makefile

Koarl
Posts: 203
Joined: Sun Jul 01, 2012 5:08 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by Koarl » Sun Nov 15, 2015 6:12 pm

I´m back home now.
In the radio settings I couldn´t find such a sound option where I can switch between piezo and the speaker. As I already said it works just right away when I flash the transmitter to gruvin9x. So hardware can´t be the problem. Maybe I hit the wrong FW version and can´t figure out which is the right one.


Thanks!

User avatar
rperkins
Posts: 1422
Joined: Sun Jan 08, 2012 12:51 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by rperkins » Sun Nov 15, 2015 6:21 pm

I think Gruvin gave the best advice here
viewtopic.php?p=105317#p105088

This would require opening the radio and moving some wires, I think.

I dont believe there is a FW version for opentx that supports what you want. It may help if you fully explain what modification have been done to your hardware, and what particular FW you were using with gruvin9x. Then again Gruvin probably knows exactly what you have modified and that is why he recommended the above linked solution

Koarl
Posts: 203
Joined: Sun Jul 01, 2012 5:08 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by Koarl » Sun Nov 15, 2015 6:33 pm

Actually I have not done any real mod. I just wired a Speaker from some old headphones to the speaker port on the port. Gruvin wrote me a PM were he said that there must be a sound option in the radio menu were one can choose between speaker and piezo. But I couldn´t find such an option.

In the attachement is the gruvin version were the speaker beeps just like it should.

Thanks!

User avatar
Kilrah
Posts: 10416
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: gruvin9x board no buzzer in opentx

Post by Kilrah » Sun Nov 15, 2015 6:42 pm

You might want to try older OpenTX versions, 2.0 or even pre-github.
Developments that applied to the Gruvin board stopped probably 3 years ago or so, so newer versions shouldn't get you much extra but due to decrease in usage/testing probably rather got more and more broken...
If an older version has the option you talk about then it would give a path to investigate/fix the regression.

Koarl
Posts: 203
Joined: Sun Jul 01, 2012 5:08 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by Koarl » Sun Nov 15, 2015 6:59 pm

Thanks Kilrah!

Maybe this does the trick, but how do I download an older version? Companion always downloads the latest version, doesn´t it?

User avatar
Kilrah
Posts: 10416
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: gruvin9x board no buzzer in opentx

Post by Kilrah » Sun Nov 15, 2015 7:03 pm

You need older versions of companion. Companion 2.1 will download 2.1 firmware, companion 2.0 will download 2.0 firmware, companion9x 1.52 will download pre-github firmware.

EDIT: pre-github is not available anymore actually, the server that was providing it is gone so it would be self-compile only. 2.0 is available and supported.

Koarl
Posts: 203
Joined: Sun Jul 01, 2012 5:08 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by Koarl » Sun Nov 15, 2015 8:20 pm

Finally my Tx does what it should! I switched to companion 2.0.8 and that worked. Thank you all for your help!

Koarl
Posts: 203
Joined: Sun Jul 01, 2012 5:08 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by Koarl » Sun Nov 15, 2015 9:33 pm

I know this is offtopic, but I have to other questions now:

In the servo monitor the rudderstick runs in the wrong direction, how can I fix this?
I want to set the timer with the trainerswitch, on my Taranis it´s just the SH(down arrow)t function, but I can´t find this on my 9x. How can I set this?
To clear things, the timer should count up when I pull the trainerswitch for one second.

Thanks!

Koarl
Posts: 203
Joined: Sun Jul 01, 2012 5:08 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by Koarl » Tue Nov 17, 2015 11:45 am

I tried several firmware versions of opentx and gruvin9x, but the problem with the rudderstick stays the same. Maybe I should switch the two outer wires of the poti?

I also couldn't manage the timer being controlled with the trainer switch.

Koarl
Posts: 203
Joined: Sun Jul 01, 2012 5:08 pm
Country: -

Re: gruvin9x board no buzzer in opentx

Post by Koarl » Thu Nov 19, 2015 1:02 pm

I switched the two wires of the poti, now the rudderstick works as it should.

But I still can't get the timer working how I want. Maybe I'll open a new thread for it.

WendoNZ
Posts: 50
Joined: Fri Dec 21, 2012 4:00 am
Country: -

Re: gruvin9x board no buzzer in opentx

Post by WendoNZ » Thu Dec 31, 2015 7:48 am

Having just upgraded from the old 1.x versions to 2.1 I can confirm somewhere between 2.0 and 2.1 the buzzer options on the gruvin9x board stopped working. On the 2.0 branch it works fine as long as you don't specify the voice option, on the 2.1 branch it doesn't work at all even with the voice option not selected, you get the same quiet clicking from the buzzer you would get if you had selected the voice option


Post Reply

Return to “Software”