XJT module + X8R receiver = only 1 channel works?

Help with any software/desktop related issues. e.g. companion9x, eePe, etc
Post Reply
Codi
Posts: 4
Joined: Tue Mar 06, 2018 6:14 pm
Country: -

XJT module + X8R receiver = only 1 channel works?

Post by Codi » Sat Apr 07, 2018 7:35 pm

Hi.
I have JR mx-22 radio and I've purchased new XJT module with EU LBT sw (at least sticker says it).
Original X9D radio has no LBT firmware and all my receivers are "old" no LBT and for the moment I wish to stay with it.
For the new EU LBT XJT module I tried flash X8R receiver with EU LBT firmware (151118 also 170210). The efect is:
- X8R can now to bind with new XJT module
- from X8R only CH1 put signal to servo (servo is in one position)
- all other channels are quiet (no signal I can move connected servo without any issue)
- any sticks movement on JR with new XJT module has no effect on that "working" CH1

After several hours of flashing back and forth - I'm lost :(

Flashing of X8R via servo cable from X9D (OpenTx updated to v221, bootloader updated to v221)

Any ideas what could be the reason that X9R binds to XJT with CH1 active (and no respond on stick movement)?

Best regards,
Codi.

User avatar
MikeB
9x Developer
Posts: 15805
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: XJT module + X8R receiver = only 1 channel works?

Post by MikeB » Sat Apr 07, 2018 9:45 pm

Since you want to use this module in the JR, are you using PPM as the protocol for the external module?
I suggest, if you aren't, changing to PPM, then bind using the button on the back of the module (uses a default Rx Number).
Check the mixer is set to send at least 4 channels, and check the "bars" display show all 4 channels responding to controls, then check if you have servos operating.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

Codi
Posts: 4
Joined: Tue Mar 06, 2018 6:14 pm
Country: -

Re: XJT module + X8R receiver = only 1 channel works?

Post by Codi » Sun Apr 08, 2018 5:24 pm

Jr is in PPM18 mode (I also checked PPM24, SPCM,...) no changes in receiver behaviour.
In servo view on JR, the bars changes their state, so it seems it is fine.
What is strange, as I post it above - there is no issue to link X8R with XJT. They are linked.
The issue is X8R is setting CH1 in neutral and don't respond to any control. The rest channels from X8R have no signal at all (servo can be rotate without any issue by finger).

Any ideas?

Best regards,
Codi.

User avatar
Kilrah
Posts: 9666
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: XJT module + X8R receiver = only 1 channel works?

Post by Kilrah » Sun Apr 08, 2018 5:30 pm

Seems like you might have bound the receiver in the mode where the servo pins output channels 9 to 16 instead of 1-8.

Codi
Posts: 4
Joined: Tue Mar 06, 2018 6:14 pm
Country: -

Re: XJT module + X8R receiver = only 1 channel works?

Post by Codi » Tue Apr 10, 2018 4:59 pm

Ok I found it.
FW 170210 for X8R is not working with XJT module. Firstly I had to flash receiver with sw 151118, then bind it to upgraded X9D and than bind it again to JR with XJT.
Now it works :)


User avatar
Kilrah
Posts: 9666
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: XJT module + X8R receiver = only 1 channel works?

Post by Kilrah » Wed Apr 11, 2018 3:50 am

Or update the module then.

Codi
Posts: 4
Joined: Tue Mar 06, 2018 6:14 pm
Country: -

Re: XJT module + X8R receiver = only 1 channel works?

Post by Codi » Wed Apr 11, 2018 7:53 pm

I didn't check XJT module firmware - it was new, freshly purchased.
Now I'm happy with my receivers and XJT module in JR :)

Post Reply

Return to “Software”