Unable to check for updates Ubuntu 16.04

Help with any software/desktop related issues. e.g. companion9x, eePe, etc
Post Reply
TaranisX7User
Posts: 11
Joined: Sun Mar 04, 2018 5:34 pm
Country: -

Unable to check for updates Ubuntu 16.04

Post by TaranisX7User » Sun Mar 04, 2018 5:42 pm

Software is installed and linking to my Taranis x7. I have selected to "use release candidates" in drop down menu from setting. I have also tried "use nightly builds".....no luck. Software is version 2.2.1. X7 has 2.2.0 on it. I have tried looking for updates for the last couple days....no luck. Internet connection is good. Any suggestions? Thanks

jtaylor
Posts: 131
Joined: Fri Nov 01, 2013 1:31 am
Country: -
Location: Wexford (Pittsburgh), PA

Re: Unable to check for updates Ubuntu 16.04

Post by jtaylor » Sun Mar 04, 2018 9:58 pm

If you have 2.2.1 Companion you have either already downloaded 2.2.1 firmware or said to ignore it. In either case checking for updates won't download it again. If you already downloaded the firmware just burn it to the transmitter. And if you have either not downloaded it or can't remember where you put it just download it again manually File-Download and click the "Download Firmware" button.

Check for updates checks or updates to what has been download, not what is on the transmitter.

Jim

TaranisX7User
Posts: 11
Joined: Sun Mar 04, 2018 5:34 pm
Country: -

Re: Unable to check for updates Ubuntu 16.04

Post by TaranisX7User » Sun Mar 04, 2018 10:55 pm

Thanks for the reply. When I click on the the "write firmware to radio" it asks for a link to load the firmware from on my computer. Is there a site to manually download the firmware besides the Companion program. Is that the correct way to install the firmware? Also it shows my bootloader on the X7 radio as 2.2.0. Is there a way to check the firmware on the radio? Thank you!

TaranisX7User
Posts: 11
Joined: Sun Mar 04, 2018 5:34 pm
Country: -

Re: Unable to check for updates Ubuntu 16.04

Post by TaranisX7User » Sun Mar 04, 2018 11:07 pm

Ok I did confirm my X7 radio firmware is 2.2.0 with a date of 2017-05-17. Bootloader is also 2.2.0

jtaylor
Posts: 131
Joined: Fri Nov 01, 2013 1:31 am
Country: -
Location: Wexford (Pittsburgh), PA

Re: Unable to check for updates Ubuntu 16.04

Post by jtaylor » Sun Mar 04, 2018 11:54 pm

Yes, you must first download the firmware to your computer using Companion, there is no other way to download it. Companion knows from where to download it. Did you try to download it manually as I told you in my last post? Click "File" from the menu, click Download form the file drop down and click the "Download Firmware Button". Tell the computer where to store the file and when you go to write firmware point it to the file you just downloaded.

You can check the version on the radio by going into Radio Setup (Menu-long) and paging forward to the version screen.


TaranisX7User
Posts: 11
Joined: Sun Mar 04, 2018 5:34 pm
Country: -

Re: Unable to check for updates Ubuntu 16.04

Post by TaranisX7User » Mon Mar 05, 2018 12:48 am

Still no luck. I tried going to" file" then to "download", and clicked the "download firmware" button. Still responds with "unable to check for updates" Can anyone confirm if the server is down? I installed this to my Ubuntu 16.04 computer by downloading the PPA link and clicking on the Xenial link. After it was downloaded it I just chose to install when asked. The program runs and links to the radio, maybe I missed a step? Is there a way to uninstall the Companion to try a fresh install? I tried to delete the program from software center but it still runs even after reboot and icon is still present in sidebar. Thanks again

jtaylor
Posts: 131
Joined: Fri Nov 01, 2013 1:31 am
Country: -
Location: Wexford (Pittsburgh), PA

Re: Unable to check for updates Ubuntu 16.04

Post by jtaylor » Mon Mar 05, 2018 2:54 am

The server was up when I posted last. I downloaded a x9d firmware just to make sure. I'm not familiar with Ubuntu, I use Windows 10 and openSUSE Leap 42.3 and nether one of them have a problem downloading firmware. I'm pretty sure a few people on here are using Ubuntu so maybe they can suggest something in the morning.

TaranisX7User
Posts: 11
Joined: Sun Mar 04, 2018 5:34 pm
Country: -

Re: Unable to check for updates Ubuntu 16.04

Post by TaranisX7User » Mon Mar 05, 2018 3:08 am

Great, I'll check back in the AM. Thanks

jtaylor
Posts: 131
Joined: Fri Nov 01, 2013 1:31 am
Country: -
Location: Wexford (Pittsburgh), PA

Re: Unable to check for updates Ubuntu 16.04

Post by jtaylor » Mon Mar 05, 2018 4:40 pm

Since nobody that knows Ubuntu jumped in with suggestions I'll give you a couple more. The site that gets checked for updates is downloads.open-tx.org.

1. Make sure you can get to it by pinging it:
HP-Linux:~/frsky/opentx/git/opentx/ # ping downloads.open-tx.org
PING downloads.open-tx.org (51.15.192.53) 56(84) bytes of data.
64 bytes from download.open-tx.org (51.15.192.53): icmp_seq=1 ttl=50 time=171 ms

2. If you can ping it the file that gets checked for updates is:
https://downloads.open-tx.org/2.2/relea ... opentx.txt if you put that in a browser you shoud get a response simular to:
#define DATE "2018-01-09"
#define TIME "09:16:27"
#define VERSION "2.2.1"

#define VERSION_MAJOR 2
#define VERSION_MINOR 2
#define VERSION_REVISION 1
#define GIT_STR "cca71808"

3. If both of these work open a terminal window and try running Companion from the command line and see what kind of messages you get when you try to download firmware. When it works you should get something like:
D] mainwindow.cpp::MainWindow::checkForUpdates():264 - Checking for Companion update "https://downloads.open-tx.org/2.2/relea ... inux.stamp"
[D] mainwindow.cpp::MainWindow::checkForUpdates():276 - Checking for firmware update "https://downloads.open-tx.org/2.2/relea ... opentx.txt"
[D] mainwindow.cpp::MainWindow::checkForUpdates():276 - Checking for firmware update "https://downloads.open-tx.org/2.2/relea ... opentx.txt"
[D] mainwindow.cpp::MainWindow::startFirmwareDownload():541 - Downloading firmware "https://downloads.open-tx.org/2.2/relea ... lua-en.bin"

I don't know Ubuntu so if you're sure you have the correct version of Companion installed and you know how to use the command line this might give you a hint as to what's wrong. Please report back with the solution when you find it.

Jim

ReSt
Posts: 1477
Joined: Tue Dec 27, 2011 11:34 pm
Country: -

Re: Unable to check for updates Ubuntu 16.04

Post by ReSt » Mon Mar 05, 2018 7:09 pm

I had a similar problem some days ago with windows XP where I have an older version of Firefox running. This is the computer I have used up to last week to download the er9x/Ersky9x sourcecode from Github, so I can modify and compile it by myself.
All of a sudden, "Github clone" ended with an error, rejecting to download the code.
When I open the github site with my (old) Firefox, I see a message displayed, that "Github no longer supports old versions of Firefox"
I believe, this is, because they do no longer support the TLS0 communication protocol.

Could it be that you have a similar problem with your Ubuntu?

Reinhard

TaranisX7User
Posts: 11
Joined: Sun Mar 04, 2018 5:34 pm
Country: -

Re: Unable to check for updates Ubuntu 16.04

Post by TaranisX7User » Mon Mar 05, 2018 7:27 pm

Jim, Thanks for helping! So I tried pinging the server and all is well, same results as you had. But when starting the program from command line I get an error message. Hopefully it makes some sense to you. So glad people are willing to help and know so much about computing. Here's a screenshot of what I'm getting back from the terminal.

[D] SimulatorLoader::registerSimulators():75 - [simulator.interface.loader] Registered "opentx-x12s" simulator in "/usr/lib/companion22/libopentx-x12s-simulator.so" and unloaded: true
[D] SimulatorLoader::registerSimulators():60 - [simulator.interface.loader] Trying to register simulator in "libopentx-x7-simulator.so"
[D] SimulatorLoader::registerSimulators():75 - [simulator.interface.loader] Registered "opentx-x7" simulator in "/usr/lib/companion22/libopentx-x7-simulator.so" and unloaded: true
[D] SimulatorLoader::registerSimulators():60 - [simulator.interface.loader] Trying to register simulator in "libopentx-x9d+-simulator.so"
[D] SimulatorLoader::registerSimulators():75 - [simulator.interface.loader] Registered "opentx-x9d+" simulator in "/usr/lib/companion22/libopentx-x9d+-simulator.so" and unloaded: true
[D] SimulatorLoader::registerSimulators():60 - [simulator.interface.loader] Trying to register simulator in "libopentx-x9d-simulator.so"
[D] SimulatorLoader::registerSimulators():75 - [simulator.interface.loader] Registered "opentx-x9d+" simulator in "/usr/lib/companion22/libopentx-x9d-simulator.so" and unloaded: true
[D] SimulatorLoader::registerSimulators():60 - [simulator.interface.loader] Trying to register simulator in "libopentx-x9e-simulator.so"
[D] SimulatorLoader::registerSimulators():75 - [simulator.interface.loader] Registered "opentx-x9e" simulator in "/usr/lib/companion22/libopentx-x9e-simulator.so" and unloaded: true
[D] SimulatorLoader::registerSimulators():83 - [simulator.interface.loader] Found libraries: ("opentx-9x", "opentx-9xrpro", "opentx-gruvin9x", "opentx-mega2560", "opentx-sky9x", "opentx-x12s", "opentx-x7", "opentx-x9d", "opentx-x9d+", "opentx-x9e")
[D] MainWindow::checkForUpdates():264 - Checking for Companion update "https://downloads.open-tx.org/2.2/rc/co ... inux.stamp"
[W] unknown():0 - [qt.network.ssl] QSslSocket: cannot call unresolved function SSLv23_client_method
[W] unknown():0 - [qt.network.ssl] QSslSocket: cannot call unresolved function SSL_CTX_new
[W] unknown():0 - [qt.network.ssl] QSslSocket: cannot call unresolved function SSL_library_init
[W] unknown():0 - [qt.network.ssl] QSslSocket: cannot call unresolved function ERR_get_error
[W] unknown():0 - [qt.network.ssl] QSslSocket: cannot call unresolved function ERR_get_error

jtaylor
Posts: 131
Joined: Fri Nov 01, 2013 1:31 am
Country: -
Location: Wexford (Pittsburgh), PA

Re: Unable to check for updates Ubuntu 16.04

Post by jtaylor » Mon Mar 05, 2018 8:46 pm

That's a nasty little problem...but at least it explains why you can't connect. There is a problem with Companion's qt version being able to get to use https secure connections. Sorry, but I don't know anything about Ubuntu and won't be much help. My guess is that it is a problem with your systems openssl version. Either it doesn't have openssl installed or there is a mismatch between the version qt/Companion was built with and the version on your system. My only suggestion would be to make sure openssl is installed (however you do that on Ubuntu) and upgrade it if it isn't the latest level. If that doesn't work and nobody else jumps in with a fix you might try going over to the opentx chat room ( https://opentx.rocket.chat/channel/OpenTX_General ) and point them to this post and ask for suggestions.

Jim

TaranisX7User
Posts: 11
Joined: Sun Mar 04, 2018 5:34 pm
Country: -

Re: Unable to check for updates Ubuntu 16.04

Post by TaranisX7User » Mon Mar 05, 2018 11:36 pm

Thanks Ill look into updating or installing ASAP and report back.

TaranisX7User
Posts: 11
Joined: Sun Mar 04, 2018 5:34 pm
Country: -

Re: Unable to check for updates Ubuntu 16.04

Post by TaranisX7User » Mon Mar 05, 2018 11:50 pm

No luck. I updated OpenSSL and still the same problem. Maybe ill reinstall the OS. IF anyone has any other suggestions before that happens, please let me know. Thanks for all the help.

jtaylor
Posts: 131
Joined: Fri Nov 01, 2013 1:31 am
Country: -
Location: Wexford (Pittsburgh), PA

Re: Unable to check for updates Ubuntu 16.04

Post by jtaylor » Tue Mar 06, 2018 2:40 pm

Before doing something that drastic I would check a couple more things. I don't know what Ubuntu installs with openssl so I would check if libopenssl-devel is installed and also (I'm guessing you have a 64 bit system) that the 32 bit libopenssl-32bit libraries are installed. If not I would install them (again don't ask me how) and try again. After that I'm out of ideas.

Also just for curiosity what version of openssl do you have installed 1.0.something or 1.1.something?

Jim

TaranisX7User
Posts: 11
Joined: Sun Mar 04, 2018 5:34 pm
Country: -

Re: Unable to check for updates Ubuntu 16.04

Post by TaranisX7User » Tue Mar 06, 2018 10:57 pm

Great! I’ll have a look and report back. Thanks!

TaranisX7User
Posts: 11
Joined: Sun Mar 04, 2018 5:34 pm
Country: -

Re: Unable to check for updates Ubuntu 16.04

Post by TaranisX7User » Thu Mar 08, 2018 10:17 pm

open ssl says up to date. I'm looking at making sure 32 bit version is installed. Thanks. OpenSSL 1.0.2g-1ubuntu4.10

TaranisX7User
Posts: 11
Joined: Sun Mar 04, 2018 5:34 pm
Country: -

Re: Unable to check for updates Ubuntu 16.04

Post by TaranisX7User » Thu Mar 08, 2018 10:33 pm

ITS A MIRACLE! Jim your a genius! THANK YOU! So for anyone with similar problem, it was not having the libssl32 version installed. Here is the terminal command I used fix the problem.

sudo apt-get install libssl1.0.0:i386

Again so for spending the time to point me in the right direction. Have a good day!

User avatar
deaconFlyer
Posts: 75
Joined: Fri Apr 05, 2013 11:22 am
Country: Canada
Location: Ontario

Re: Unable to check for updates Ubuntu 16.04

Post by deaconFlyer » Thu Mar 08, 2018 10:41 pm

Short of doing a complete Companion removal, followed by a purge command and then a reboot and reinstall not too many suggestions.

I would for certain go looking for settings in the /.config/OpenTX directory before reinstalling as well and rename it OpenTX-old. In the terminal I do a complete "sudo apt-get autoremove" followed by "sudo apt-get update" and "sudo apt-get upgrade" and a reboot.

Ubuntu 18.04 is coming out on April 25. It has entered into the final freeze periods this week I believe. I went from 16.04 to 17.10.1 and must admit, I am very, very happy I did. All sorts of video and wifi issues disappeared with the new kernel.

Making the upgrade required a complete reinstall of Companion / OpenTX. My radio files are all stored in Dropbox so I did not have to worry about them.

And yes, I too had to do "sudo apt-get install libssl1.0.0:i386"

jtaylor
Posts: 131
Joined: Fri Nov 01, 2013 1:31 am
Country: -
Location: Wexford (Pittsburgh), PA

Re: Unable to check for updates Ubuntu 16.04

Post by jtaylor » Fri Mar 09, 2018 8:17 pm

Glad you got it working and thanks for letting us know.

Jim

Post Reply

Return to “Software”