Realistic driving in land vehicles.

Help with any software/desktop related issues. e.g. companion9x, eePe, etc
Rad
Posts: 176
Joined: Wed Apr 20, 2016 3:43 pm
Country: -

Realistic driving in land vehicles.

Post by Rad » Wed Feb 14, 2018 3:47 pm

Hi guys, today I need a little help in the software related area.

My idea is to have the most realistic driving of land vehicles possible, so, I would like to have the throttle stick just for throttle and use the 3-pos ID switch for the gear selection.

So, for example with the ID in center position, it would be neutral gear, UP would let me drive forwards, and DOWN would let me drive the vehicle backwards. When in forwards, the stick at the top down would be 0 signal (instead of -100) the center position would be +50 (instead of 0) and the top up +100. And when in backwards the same but with negative numbers. I guess you get the idea, lol. And also in neutral the vehicle wont move.

How could I do it?

This the beginning of my probarbly quite-complicated-to-be-fun way of driving. Then I was planning with some push switches at the back of the radio, to be able to change speeds. I mean, to have something like 3-4 speeds inside the forward gear, and changing them with the push buttons.

What do you think? Has it been invented before? How could I do it?

As always, thanks in advance!
Last edited by Rad on Thu Feb 15, 2018 9:51 am, edited 1 time in total.

User avatar
jhsa
Posts: 18143
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Realistic driving ind land vehicles.

Post by jhsa » Wed Feb 14, 2018 4:33 pm

All very possible.. what firmware and what radio are you using?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Rad
Posts: 176
Joined: Wed Apr 20, 2016 3:43 pm
Country: -

Re: Realistic driving ind land vehicles.

Post by Rad » Wed Feb 14, 2018 5:56 pm

jhsa wrote:
Wed Feb 14, 2018 4:33 pm
All very possible.. what firmware and what radio are you using?

João
9xtreme and 9xr pro with ersky9xProvR221g2

User avatar
jhsa
Posts: 18143
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Realistic driving ind land vehicles.

Post by jhsa » Wed Feb 14, 2018 6:09 pm

ok, good, give me some time.. I will try to help you :) Another challenge for me :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
jhsa
Posts: 18143
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Realistic driving ind land vehicles.

Post by jhsa » Wed Feb 14, 2018 6:25 pm

Ok. for the driving forward / backwards thing.. it is really easy.. I have throttle on ch3

Ch3 0% FULL Switch (ID-)
R 50% Thr Offset (50%) Switch (ID^)
R -50% Thr Offset (-50%) Switch (IDv)

"R" means that the mix is a replace mix.

Now, what do you exactly have in mind for the different gears? :) What values?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW


User avatar
MikeB
9x Developer
Posts: 15811
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Realistic driving ind land vehicles.

Post by MikeB » Wed Feb 14, 2018 6:43 pm

I was going to suggest:
CH3: 50% Thr (Offset 50%)
* -100% sIDx
Where the * indicates a Multiply mix
Only needs 2 mix lines.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 18143
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Realistic driving ind land vehicles.

Post by jhsa » Wed Feb 14, 2018 6:52 pm

Thanks Mike, Will try it.. but he also wants different speeds on different switches.. I thought the way I did it would make it easy to understand what is happening :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Rad
Posts: 176
Joined: Wed Apr 20, 2016 3:43 pm
Country: -

Re: Realistic driving ind land vehicles.

Post by Rad » Wed Feb 14, 2018 7:15 pm

Hi guys, I can not test your mixes today, children sleeping around here and my tanks are very noisy, lol, but Ill try them tomorrow.

My idea about changing speeds is very similar to driving an automatic car. In a car you have the PRND selector: P (Parking) N (Neutral) R (Reverse) D (Drive) Well, with in our radio, using the the ID switch, P and N are Neutral, R is ID down and D is Id UP

In most of the automatic cars, even when automatic, you can change gears up or down pressing buttons in both sides of the steering wheel... Pressing the button in the left side changes to a shorter gear, and in the right to a longer gear... My idea is to do exactly the same after installing the push switches that I am waiting them to arrive from china.

For not complicating the things too much, lets say we can program 3 speeds forwards. When in first gear the vehicle could drive from 0 to +33. In second gear from +34 to +66, and in the last from +67 to +100.

And to have only one speed backwards like something from -1 to -40

EDIT: I just noticed it might not work with momentary push switches... Well, there are more switches in the radio that I can use on that purpose, lol.

User avatar
jhsa
Posts: 18143
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Realistic driving ind land vehicles.

Post by jhsa » Wed Feb 14, 2018 9:10 pm

It will work with momentary switches :D

João

Sent from my BLN-L21 using Tapatalk

My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Rad
Posts: 176
Joined: Wed Apr 20, 2016 3:43 pm
Country: -

Re: Realistic driving ind land vehicles.

Post by Rad » Thu Feb 15, 2018 6:03 pm

jhsa wrote:
Wed Feb 14, 2018 6:25 pm
Ok. for the driving forward / backwards thing.. it is really easy.. I have throttle on ch3

Ch3 0% FULL Switch (ID-)
R 50% Thr Offset (50%) Switch (ID^)
R -50% Thr Offset (-50%) Switch (IDv)

"R" means that the mix is a replace mix.

Now, what do you exactly have in mind for the different gears? :) What values?

João
Im testing this in this vehicle, https://www.youtube.com/watch?v=VNbR3RhvINA

and it worked! BUT I had to add a replace in the 0% FULL Switch (ID-) too. So the selecting gears part works! :)

User avatar
jhsa
Posts: 18143
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Realistic driving in land vehicles.

Post by jhsa » Thu Feb 15, 2018 6:36 pm

And i think i have 3 gears forward working for you.. Give half an hour or so.. will post a file for you to test. I am a bit concerned about your idea of not being able to drive from 0 on every gear.. But that is what I did and have working in eepskye at the moment. As i said will test further and post shortly..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
jhsa
Posts: 18143
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Realistic driving in land vehicles.

Post by jhsa » Thu Feb 15, 2018 7:13 pm

Here is a model file that you can load in eepskye and test..
This one use GVARs Adjusters, Logical switches and Safety switches...

When ID^ is selected, the TRN switch increase the Gears, and the GEA switch decrease the gears. When you installed the pushbuttons, you will have to replace the TRN and GEA switches with them..
After you set the Throttle direction switch to neutral (ID-) and then again to ID^, you must start again from the first gear and the stick must be at the bottom, otherwise the motor won't start. Safety first :mrgreen:

1st Gear - 0 to 34
2nd gear - 34 to 66
3rd gear - 66 to 100

As I said, I have the feeling that all the gears should start from 0 (motor stopped)

When IDv is selected, the throttle moves between 0 and -40 (Reverse)

João
Attachments
Car_Gears.eepm
(4.13 KiB) Downloaded 125 times
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Rad
Posts: 176
Joined: Wed Apr 20, 2016 3:43 pm
Country: -

Re: Realistic driving in land vehicles.

Post by Rad » Sat Feb 17, 2018 8:13 am

Hi Joao, I tested it in one of the tanks.
My experience so far is that it works, but it needs some polishing:
When in neutral it does not move, but the tank makes a sound of being a bit rev up.
When in reverse, it can drive very very fast (Id say maximum speed)
When in forward, with the first gear does not move. (top lower stick makes some rev sounds, a bit more further idle sound, and top up a bit rev sounds)
With the second gear works, but top speed is almost the maximum the vehicle can reach.
With the third gear, seems to work fine.

In order to not to keep you working and making versions for me, how could I modify it myself?

Also if you make another version, could you use CH 2 as throttle? Big thanks here!

We are on the right way :)

User avatar
jhsa
Posts: 18143
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Realistic driving in land vehicles.

Post by jhsa » Sat Feb 17, 2018 10:40 am

Will have a look later, but it did work in the eepskye simulator.. make sure you copied the settings correctly.
Please do something.. post your eeprom here so I can compare and test it in eepskye. Perhaps some other setting is preventing it from working..

João

EDIT: I read your post again, it looks like there is some unwanted offset somewhere. Please post the eeprom.. :)


My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Rad
Posts: 176
Joined: Wed Apr 20, 2016 3:43 pm
Country: -

Re: Realistic driving in land vehicles.

Post by Rad » Sat Feb 17, 2018 11:33 am

Hi. This is the memory of my 9xtreme. Your model is under the name of Gears.

The other model geared is the "Tamiya Grd" but this has no speeds, just the gears.
Attachments
modelos.rar
(1.39 KiB) Downloaded 35 times

User avatar
jhsa
Posts: 18143
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Realistic driving in land vehicles.

Post by jhsa » Sat Feb 17, 2018 12:17 pm

I found a little problem as I didn't know, or didn't remember that you had changed the GEA switch to a 3 position switch.. Ok, TRH switch increases gears, and GEA- decreases gear now.
I also changed the Throttle to Channel 2. if the model is not responding to the speeds you need, please look at the radio numerical output screen while you move the throttle a write down the numbers when you move the throttle at the required speeds.. Then I can change them..

Also, I don't know how the tamya_Grd model worked for you as it was completely messed up :)
You seem to use the radio in mode 1 (throttle on the right hand side)??

João
Attachments
Gears.eepm
(4.12 KiB) Downloaded 119 times
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Rad
Posts: 176
Joined: Wed Apr 20, 2016 3:43 pm
Country: -

Re: Realistic driving in land vehicles.

Post by Rad » Sat Feb 17, 2018 12:50 pm

jhsa wrote:
Sat Feb 17, 2018 12:17 pm
I found a little problem as I didn't know, or didn't remember that you had changed the GEA switch to a 3 position switch.. Ok, TRH switch increases gears, and GEA- decreases gear now.
I also changed the Throttle to Channel 2. if the model is not responding to the speeds you need, please look at the radio numerical output screen while you move the throttle a write down the numbers when you move the throttle at the required speeds.. Then I can change them..

Also, I don't know how the tamya_Grd model worked for you as it was completely messed up :)
You seem to use the radio in mode 1 (throttle on the right hand side)??

João

Hi, yep, I replaced ELE RUD AIL y GEAR with 3 pos switches :)

In all my land models I am using throttle stick in the left hand side. The advanced options it changes depending of the electronics a lot, but for the basic ones the tank drives like this:
Left stick trottle and steering, and right stick horizontal, turret movement, vertical barrel elevation.
In the case of the Tamiya GRD, right stick up shoots the cannon, left stick down shoots the machine gun (I put that on the TRN and THR Switches) it is not messed...

Now I am having problems making the tank drive, lol. but Ill keep trying changing the order of connectors in the receiver.

EDIT: I cant make it run as it should, I guess the problem comes because we are using diferent configurations in the RETA area. When moving the throttle in the last file you sent me, even when is channel 2, the bar that moves is the third...

EDIT 2: Radio setup/controls/ RETA/Mode 2.. Fixed! Now testing the speeds!
Last edited by Rad on Sat Feb 17, 2018 1:11 pm, edited 1 time in total.

User avatar
jhsa
Posts: 18143
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Realistic driving in land vehicles.

Post by jhsa » Sat Feb 17, 2018 1:06 pm

I believe that you don't know how to configure the modes on your transmitter, and are just trying to play with the channel order to try to make things work. :(
People often get confused about stick mode and channel order. they are NOT the same thing..
Please get the er9x manual from here

http://openrcforums.com/forum/viewtopic.php?f=5&t=6473

and read about channel order and stick modes. Er9x is a more basic version of Ersky9x that runs on the stock 9x mainboard, but in this case they are identical.

So, you have the throttle on the left side, right? then go to "Radio setup / Controls" and then select mode 2. You have currently mode 1 selected that assigns throttle to the right vertical stick..

Then reload the latest model I sent you and use Channel 2 for throttle. Do not change any switch at this point because it has to be changed in more than one place, and if you don't do it correctly, things will not work. Test with TRN to increase gear, and GEA- to decrease gear.. The if it works we will change it to other switches if you want.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Rad
Posts: 176
Joined: Wed Apr 20, 2016 3:43 pm
Country: -

Re: Realistic driving in land vehicles.

Post by Rad » Sat Feb 17, 2018 1:12 pm

jhsa wrote:
Sat Feb 17, 2018 1:06 pm
I believe that you don't know how to configure the modes on your transmitter, and are just trying to play with the channel order to try to make things work. :(
People often get confused about stick mode and channel order. they are NOT the same thing..
Please get the er9x manual from here

http://openrcforums.com/forum/viewtopic.php?f=5&t=6473

and read about channel order and stick modes. Er9x is a more basic version of Ersky9x that runs on the stock 9x mainboard, but in this case they are identical.

So, you have the throttle on the left side, right? then go to "Radio setup / Controls" and then select mode 2. You have currently mode 1 selected that assigns throttle to the right vertical stick..

Then reload the latest model I sent you and use Channel 2 for throttle. Do not change any switch at this point because it has to be changed in more than one place, and if you don't do it correctly, things will not work. Test with TRN to increase gear, and GEA- to decrease gear.. The if it works we will change it to other switches if you want.

João
Lol, you were writing this when I was already solved the problem. But thank zou very much anyway! Hope somebody lost with this can find this small tutorial too.

User avatar
jhsa
Posts: 18143
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Realistic driving in land vehicles.

Post by jhsa » Sat Feb 17, 2018 1:19 pm

Good :) then load again the latest model I posted and try it..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Rad
Posts: 176
Joined: Wed Apr 20, 2016 3:43 pm
Country: -

Re: Realistic driving in land vehicles.

Post by Rad » Sat Feb 17, 2018 1:27 pm

Ok news here, I took a look to the numericals, and yep, you did it perfectly. 0-34, then to 65,9 and then to 100.

I think if it does not move from 0-34 is because the electronics of the tank itself, but definitely you did it correctly.

The only thing needed is to fine tune them and I guess I have to do it myself unless you have a 1:16 King Tiger to test it too, lol.

This is the first time I mess with this but Im going to try experimenting with the weight and offset until I achieve all the speeds.

As always, thank you very much!!! Ill update the thread if I discover something else.

User avatar
jhsa
Posts: 18143
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Realistic driving in land vehicles.

Post by jhsa » Sat Feb 17, 2018 1:38 pm

This might not be the issue, but try calibrating the radio sticks and pots..

let me know if you need help with the weight and offset for new values.

joão
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Rad
Posts: 176
Joined: Wed Apr 20, 2016 3:43 pm
Country: -

Re: Realistic driving in land vehicles.

Post by Rad » Sat Feb 17, 2018 8:18 pm

I spent a couple of hours testing and have some news and issues here.

First, in eepysky, when I click in "write memory to TX", it copies the models, but the protocol configuration always dissapears. Luckily I use the stock module receivers in all the models except one, lol. Next time I will try just flashing a concrete model and we will see what happens.

Second. After modifiying the weight and offsets, now I managed to fix the fast speed backwards, and all forward speed works as I wanted!!! :DDDD
But there are two small things I would like to change: In the first speed, the throttle seems to work only when the throttle is a bit more than the middle point instead of working from the beginning. In the second is not that evident and in the third this problem is not present. Not a big problem, but if I fix it would be great.

Third, when ID- the tank sounds like is driving at very low speed instead of being in idle, and it should sound like it is in idle. In first gear 0 throttle sounds in idle, and that is perfect. I tried diverse configurations with the weight and offset, and It seems I can not fix it. Any clue?

Four and more important: Mode 1, mode 2 stuff. Today early in the morning it took me some time to find where was the problem. I hardly ever mess with the radio configuration. Today for your gears file, I had to change the mode in the radio configuration... But doing it,the rest of my models are messed up. So, is there any way I can change your file to work like the rest (Throttle in left hand) instead of having to change the model in the radio config menu every time?

Thanks!

User avatar
MikeB
9x Developer
Posts: 15811
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Realistic driving in land vehicles.

Post by MikeB » Sat Feb 17, 2018 8:31 pm

If your throttle (ratchet) stick is on the left, then you should be in mode 2. The radio needs this to be able to "know" where the throttle stick is in order to do the throttle check on power on/model select properly. Note that in each model, you may configure the throttle check to test for the stick being in the mid position, not fully down.

Are you reading the EEPROM from the radio, modifying it, then writing it back?
What are the revisions of ersky9x and eepskye you are using?

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 18143
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Realistic driving in land vehicles.

Post by jhsa » Sat Feb 17, 2018 9:13 pm

The problem seems to be that you have had the radio configured wrong since the beginning..
As Mike said, if the throttle stick is on the left side, you should have mode 2 selected..
The reason you would have to fix all your models is because they might be all wrong :)

If the throttle is zero, and the sound is configured to play the idle file at that point, it should do.. I don't understand why it doesn't..
Please try calibrating your sticks and pots. To do so go to "Radio Setup / Calibration" then follow the on screen instructions.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Rad
Posts: 176
Joined: Wed Apr 20, 2016 3:43 pm
Country: -

Re: Realistic driving in land vehicles.

Post by Rad » Sat Feb 17, 2018 11:00 pm

Damn, yeah, you are right. Im using it wrong since the origin of times, lol.

Mike: I was using: Eepysky v421 nov 21 2016. Now I checked again in the test files and I downloaded the last eepesky version and tried to install it... Due to it was not an .exe I just replaced the file in the old eepe folder. It seems to work and it says is running the 421v Dec 12, 2017

My 9xtreme was running ersky9xProvR221g2 Now I updated to the 221g7

Just curious, since the R220 was released there have been a lot of changes. Why not to release an official R221 and keep making releases in a prov R222?

And yes, I was doing what you said, reading, modifying and writing it back. I guess the problem is I was using an old version of eepesky. Next time I do it Ill report if I fixed the problem, but Im sure it is now solved.

At the other hand, now I have set mode 2 in the radio, Order of channels RTEA, sticks and pots recalibrated. Tomorrow morning I will test it in the tank. Cant wait to see how it goes! :)

User avatar
jhsa
Posts: 18143
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Realistic driving in land vehicles.

Post by jhsa » Sat Feb 17, 2018 11:45 pm

Good Luck :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Rad
Posts: 176
Joined: Wed Apr 20, 2016 3:43 pm
Country: -

Re: Realistic driving in land vehicles.

Post by Rad » Sun Feb 18, 2018 10:25 am

I did the first test video: https://www.youtube.com/watch?v=A3XmzEvtqgY

So far it is working, but the sticks seems to have quite a big dead area. I guess this is due to the tamiya electronics, I will try with other stuff soon.

What I dont understand, is at the beginning of the video, with ID neutral youu can heard the motor idle sound and those two green leds blinking... Thats perfect!,
Then I put gear forwards, when thottle in 0 position still have idler sound (still perfect) and when pushing throttle forward we have motor sound (perfect too)
But if I put the neutral again, then the idler sound is not there any more. Instead we have the sound of driving very slowly, and the leds say the same. (minute 1:59) I am not sure why, because the radio seems to be emiting 0 signal...

I think it is more related with the tamiya electronics themselves. What do you think?

User avatar
jhsa
Posts: 18143
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Realistic driving in land vehicles.

Post by jhsa » Sun Feb 18, 2018 10:45 am

Hmm, it looks like the electronics might be a bit offset and don't expect the zero to be zero.. if the electronics were designed for Futaba radios for example, the center point is not 1500uS (micro seconds) anymore, but around 1520uS.
Try playing with the Sub-Trim value on the Thr channel in the "Model Setup / Limits" menu. It is the first value right after the Channel number. Try increasing it a little and see if it gets better..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Rad
Posts: 176
Joined: Wed Apr 20, 2016 3:43 pm
Country: -

Re: Realistic driving in land vehicles.

Post by Rad » Sun Feb 18, 2018 6:47 pm

jhsa wrote:
Sun Feb 18, 2018 10:45 am
Hmm, it looks like the electronics might be a bit offset and don't expect the zero to be zero.. if the electronics were designed for Futaba radios for example, the center point is not 1500uS (micro seconds) anymore, but around 1520uS.
Try playing with the Sub-Trim value on the Thr channel in the "Model Setup / Limits" menu. It is the first value right after the Channel number. Try increasing it a little and see if it gets better..

João
In fact this tank electronics is designed for futaba radios, lol.
I played with the sub trim value, and when adding numbers into it in the channel 2, the forward speed goes much better (I mean, I have way less deadband) but when backwards the deadband seems to grow. It is not a big problem due to 95% of use is frontwards

When ID neutral, the ms is 1500, and as you point, I seem to need about 1525uS to be idle. How do I do it?

Post Reply

Return to “Software”