companion23 segmantaion fault on Fedora 36

Help with any software/desktop related issues. e.g. companion9x, eePe, etc
Post Reply
inisider
Posts: 1
Joined: Sun Sep 18, 2022 1:59 pm
Country: -

companion23 segmantaion fault on Fedora 36

Post by inisider » Sun Sep 18, 2022 2:06 pm

Hello.

I would like to install http://www.open-tx.org/2022/04/22/opentx-2.3.15 but the package is delivered as deb package so I did the following:
$ sudo alien -r companion23_2.3.14_amd64.deb
$ sudo dnf install companion23-2.3.14-1.x86_64.rpm
$ rpmrebuild -pe ./companion23-2.3.14-1.x86_64.rpm
$ sudo dnf install /home/ok/rpmbuild/RPMS/x86_64/companion23-2.3.14-1.x86_64.rpm

And when I am trying to run it I receive Segmentation fault:
[[email protected] Downloads]$ companion23
QSocketNotifier: Can only be used with threads started with QThread
Segmentation fault (core dumped)

Has anyone tried to run OpenTx Companion on Fedora?


User avatar
kalle123
Posts: 899
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: companion23 segmantaion fault on Fedora 36

Post by kalle123 » Wed Sep 21, 2022 6:32 am

inisider wrote:
Sun Sep 18, 2022 2:06 pm
I would like to install http://www.open-tx.org/2022/04/22/opentx-2.3.15 but the package is delivered as deb package so I did the following:
$ sudo alien -r companion23_2.3.14_amd64.deb
Hi, the package you tried to convert should be 'companion23_2.3.15_amd64.deb' ;)

But besides that, I would try to build from the sources, if it has to be OpenTX

https://github.com/opentx/opentx/wiki/O ... structions

Did that once on my Debian system. But it was a 'PITA'.

My advice to you ... Have a look at EdgeTX, there is an active developer team, which is willing to give a helping hand.

Under EdgeTX companion comes under Linux as an appimage and there are several well documented ways to get the EdgeTX firmware on your radio ....

br KH

Post Reply

Return to “Software”