Firmware update trouble from 2.2.1 to current

Help with any software/desktop related issues. e.g. companion9x, eePe, etc
Post Reply
SaltyPeppersen
Posts: 1
Joined: Tue Aug 02, 2022 11:48 pm
Country: -

Firmware update trouble from 2.2.1 to current

Post by SaltyPeppersen » Wed Aug 03, 2022 12:38 am

I cant get firmware for my QX7 ACCST to update from 2.2.1 to current version (2.3.15)
Error message reads: "New firmware is not compatible with the one currently installed!"

The version listed closest to 2.2.1 is 2.2.4 but i get an error message when I click to download firmware that reads: "Unable to check for updates."

While attempting the verions in between (version 2.3.9 and 2.3.10) Error message upon download attempt in companion reads: " Firmware update check failed, new version information not found or invalid."

Has anyone a fix for this?


User avatar
Kilrah
Posts: 11039
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Firmware update trouble from 2.2.1 to current

Post by Kilrah » Wed Aug 03, 2022 6:28 am

If it has stock FrSky firmware make sure to select the correct radio type in companion and disable the compatibility check.

Post Reply

Return to “Software”