Newbie and Turnigy 9x Problem

Help with any software/desktop related issues. e.g. companion9x, eePe, etc
Post Reply
asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Thu Apr 29, 2021 3:23 pm

Good afternoon from Spain.
The first thing is to congratulate them on their forum and everything they have posted on it.
Then tell them that I have a problem with my Turnigy 9x. It has an ATMEGA 128 a-au processor.
I managed to update my station with the er9x, following in the steps of this videowith the following AVR programmer.

https://www.youtube.com/watch?v=7sdB1wb ... YG&index=5

With the following AVR programmer.

https://es.aliexpress.com/item/10050014 ... uUQAvD_BwE

I don't know if you can open this page, I leave photo of the programmer

But I don't know where I've touched that the screen doesn't turn on, I have communication with the station, or at least I think so, since the program performs the process of uploading both the er9x-128.hex, and in file with the settings called asesorplaza1_er9.eepe, attached the process photos.
But the display does not turn on, e.g. when the station is connected to the computer, or when I connect the battery to it.
I have read in the forum that you can modify the settings of the screen, but since I see nothing, I can not reach the menu of the screen give the station. So the question is:
Can I change the display settings in any way from the er9x program?, or can they only be changed from the station. And if you can change them from the program, how do you do it?, since I have not been able to find a way to modify these settings.
Thanks a lot.
Attachments
write to eeprom.jpg
(1.74 MiB) Not downloaded yet
write flash to tx.jpg
(2.74 MiB) Not downloaded yet
Soldering.jpg
(3.24 MiB) Not downloaded yet
Programador_AVR.jpg
Programador_AVR.jpg (22.23 KiB) Viewed 3052 times
Procesador ATMEGA 128 a-au.jpg
(2.63 MiB) Not downloaded yet


ReSt
Posts: 1571
Joined: Tue Dec 27, 2011 11:34 pm
Country: -

Re: Newbie and Turnigy 9x Problem

Post by ReSt » Thu Apr 29, 2021 4:46 pm

Could be that your contrast setting is to low
If LCD contrast gone to MIN or MAX that can't not see nothing after loading ersky9x firmware, try this key sequence.

1. EXIT key 5 times or more.
2. Left key hold down, let it enter RADIO SETUP menu
3. MENU key once
4. try Left or Right key to adjust LCD contrast.
Otherwise, run eePe, go into "General settings", "Setup" and set the 'Contrast' value to something like 25 and write that back to the radio


Reinhard

asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Re: Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Thu Apr 29, 2021 10:46 pm

Good night and thank you so much for answering so quickly.
I'm sorry to inform you that I'm a lot more clumsy than I seem.
I have followed your instructions and I have not achieved anything from the station, and when looking for what you say in the program, if I find the tab "settings", but I do not see the "General configuration", to which you refer, and I see nothing that refers to "Contrast value", nor in the program eepe review 422, 18 February 2018 , or in the file that can be saved to the station with the model settings to be controlled.
Thank you very much for your patience and understanding
Attachments
asesorplaza1_erx9.eepe
(1.73 KiB) Downloaded 38 times

ReSt
Posts: 1571
Joined: Tue Dec 27, 2011 11:34 pm
Country: -

Re: Newbie and Turnigy 9x Problem

Post by ReSt » Fri Apr 30, 2021 12:02 pm

Low contrast is obviously not your problem, as it is set to 25 in your eeprom file.
Did you open the radio in the past? It could be, that the flat cable of the display is not seated correctly in its socket.

btw. regarding your eeprom file, channel 6. You can replace the three line by this one:
CH6 +100% sIDx

The 3pos switch as source produces the output values of -100, 0 +100 depending on the position of the switch

Reinhard

asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Re: Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Fri Apr 30, 2021 11:19 pm

Thank you so much for answering.

I would like to know where the contrast value is to upload it a little more for example to 30, but I do not see any option that says "contrast", nor do I see any value "25" in the eeprom file. Would you be so kind as to tell me where that value is to change it?

I have only opened the station this time to weld the AVR programmer, and I am not aware of having touched the flat cable of the screen at any time, because it is far from the area of the welding work, I've checked it anyway and it seems to be in place.

The whole eeprom file is configured by a friend to be used in a Tamiya truck, anyway I have followed his Reinhard advice, and I think I have changed it well, Channel 6, 3-position switch, is the one used by a servo to trigger gear shifting, in positions
0 first speed, completely left servo
1 second speed, servo in center position
2 third speed, completely right servo
Attached the modified file for verification.

What surprises me about the behavior of the station, is that if I turn it on with any switch outside the "off" position, the station does not whistle or emit any noise, when I think it should beep warning that there is a switch activated, with the consequent danger to the model operator.

Thank you very much for your time, a greeting
Attachments
asesorplaza1_erx9.eepe
(1.73 KiB) Downloaded 34 times


User avatar
MikeB
9x Developer
Posts: 17493
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Newbie and Turnigy 9x Problem

Post by MikeB » Sat May 01, 2021 9:15 am

The contrast setting is in the "General Settings", not the model settings. Double click on the "General Settings" line in the radio window, then select the "Setup" tab.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Re: Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Sat May 01, 2021 3:46 pm

Thank you very much for answering and for your time.
I've been able to locate the general settings tab, which is inside the .eepe file, and I've changed the contrast value from 25 to the current one of 30, but the screen still doesn't turn on, and I can't see anything on the station.
Attachments
asesorplaza1_erx9.eepe
(1.73 KiB) Downloaded 28 times

User avatar
jhsa
Posts: 19443
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Newbie and Turnigy 9x Problem

Post by jhsa » Sun May 02, 2021 1:02 pm

Please post a good resolution picture of the top side of the radio's motherboard. Even better if you can keep the complete processor in the picture..

Also, did you install any type of backlight behind your radio's screen?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Re: Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Sun May 02, 2021 6:40 pm

Thank you very much for answering and for your time.
I haven't connected anything else.
Thanks a lot.
Attachments
20210502_203803.jpg
(3.39 MiB) Not downloaded yet
20210502_203754.jpg
(3.21 MiB) Not downloaded yet
20210502_203747.jpg
(3.06 MiB) Not downloaded yet

User avatar
jhsa
Posts: 19443
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Newbie and Turnigy 9x Problem

Post by jhsa » Sun May 02, 2021 6:52 pm

Please check your LCD connection. it looks like the right tab of the LCD connector is not fully closed. Check also that the LCD is well inserted in the connector, and straight..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Re: Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Sun May 02, 2021 7:05 pm

Thank you very much for answering and for your time.
I just checked the LCD connection, and indeed, a closure was not fully fitted, now if it is, the screen still does not turn on.
Thanks a lot.
Attachments
20210502_210719.jpg
(2.81 MiB) Not downloaded yet

User avatar
jhsa
Posts: 19443
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Newbie and Turnigy 9x Problem

Post by jhsa » Sun May 02, 2021 7:42 pm

Ok, did that radio screen work before?

Can you please use eepe to read the fuses, and post them here?
Connect your programmer to the radio as you do to flash the firmware. Then open eepe, and click on the "Burn" menu. Then select "Read Fuses".
Please post the output here.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Re: Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Sun May 02, 2021 9:46 pm

Thanks a lot.
The screen used to work properly.
Here's what you tell me after reading fuses.
A greeting
Attachments
20210502_234659.jpg
(3.05 MiB) Not downloaded yet

asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Re: Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Sun May 02, 2021 10:09 pm

Thank you for your time and patience
A cable had been released, every time I open the station, A new problem arises.
Now that it works well what it says when reading the fuses is this.
Thanks a lot.
Attachments
20210503_001104.jpg
(3.97 MiB) Not downloaded yet

asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Re: Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Mon May 03, 2021 9:30 pm

Thank you so much for your time.
Please tell me if this is what you need, or it is something else, the station still does not turn on.
Thanks a lot

User avatar
jhsa
Posts: 19443
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Newbie and Turnigy 9x Problem

Post by jhsa » Wed May 05, 2021 11:51 pm

The fuses, as far as I remember, look ok. :o
Can your radio control a servo? Is it only the screen that is dead?
If so, it could be that the screen is damaged, Please try to gently removing the screen ribbon from the connector, then insert it again and lock the connector. Perhaps there is some bad connection. Also, please check that there aren't any blobs of solder shorting some of the processor pins.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Re: Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Sun May 09, 2021 9:01 pm

Good night from Spain
Thank you very much for responding and for your time.
I'm sorry it took me so long to answer, but I've had to fix some personal problems.
I followed your instructions and tried to pair a receiver with the station. While during the bind or pairing process, the receiver sets the search light
starts with a flashing light and then stays fixed
I have not managed to make it able to control a servo afterwards.
So the station seems to be alive, but for some reason I don't know, it doesn't work properly.
I've also checked that there are no weld stains on the processor and that the display is well connected
A greeting

User avatar
jhsa
Posts: 19443
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Newbie and Turnigy 9x Problem

Post by jhsa » Sun May 09, 2021 10:25 pm

So, you cannot make the radio control a servo? can you download the eeprom to eepe, and select the correct protocol, and then burn the eeprom to the radio again? Then try to move a servo again?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Re: Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Sun May 09, 2021 11:39 pm

Thank you very much for responding and for your time.
According to the computer, I can read and write the firmware, I can read and write on the eprom, without seeing anything on the screen, disconnect the station from the computer, connect the battery to the station, turn on the station and I do not see anything on the screen, I do the pairing process with the receiver, blindly, the receiver changes from flashing light to fixed light , I turn off the receiver and the transmitter, remove the bridge cable, turn on the transmitter and receiver, the receiver turns off the light, and I can't control any servos.

the program eepe, tells me this.
Attachments
20210510_013956.jpg
(4.4 MiB) Not downloaded yet

asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Re: Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Sun May 09, 2021 11:49 pm

What do you mean, "select the right protocol"?, I'm loading er9x-128Green.hex, I already told you that my processor is an ATMEGA 128 a-au green
Last edited by asesorplaza1 on Sun May 09, 2021 11:55 pm, edited 1 time in total.

asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Re: Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Sun May 09, 2021 11:53 pm

Thank you very much for answering and for your time, a greeting

ReSt
Posts: 1571
Joined: Tue Dec 27, 2011 11:34 pm
Country: -

Re: Newbie and Turnigy 9x Problem

Post by ReSt » Mon May 10, 2021 8:43 am

In the test versions thread
viewtopic.php?f=5&t=4598#p64969
there are three test versions especially for the green processor
er9x-128Green.zip
20-Jul-2020 17:44
Test Build for '128 with "Green" processor, uses software watchdog.
(92.12 KiB) Downloaded 136 times

er9x-128SwWdog.zip
20-Jul-2020 15:21
Special test version for M128. Implement 300mS software watchdog.
(92.1 KiB) Downloaded 127 times

er9x-128WD2S.zip
20-Jul-2020 11:26
Special test version for M128. Watchdog set to 2 seconds instead of 0.5 seconds.
Only use this for testing "Green" processor.
(92.16 KiB) Downloaded 128 times
Can you try if any of these versions show a display on your radio?

Reinhard

User avatar
jhsa
Posts: 19443
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Newbie and Turnigy 9x Problem

Post by jhsa » Mon May 10, 2021 9:33 pm

asesorplaza1 wrote:
Sun May 09, 2021 11:49 pm
What do you mean, "select the right protocol"?, I'm loading er9x-128Green.hex, I already told you that my processor is an ATMEGA 128 a-au green
Download the radio eeprom to eepe, edit the model, select the correct protocol for the RF module you are using, and then burn the eeprom back to the radio..
What i said has nothing to do with flashing the er9x firmware.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Re: Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Fri May 14, 2021 11:00 pm

Thank you very much for responding and for your time.

I'm sorry it took me so long to answer, but I have to work to win Euros, so I can spend them on the radio control hobby.

When I download the eeprom file, the time comes when the eep program collapses and exits the reading. Still, it generates a file, which when I try to open it with the eep program, does nothing. If I open that program with the note block program, rare and illegible characters come out, instead of a series of zeros, ones and leter, such as when any file in the eep program.

Attached eeprom file

since it won't let me attach a file with the .bin extension, I've added .txt, so I can attach it in the publication
Attachments
document1.bin.txt
(128 KiB) Downloaded 20 times

asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Re: Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Sun May 16, 2021 7:03 pm

Good afternoon, thank you very much for your time
I have to give you good news, my station is not dead as I thought, I have managed to bring it from the other dimension to this side of life.
I have tried to upload another file of those in the program, as I already gave up and spoiled, and it turns out that it has worked, if I charge you the program er9x.hex works correctly, if you charge the one that corresponds to it the er9x-128Green.hex does not work.
When the first time I load the program er9x-128Green.hex, if it worked
Electronics elves stuff, I have no explanation for this.
now I have the hardest thing to do, set it up correctly so I can handle my models
A greeting

asesorplaza1
Posts: 16
Joined: Thu Apr 29, 2021 3:16 pm
Country: Spain

Re: Newbie and Turnigy 9x Problem

Post by asesorplaza1 » Sun May 16, 2021 9:51 pm

Now I have another problem, it does not let me copy the model configuration file, and I do not have telemetry options, I keep testing to load other files and I do not get the station to support them, it only supports the er9x.hex When I try to load the file with the models, when the process is successfully finished the station says "ALERT bad eeprom data press any key" , press exit and say "Message eeprom formatting" in one second time goes to the ER9X general menu and the station menu without modify the models.
Evil electronics elves

User avatar
MikeB
9x Developer
Posts: 17493
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Newbie and Turnigy 9x Problem

Post by MikeB » Sun May 16, 2021 10:33 pm

If you have a '128 processor, then er9x-128.hex should work. If it doesn't, but er9x.hex (for the '64 processor) does work, then it suggests the processor is faulty.
The EEPROM format for the '64 (as used by er9x.hex) is different to that for the '128 (only 2K EEPROM instead of 4K).
To read and write the EEPROM for er9x.hex, you probably need to set eepe to be expecting the '64 processor.
In eepe, choose "preferences" (the gear wheel icon), set the processor to M64, then lower down the dialog (Burn Configure) set the mcu to m128.
See if that works, read the EEPROM from the radio, add a new model, then write it back.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!


Post Reply

Return to “Software”