OpenTx 2.2.4 Companion Issues (QX7)

Post Reply
Chuppster
Posts: 6
Joined: Sat Jul 11, 2020 7:32 pm
Country: -

OpenTx 2.2.4 Companion Issues (QX7)

Post by Chuppster » Thu Jul 23, 2020 7:10 pm

I recently updated to OpenTx Companion 2.2.4 (with new firmware on my Taranis QX7) and everything worked great. However, it's been a few weeks and now when I go to load the models from my radio I get the error "Can't extract RADIO/radio.bin" I've tried restarting the radio and restarting companion but nothing works. Does anyone have troubleshooting steps so I can use Companion again?
Last edited by Chuppster on Sat Jul 25, 2020 9:41 pm, edited 1 time in total.


User avatar
3djc
Posts: 77
Joined: Mon Feb 22, 2016 7:15 am
Country: -

Re: OpenTx 2.2.4 Companion Issues

Post by 3djc » Sat Jul 25, 2020 6:33 am

You don't even mention your radio type ....

Chuppster
Posts: 6
Joined: Sat Jul 11, 2020 7:32 pm
Country: -

Re: OpenTx 2.2.4 Companion Issues

Post by Chuppster » Sat Jul 25, 2020 9:40 pm

3djc wrote:
Sat Jul 25, 2020 6:33 am
You don't even mention your radio type ....
My apologies. I have a Taranis QX7.

User avatar
3djc
Posts: 77
Joined: Mon Feb 22, 2016 7:15 am
Country: -

Re: OpenTx 2.2.4 Companion Issues (QX7)

Post by 3djc » Mon Jul 27, 2020 12:41 pm

Then I guess your radio profile must be set wrong (I'm assuming "load the models from my radio" is actually read model and settings from radio ?)

Chuppster
Posts: 6
Joined: Sat Jul 11, 2020 7:32 pm
Country: -

Re: OpenTx 2.2.4 Companion Issues (QX7)

Post by Chuppster » Tue Jul 28, 2020 1:38 pm

3djc wrote:
Mon Jul 27, 2020 12:41 pm
Then I guess your radio profile must be set wrong (I'm assuming "load the models from my radio" is actually read model and settings from radio ?)
The "Radio Type" field is set to "FrSky Taranis X7 / X7S".

When I click "Read Models and Settings from Radio" the status bar comes up for second then an error field pops up saying "Can't extract RADIO/radio.bin".


User avatar
Kilrah
Posts: 10740
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: OpenTx 2.2.4 Companion Issues (QX7)

Post by Kilrah » Tue Jul 28, 2020 2:32 pm

And do you have the radio in bootloader mode?

Chuppster
Posts: 6
Joined: Sat Jul 11, 2020 7:32 pm
Country: -

Re: OpenTx 2.2.4 Companion Issues (QX7)

Post by Chuppster » Tue Jul 28, 2020 7:41 pm

Kilrah wrote:
Tue Jul 28, 2020 2:32 pm
And do you have the radio in bootloader mode?
Yep! I should mention that I've configured with Companion many times but haven't encountered this issue until recently.


Post Reply

Return to “openTx for FrSky radios”