Trouble connecting dfu-utils in Linux to Taranis QX7s

Post Reply
jeffeb3
Posts: 1
Joined: Mon Aug 19, 2019 2:11 am
Country: -

Trouble connecting dfu-utils in Linux to Taranis QX7s

Post by jeffeb3 » Mon Aug 19, 2019 2:20 am

I am pretty good with Linux, and I don't have any mac or window machines here. I installed the companion22 via the .deb (2.2, FWIW) and it seems to be running fine, and everything. I installed dfu-utils (sudo apt install dfu-utils) and I'm getting messages like this (even if I run companion as sudo, which I hate to do for graphics programs, especailly):

Code: Select all

dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

/usr/bin/dfu-util -a 0 --dfuse-address 0x08000000:524288 --device 0483:df11  -U/home/jeffe/opentx/bkup
=================================================================================
dfu-util: No DFU capable USB device available

=================================================================================

I have a little experience with dfu-utils in the past, and when I try `sudo dfu-tool list`, I get nothing back.

On the Taranis radio, I am pretty sure I have it in the right configuration, I got into the "write firmware" menu, and it says, "USB Connected" (and also "OTX Bootloader - 2.2.2").

I don't have an SD card in it ATM. I didn't fill out the sd card path in the companion settings yet. I am seeing some errors in dmesg, and I assume that's because I don't have an sd card (and it's trying to find it in sdc):

Code: Select all

[ 1700.622003] usb 2-2: new full-speed USB device number 6 using xhci_hcd
[ 1700.771392] usb 2-2: New USB device found, idVendor=0483, idProduct=5720
[ 1700.771397] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1700.771400] usb 2-2: Product: FrSky Taranis Bootloader
[ 1700.771402] usb 2-2: Manufacturer: FrSky
[ 1700.771405] usb 2-2: SerialNumber: 00000000001B
[ 1700.772227] usb-storage 2-2:1.0: USB Mass Storage device detected
[ 1700.773482] scsi host4: usb-storage 2-2:1.0
[ 1701.782591] scsi 4:0:0:0: Direct-Access     FrSky    Taranis Radio    1.00 PQ: 0 ANSI: 2
[ 1701.782906] scsi 4:0:0:1: Direct-Access     FrSky    Taranis Radio    1.00 PQ: 0 ANSI: 2
[ 1701.783844] sd 4:0:0:0: Attached scsi generic sg1 type 0
[ 1701.784330] sd 4:0:0:1: Attached scsi generic sg2 type 0
[ 1701.784628] sd 4:0:0:0: [sdb] Attached SCSI removable disk
[ 1701.785222] sd 4:0:0:1: [sdc] 1100 512-byte logical blocks: (563 kB/550 KiB)
[ 1701.785363] sd 4:0:0:1: [sdc] Write Protect is off
[ 1701.785366] sd 4:0:0:1: [sdc] Mode Sense: 00 00 00 00
[ 1701.785504] sd 4:0:0:1: [sdc] Asking for cache data failed
[ 1701.785508] sd 4:0:0:1: [sdc] Assuming drive cache: write through
[ 1701.790527]  sdc:
[ 1701.791329] sd 4:0:0:1: [sdc] Attached SCSI removable disk
What else can I try?

PS, thanks a bunch for your help. I frequent the v1engineering forums to help with open source CNC machines, and I know it's a lot of fun, but thanks go a long way.


User avatar
Kilrah
Posts: 10739
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Trouble connecting dfu-utils in Linux to Taranis QX7s

Post by Kilrah » Mon Aug 19, 2019 8:41 am

jeffeb3 wrote:
Mon Aug 19, 2019 2:20 am
On the Taranis radio, I am pretty sure I have it in the right configuration, I got into the "write firmware" menu, and it says, "USB Connected" (and also "OTX Bootloader - 2.2.2").
You don't, if you want to use dfu the radio has to be off.
As it is it makes a mass storage drive that if mounted companion will write to.

User avatar
kalle123
Posts: 841
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: Trouble connecting dfu-utils in Linux to Taranis QX7s

Post by kalle123 » Mon Aug 19, 2019 9:18 am

You did not mention, which distro you are using. Mint, some Buntu, DEBIAN?

I am on DEBIAN Buster here and that is, what I see when running dfu-util WITHOUT anything attached.

Code: Select all

~$ dfu-util -l
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/
and here I did attache a Taranis (TX is OFF!)

Code: Select all

~$ dfu-util -l
dfu-util 0.9

Copyright 2005-2009 Weston Schmidt, Harald Welte and OpenMoko Inc.
Copyright 2010-2016 Tormod Volden and Stefan Schmidt
This program is Free Software and has ABSOLUTELY NO WARRANTY
Please report bugs to http://sourceforge.net/p/dfu-util/tickets/

Found DFU: [0483:df11] ver=2200, devnum=2, cfg=1, intf=0, path="3-2", alt=3, name="@Device Feature/0xFFFF0000/01*004 e", serial="385832683337"
Found DFU: [0483:df11] ver=2200, devnum=2, cfg=1, intf=0, path="3-2", alt=2, name="@OTP Memory /0x1FFF7800/01*512 e,01*016 e", serial="385832683337"
Found DFU: [0483:df11] ver=2200, devnum=2, cfg=1, intf=0, path="3-2", alt=1, name="@Option Bytes  /0x1FFFC000/01*016 e", serial="385832683337"
Found DFU: [0483:df11] ver=2200, devnum=2, cfg=1, intf=0, path="3-2", alt=0, name="@Internal Flash  /0x08000000/04*016Kg,01*064Kg,07*128Kg", serial="385832683337"
br KH

hexagon5un
Posts: 1
Joined: Fri Jul 03, 2020 7:02 am
Country: -

Re: Trouble connecting dfu-utils in Linux to Taranis QX7s

Post by hexagon5un » Fri Jul 03, 2020 7:09 am

I had this same problem: dfu-utils not seeing the device. I got it working by connecting to the laptop _directly_ with a USB cable, and not through a USB hub as I do when I'm using the QX7s as a joystick or drive. Also, as mentioned above, it only works when it's off.

TL;DR: Plug in a cable directly with X7 off. Works like a charm.

(Of course, so does loading the .bin onto the flash card and flashing from the bootloader. OpenTX is awesome.)


Post Reply

Return to “openTx for FrSky radios”