Page 1 of 2

Horus X10S Express

Posted: Sat Aug 17, 2019 3:25 am
by BillE
Good Day All

Will OpenTX 2.2.4 run on the Horus X10S Express? I am expecting delivery of mine and it isn't clear if I need to wait for the Express version of 2.3

Many Thanks

Bill

(Off topic, but does anyone know what Battery I need for the TX?)

Re: Horus X10S Express

Posted: Sat Aug 17, 2019 6:35 am
by Kilrah
The latter, the new hardware needs 2.3.

Re: Horus X10S Express

Posted: Sat Aug 17, 2019 8:16 am
by BillE
Many thanks.

Does anyone know a time scale for 2.3? I don't expect an exact date, but are we talking days? Weeks? Months? Or have I been a bit premature with my order :D

Re: Horus X10S Express

Posted: Sat Aug 17, 2019 8:35 am
by Kilrah
Ptobably "weeks".

Re: Horus X10S Express

Posted: Sat Aug 17, 2019 8:51 am
by BillE
Again, many thanks. It should be delivered Monday and whilst I'll look at FROS, I really want to get it onto OpenTX.

I've used Google and looked at FRSky's web site, but other than a 2S, they aren't very specific what battery I need - hopefully all will be revealed Monday!

Re: Horus X10S Express

Posted: Fri Aug 23, 2019 7:29 am
by BillE
I have the radio and am very pleased with it. It came with a battery, so I need not have worried about that.

I don't like/can't get on with FROS and want to get it onto Open TX as soon as I can.

I did wonder if the 2.3 Nightly Builds would install - perhaps not to fly, but at least so I can have a play. However, whilst I can download the SD Card Content, the Firmware isn't available for the X10

I have a rather expensive paper weight whilst I wait for Open TX 2.3 :lol:

Re: Horus X10S Express

Posted: Wed Aug 28, 2019 7:20 am
by pafleraf
@BillE we have started testing 2.3 with the new TXs and would need your help! Here are the details: viewtopic.php?f=45&t=12168

Just for the info, on my X10, all my models from 2.2 convert now perfectly and it's absolutely usable. Let's find out if this is the same for you ;-)

Re: Horus X10S Express

Posted: Thu Aug 29, 2019 7:33 am
by BillE
WOW! Thank You!!

I installed 2.3 this morning and it works well - no issues so far.

I've copied all my models across and although I've yet to fully look through, all seems to be correct so far.

Excuse my ignorance here - The 'front page' of every model needs to be redone, that is the widgets I set up for each model have to be put back. I don't know if that's expected or if there was an issue? In any event it is an extremely MINOR point!

Many thanks for prompt service!

All the best

Bill

Re: Horus X10S Express

Posted: Thu Aug 29, 2019 11:06 am
by Kilrah
What did you copy them across from?

Re: Horus X10S Express

Posted: Thu Aug 29, 2019 11:57 am
by BillE
An X10S

Re: Horus X10S Express

Posted: Thu Aug 29, 2019 5:00 pm
by Kilrah
And you used companion to convert them, right?

Envoyé de mon 16th en utilisant Tapatalk


Re: Horus X10S Express

Posted: Thu Aug 29, 2019 5:22 pm
by BillE
I used 2.2 to read them from the X10S, saved the file. Opened the file in 2.3 and then saved it to the Express. I didn't "convert". Have I missed a step??

Re: Horus X10S Express

Posted: Thu Aug 29, 2019 7:27 pm
by Kilrah
Was 2.3 configured to x10 express type? If yes then it would have done the conversion, which means there's a bug in that process.

Re: Horus X10S Express

Posted: Thu Aug 29, 2019 8:51 pm
by BillE
I can confirm that 2.3 was configured to X10 Express. I've just re-done it and whilst the models saved to the radio, the widgets didn't.

Re: Horus X10S Express

Posted: Mon Sep 02, 2019 6:18 pm
by Kilrah
Should now be fixed in the latest nightly.

Re: Horus X10S Express

Posted: Tue Sep 03, 2019 7:01 am
by BillE
I must be doing something wrong then as it isn't fixed for me.

In Companion 2.2.4 I connect my X10S and read settings and models from TX. I then save the otx file to my PC, eject and disconnect my X10S.

I close down Companion 2.2.4 and open Companion 2.3

I open the otx file in Companion 2.3 and then connect my X10 Express. I write the setting and models to the TX. The models are fine (I've checked a recent change, so I know I have the correct file etc), but the home screen widgets don't show.

Am I doing something wrong?

Many thanks

Bill

Re: Horus X10S Express

Posted: Tue Sep 03, 2019 7:16 am
by Kilrah
On which companion 2.3 nightly version have you just been trying?

Re: Horus X10S Express

Posted: Tue Sep 03, 2019 7:38 am
by BillE
You're a STAR!

I had updated to the latest firmware, but forgot about the latest companion.

I can confirm it works as expected.

(Apologies, operator error!)

Re: Horus X10S Express

Posted: Thu Sep 05, 2019 6:17 pm
by BillE
I'm starting to have a play with the X10S Express with the latest nightlie - not to fly, but to get used to it.

I've run into two problems:

1) I can't find a way to bind to my old D16 receivers - the only option I have is ISRM

2) I have an Access RX4R. I put the TX into "Register", power the RX holding down the F/S Button, get a red and green solid LED, but nothing happens. It won't register.

Problem? Or operator error (again) ?

Many thanks

Bill

Re: Horus X10S Express

Posted: Fri Sep 06, 2019 7:05 pm
by BillE
Can anyone confirm that D16 compatibility is available in the nightly build of 2.3 please?

I can now connect an Access RX (I needed too update the RX firmware), but I cannot see how to connect a D16 RX.

Re: Horus X10S Express

Posted: Fri Sep 06, 2019 7:14 pm
by Kilrah
Image

Re: Horus X10S Express

Posted: Fri Sep 06, 2019 7:32 pm
by BillE
Any idea why mine says something different?? (LR12)

Re: Horus X10S Express

Posted: Fri Sep 06, 2019 8:22 pm
by Kilrah
That is another available choice... just select the right one.

Re: Horus X10S Express

Posted: Fri Sep 06, 2019 8:26 pm
by BillE
I have the choice of Access or LR12 - No D16 in that menu :(

Re: Horus X10S Express

Posted: Fri Sep 06, 2019 9:26 pm
by Kilrah
Current nightly build should have it. You didn't say which one you were using.

Re: Horus X10S Express

Posted: Fri Sep 06, 2019 10:12 pm
by BillE
I'm using the latest - 2.3.0N80

Re: Horus X10S Express

Posted: Sun Sep 08, 2019 7:40 am
by BillE
I've made some progress on this.

I am in the UK so select "EU" when downloading the firmware. I do not have the option of D16.

If I download the firmware without selecting "EU" I DO have the D16 option.

I understand why the D8 is unavailable in the EU, but not the D16.

Re: Horus X10S Express

Posted: Sun Sep 08, 2019 8:33 am
by Kilrah
Likely a bug, the eu checkbox used to disable "the second item" and since there is no D8 the second item is now D16.

Re: Horus X10S Express

Posted: Sun Sep 08, 2019 9:20 am
by Kilrah
Confirmed, will be fixed in tomorrow's build.

Re: Horus X10S Express

Posted: Mon Sep 09, 2019 6:57 am
by BillE
Many thanks, now working & I can successfully register/bind D16 & Access RX's :)