eepskye on MAC

eepSKYe is the desktop too for flashing and managing your sky9x firmware.
Post Reply
flybabo
Posts: 143
Joined: Wed May 16, 2012 11:41 pm
Country: United States
Location: SF Bay Area, CA

eepskye on MAC

Post by flybabo » Sat Feb 21, 2015 11:19 pm

Attached MAC version of eepskye built on the latest El Capitan OS version with Qt5 library.
Note that r418 was built on Yosemite OS version with Qt4 library.

EDIT: Added eepskye-r418.zip (July 27, 2015), added eepskye-r419.zip (January 11,2016)
Attachments
eepskye-r419.zip
(13.22 MiB) Downloaded 132 times
eepskye-r418.zip
(9.53 MiB) Downloaded 128 times
Last edited by flybabo on Mon Jan 11, 2016 6:51 pm, edited 5 times in total.

User avatar
jhsa
Posts: 18131
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: eepskye on MAC

Post by jhsa » Sat Feb 21, 2015 11:21 pm

Thanks..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

nuttybrewer
Posts: 5
Joined: Wed Jul 22, 2015 8:38 pm
Country: -

Re: eepskye on MAC

Post by nuttybrewer » Wed Jul 22, 2015 8:42 pm

Can you give a short post on how you compiled all this (I don't see any Makefiles or autoconfig files anywhere). I'd like to update to Mike's latest version but all his build stuff is for Windows. If you've got most of it ported... Actually, I'm sure Mike would probably appreciate if you submitted a patch on his Github page and then we can all benefit from it!

Thanks!

User avatar
MikeB
9x Developer
Posts: 15807
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: eepskye on MAC

Post by MikeB » Tue Jul 28, 2015 8:39 am

Can you run QTcreator on your MAC? This is what is used to build eepskye. There is a .pro file that tells QT what to compile.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

flybabo
Posts: 143
Joined: Wed May 16, 2012 11:41 pm
Country: United States
Location: SF Bay Area, CA

Re: eepskye on MAC

Post by flybabo » Mon Jan 11, 2016 6:43 pm

I just posted eepskye-r419 built on the latest El Capitan OS/X with Qt5.5 library.
Note that this version may not work with retired OS/X.
"Retired" means Apple stopped releasing the security updates which makes the OS vulnerable from malicious attacks.
Those retired versions include Snow-Leopard (10.6.8) which was released on 8/28/2009 and Apple stopped updating security patches as of 5/12/2012.
If the latest eepskye doesn't work on your Mac with retired OS, you may keep using the old eepskye or build it by yourself or update your Mac to the latest OS which is free.
Please don't ask us to build one for those retired OS's, it's simply not possible.


schliden
Posts: 18
Joined: Mon Jan 11, 2016 1:54 am
Country: -

Re: eepskye on MAC

Post by schliden » Tue Jan 12, 2016 2:35 pm

I have looked but can't find ANY version of eepskye that works on snow-leopard. Can you suggest where I might find an older compatible version ?

Lots of people still use snow-leopard (Many issues with later versions of osx)

Do you know what stops the build working for older osx versions ? Is it just a matter of a compile target, or are there other dependencies that prevent it working ?

Thanks

flybabo
Posts: 143
Joined: Wed May 16, 2012 11:41 pm
Country: United States
Location: SF Bay Area, CA

Re: eepskye on MAC

Post by flybabo » Wed Jan 13, 2016 1:20 am

Sorry, I don't know about full history of eepskye on Mac.
I guess I started building the eepskye for Mac from Mountain-Lion version.
Based on my quick Googling, you'll need Xcode 3.2 and Qt4 library to build eepskye on Snow-Leopard.
You still can download old Qt4 library, but I'm not sure whether you can get a compatible Xcode.
If you don't have Xcode package, you can't compile and build Mac applications.
Note that the latest Xcode 7.x doesn't run on the Snow-Leopard.
From El Capitan, they no longer supports Qt4 library as well.
It's understandable as the first Qt4 library was released about 10 years ago.
Just out of curiosity, what are the issues on the later version of OSX as I see no one who's still using Snow-Leopard?

schliden
Posts: 18
Joined: Mon Jan 11, 2016 1:54 am
Country: -

Re: eepskye on MAC

Post by schliden » Thu Jan 14, 2016 9:29 am

I actually do have Xcode (3.2.6) installed, so that's not an issue.

Perhaps I will have a crack at compiling it... (Are there any instructions available)

The issue that I have/had with later versions of OSX is primarily with SMB/Samba performance, which, I was waiting and hoping would be fixed, but by all accounts has become even worse in the more recent releases of OSX.

I would actually UG to Mountain Lion or Mavericks now if I could, but of course the only upgrade option from apple is the latest "El Capitan" which has major Samba/Networking issues and might also run like a dog on my aging iMac...

I guess I kinda shot myself in the foot by holding off..

User avatar
Kilrah
Posts: 9671
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: eepskye on MAC

Post by Kilrah » Thu Jan 14, 2016 11:08 am

What's wrong with Samba on El Capitan? I use it every day and have no issues. Apart from a relatively high CPU usage that is, but that's been there as far back as I can remember.

schliden
Posts: 18
Joined: Mon Jan 11, 2016 1:54 am
Country: -

Re: eepskye on MAC

Post by schliden » Fri Jan 15, 2016 5:46 am

I also use samba every day and can't afford to have any issues.

So, my experience is anecdotal, but issues appear to be include permissions and performance.

I probably need to bite the bullet and test on another machine in my environment and see for myself.

flybabo
Posts: 143
Joined: Wed May 16, 2012 11:41 pm
Country: United States
Location: SF Bay Area, CA

Re: eepskye on MAC

Post by flybabo » Sat Jan 16, 2016 1:37 am

I'm connecting SAMBA-based home server every day and I didn't noticed the performance issue.
But mileage may vary depending on the hardware.

Building an eepskye is simple.
1. Download and install Qt 4.8 on your Mac
https://download.qt.io/archive/qt/4.8/
2. Create a makefile using qmake at eepskye source directory
$ qmake -spec macx-g++ eepskye.pro
3. Build an app bundle
$ make
It should create an eepskye.app application bundle.
4. Build a dmg for distribution or just copy eepskye.app directory to your application folder
$ macdeployqt eepskye.app -dmg

If you build one, why don't you post it for other Snow-Leopard users?
Good luck!

User avatar
FrickelGerry
Posts: 14
Joined: Thu Oct 04, 2012 7:34 am
Country: Germany

Re: eepskye on MAC

Post by FrickelGerry » Sat Aug 06, 2016 6:31 pm

Small problem: internationalization isn't working on my Mac. Even if i place the needed *.qm files inside a eepfiles folder inside the MacOS folder inside the application bundle. Without it i can only choose "english (default)", with this folder in place, i can choose "german" from the pull down menu, but even after restarting the app, the ui stays in english.

User avatar
MikeB
9x Developer
Posts: 15807
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: eepskye on MAC

Post by MikeB » Sat Aug 06, 2016 7:41 pm

It works on Windows, but does need a restart. I don't have a MAC so I don't know where to look.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

tsenecal
Posts: 43
Joined: Wed Mar 22, 2017 8:32 pm
Country: United States

Re: eepskye on MAC

Post by tsenecal » Fri Mar 31, 2017 10:31 pm

Mike, I have downloaded and installed QT Creator on my mac, and am trying to compile eepskye... it fails with the following:

/Users/mscoop/yagarto/mbtx/eepe/eepskye/src/modeledit.cpp:9: error: 'ProtocolDialog.h' file not found
#include "ProtocolDialog.h"
^

there is a "ProtocolDialog.cpp" in the src directory, but no "ProtocolDialog.h"...

User avatar
MikeB
9x Developer
Posts: 15807
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: eepskye on MAC

Post by MikeB » Fri Mar 31, 2017 11:26 pm

I'll get that file added, it seems to have found its way into the "ignore" list!

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

tsenecal
Posts: 43
Joined: Wed Mar 22, 2017 8:32 pm
Country: United States

Re: eepskye on MAC

Post by tsenecal » Mon Apr 10, 2017 4:35 am

Mike,

i was able to compile eePskye on my mac today, after updating my git repository... it looks like you pushed quite a few files up to your master repository... only one error kept me from compiling this version on first try. i had to add "#include <QFileDialog>" at the top of the telemetry.cpp file in "common"

tsenecal
Posts: 43
Joined: Wed Mar 22, 2017 8:32 pm
Country: United States

Re: eepskye on MAC

Post by tsenecal » Mon Apr 10, 2017 2:52 pm

Just a further note on what i am doing:

OS: mac os x 10.9.5
Qt Creator 4.2.1
Qt 5.8.0 (Clang 7.0 (Apple), 64 bit) (downloaded latest stable build)

ran the stamp-eepskye-gen shell script
opened the "eepskye.pro" in Qt Creator, and did a "Build Project"
ran the resulting eepskye.app.

tsenecal
Posts: 43
Joined: Wed Mar 22, 2017 8:32 pm
Country: United States

Re: eepskye on MAC

Post by tsenecal » Tue Apr 11, 2017 3:30 am

attached is a zip file of a mac dmg, of the latest master branch source (the changes Mike merged on 4/9?), compiled using qmake and xcode on mac os 10.6.8, with Qt version 4.8, for those that wish to try it out... right now it has my branch info in it for version numbering, and doesn't list itself as r420 or r421, if someone would like to tell me what/where to edit, i will update that. if i am not mistaken, i believe it is simply the content of the stamp-eepskye.h file, but not 100% certain that is all i need to edit.
Attachments
eepskye.dmg.zip
10.6.8 compiled latest source
(25.9 MiB) Downloaded 53 times

Post Reply

Return to “eepSKYe”