Page 2 of 2

Re: OpenXSensor GPS project 101

Posted: Sun Oct 08, 2017 7:07 pm
by mstrens
Fine that you could upload.
Please note that when you will start oXs with a gps, oXs will not start immediately to send data over Sport.
oXs sent gps data only when the gps get some kind of fix (and so know his position with enough accuracy) . It can take some time (minutes) before gps get a fix.
Most gps module have 2 led too. One is permanently ON and says that gps is powered on. The second will blink when the gps get some fix.
Please note that there can be a delay (e.g. 30 sec) between the gps led blinking and oXs sending data.
Just be patient.

Re: OpenXSensor GPS project 101

Posted: Sun Oct 08, 2017 8:34 pm
by Richard
Thanks a lot for the heads up. I guess I will be able to connect the GPS on Tuesday. USPS messed up with the delivery.
WIll be in touch.

Re: OpenXSensor GPS project 101

Posted: Fri Oct 13, 2017 8:28 pm
by Richard
Well, good news. The GPS is working just fine. I tested in the bench (outside) as you suggested and everything happened as you said. Then, I put it in the car, and made a "crash simulation" by disconnecting the receiver battery at a point which I could identify in Google, like a street intersection, to verify the latency. The results were really good, considering that there must have an error in synchronizing the battery disconnection with the center of the intersection. The fat is that using the last logged speed and comparing the last logged location with the street intersection, the difference was 7m, which translated to time, at the given speed, gave me .6 sec. Which is just over 10 times better than the FrSKY unit. Also I confirmed heading. I am having some difficulties in finding a shrink tube big enough to wrap GPS and Arduino, but its on its way and I expect to make a test on a plane next week.
I am thinking in putting together a video including all the information that I was collecting from this and the other thread, so that if by any chance there some other newvy it will shortcut some questions.
Thanks a lot for your help.

Re: OpenXSensor GPS project 101

Posted: Sat Oct 14, 2017 7:13 am
by mstrens
Happy to hear that you got it.

Re: OpenXSensor GPS project 101

Posted: Sun Oct 15, 2017 3:39 pm
by Richard
I did, thanks to your support.
I like this so much I will look into adding some other DYI sensor. Will keep you posted.

Re: OpenXSensor GPS project 101

Posted: Mon Nov 20, 2017 9:04 pm
by Richard
Sorry, but I got in the cyberspace.
The GPS worked as expected. I already added a MS5611 to have a good reading for the altitude, although both GPS and MS5611 are pretty consistent.
Now, here is a challenge for the developers: (Actually, two challenges)
1) You most probably know that Hobby Eagle came time ago with the A3 SuperII stabilization device, which has a data port that send flight info to a PC (attitude, and accelerometers. It would be possible to hook it up to the Arduino and from there to the FrSky telemetry?
2) Is any way to work with Lat, Long from the GPS without using LUA scripts? Like to set alarms for flight space limits?

Re: OpenXSensor GPS project 101

Posted: Tue Nov 20, 2018 8:16 pm
by Richard
mstrens wrote:
Tue Aug 29, 2017 1:58 pm
An arduino nano has already a converter usb/serial. So there is no need for a FTDI.

With openXsensor (oXs) there is no need to configure the neo7M (or the neo6 or neo8) because at every startup oXs assume that the gps uses the default configuration from Ublox and send some code to the gps to upload the config required by oXs it self.

I would recommend to use an arduino pro mini instead of a nano because with the nano it could be that there would be some conflict on the Tx/Rx pins (not sure about this).

For more explanation on how to setup oXs, please read the file oXs_config_description.h that is available on github with the whole package.
The rate of the GPS can be changed editing the file oXs_gps.cpp.
One of the 3 folowing lines must be uncommented (here 5 hz is uncommented)
// 0xB5,0x62,0x06,0x08,0x06,0x00,0xE8,0x03,0x01,0x00,0x01,0x00,0x01,0x39, // NAV-RATE for 1 hz
0xB5,0x62,0x06,0x08,0x06,0x00,0xC8,0x00,0x01,0x00,0x01,0x00,0xDE,0x6A, // NAV-RATE for 5 hz
// 0xB5,0x62,0x06,0x08,0x06,0x00,0x64,0x00,0x01,0x00,0x01,0x00,0x7A,0x12, // NAV-RATE for 10 hz
Hi guys. I have the openXsensor set with an arduino mini, a barometer and a Neo7M GPS. It works great.
On the other hand, I was working time ago in another project with a flight controller where I used a Neo8M GPS, and I really like it a lot. Therefore, I say to myself, why not to swap the neo7M by the neo8M in the Arduino?
I did just a pin to pin swap, and not surprising, it didn't work.
I am using an Arduino pro mini, with the resistor in the pin 6.
Any idea of why wouldn't this work? Arduino and GPS work in their original setup (Arduino+Neo7 and Neo8+Flight controller).
Thank you

Re: OpenXSensor GPS project 101

Posted: Tue Nov 20, 2018 9:37 pm
by mstrens
oXs works with Neo8M just like with Neo7M.
I made several devices with Neo6,7 and 8.
I just had once an issue. A module was declared on aliexpress as an Ublox Neo? but in fact it was not an ublox chip inside.
So oXs was unable to reconfigure it in order to get the expected types of message at the expected speed.
This was clearly deùmonstated when I conected it to the UCenter tool provided by Ublox

Re: OpenXSensor GPS project 101

Posted: Tue Nov 20, 2018 9:47 pm
by Richard
I guess I have something wrong with the wires then. Also, I will run the UBlox utility. I think I did that before with this unit but I'm not 100% sure. Thank for confining this must work.

Re: OpenXSensor GPS project 101

Posted: Wed Nov 21, 2018 10:32 pm
by Richard
mstrens, I ckecked out the Neo8 with the U-center. The only thing I found and that can be the reason why I don't have comm with the Arduino, is that the GPS is running at 38,400bps. Neo7 in the U-center connects at 9600. Therefore, I have a couple of questions: Is the Arduino running at 9600? and If the speed must be 9600, how do I change the speed of the Neo8?

Re: OpenXSensor GPS project 101

Posted: Thu Nov 22, 2018 8:47 am
by mstrens
As far I know, the Ublox gps (e.g. NEO8) have a default baud rate of 9600.
So, when they are powered on, they are sending/receiving bytes at 9600.
In the startup process, oXs expect that the GPS is set on 9600bds and it sent some commands at 9600 bds to the GPS to ask him to sent some messages in a specific Ublox format. It also sent a command to ask the GPS to switch on 38400 baud (for better performance).
From this, oXs get messages from gps at 38400 baud.

If at startup you gps sent messages at 38400 baud, it an issue because it means that the gps can not handle the commands that oXs sent.

I think that some GPS module have an eeprom/battery that let the user change the (default) setting uses at power on.
I think you can use the Ucenter to change this setting but I never had to do it myself.

Re: OpenXSensor GPS project 101

Posted: Thu Nov 22, 2018 12:01 pm
by Richard
Thanks a lot for your response mstrens.
I noticed the ucenter has a config tab, where to set the speed, but I think I will have to do some further research before I risk to mess up the GPS.
It seems that the Noe8 I have it came by default to 38400.
The other option would be to find a Neo8 whose default is 9600.
I'll report back with what did work to have the Neo8 work for my case.
Kind regards

Re: OpenXSensor GPS project 101

Posted: Thu Nov 22, 2018 12:52 pm
by mstrens
If you do not succeed changing the default baudrate to 9600, I should be possible to modify oXs code in order to let him send the commands at 38400 at startup.

Re: OpenXSensor GPS project 101

Posted: Thu Nov 22, 2018 3:03 pm
by Richard
That sounds outstanding. I was able to change the baud rate, but still I have no comms. However, I'll do some more tests because I know that the s port will not discover the GPS until the are several satellites fixed, and the initial test was indoors. Will let you know later what happens when I got outside.

Re: OpenXSensor GPS project 101

Posted: Thu Nov 22, 2018 5:28 pm
by mstrens
It can take several minutes before you get the fix.o any gps modules have a led that blink when the gps get the fix.

If it does not work, you can try to connect a usb to serial (ftdi) on the line TX signal from the gps.
So, you could get on the PC a copy of the messages sent by the gps but it can be difficult to read because oXs asks for a binary protocol.
If required, I can also add some lines of code to oXs to try to debug the issue.

Re: OpenXSensor GPS project 101

Posted: Thu Nov 22, 2018 5:42 pm
by Richard
Thank you mstrens.
I am sending here the screen I missed in my previous message. I will look into your suggestion about connecting the TX to the PC, and come back to you.
GPS port config.jpg

Re: OpenXSensor GPS project 101

Posted: Fri Nov 23, 2018 5:02 pm
by Richard
Good news mstrens.
When I connected the Neo8 back to the Ucenter, I found out that it had not changed the baud rate, therefore, I changed it back to 9600, saved, disconnected everything, connected back again to verify that it was still in 9600, and voila, it was. Connected to Arduino and now, it was working very good.
Case closed. Thank you for your help.

Re: OpenXSensor GPS project 101

Posted: Fri Nov 23, 2018 6:14 pm
by mstrens
Fine that you find the solution.
Confratulation.

Re: OpenXSensor GPS project 101

Posted: Fri Nov 23, 2018 7:31 pm
by Richard
Thanks a lot