oxs gps BN-220

Development & General Chat for the superb openxvario project.

Moderator: rainer

Post Reply
nesan
Posts: 22
Joined: Thu Nov 09, 2017 2:05 am
Country: -

oxs gps BN-220

Post by nesan » Sat Nov 21, 2020 3:55 pm

Hi smart people!
I am stumble with a problem . the openXsensor in my case Arduino nano with BN-220 gps get fix once in a while for a moment then loos the fix. could do you guys direct me to solve the problem?

kindly request to mstrens if you can spare little time


mstrens
Posts: 1434
Joined: Fri Dec 27, 2013 7:49 pm
Country: -

Re: oxs gps BN-220

Post by mstrens » Sat Nov 21, 2020 4:13 pm

I do not expect that this is oXs related. It is probably an internal GPS issue.
Did you try to check your GPS using ublox u-center.
This freeware allows you to get and to display the data provided by the GPS

nesan
Posts: 22
Joined: Thu Nov 09, 2017 2:05 am
Country: -

Re: oxs gps BN-220

Post by nesan » Sat Nov 21, 2020 6:17 pm

mstrens wrote:
Sat Nov 21, 2020 4:13 pm
I do not expect that this is oXs related. It is probably an internal GPS issue.
Did you try to check your GPS using ublox u-center.
This freeware allows you to get and to display the data provided by the GPS



Hi thanks for come up. I did not try u-center yet. could you explain how to connect to the u-center? before that I will brief what I did was connect the gps rx pin with out 10k resistor for first few times.
Then with 10k connected got fix for very short time.
folow your other direction at "viewtopic.php?t=10654" and did the first test there are no activity after these line

openXsensor starting..
milli=0
freeRam=523
Enter setup voltage
Reference voltage:1100
Voltage:1 , pin=6 , offset=0 , mVoltPerStep=17.92
Voltage:2 , pin=8 , offset=0 , mVoltPerStep=2.01
Voltage:3 , pin=8 , offset=0 , mVoltPerStep=3.44
Voltage:4 , pin=8 , offset=0 , mVoltPerStep=3.98
Voltage:5 , pin=8 , offset=0 , mVoltPerStep=1.08
Voltage:6 , pin=8 , offset=0 , mVoltPerStep=3.88
vario setting up..
vario is up..
End of GPS setup
FRSky Output Module: TX Pin=4
Sport protocol= 1
End of general set up



could I burn the rx pin of GPS by connecting with out 10K resistors for the first few times?
Last edited by nesan on Sat Nov 21, 2020 6:25 pm, edited 1 time in total.

nesan
Posts: 22
Joined: Thu Nov 09, 2017 2:05 am
Country: -

Re: oxs gps BN-220

Post by nesan » Sat Nov 21, 2020 6:34 pm

mstrens wrote:
Sat Nov 21, 2020 4:13 pm
I do not expect that this is oXs related. It is probably an internal GPS issue.
Did you try to check your GPS using ublox u-center.
This freeware allows you to get and to display the data provided by the GPS
Ok I have found out how to test GPS module with U-Center! I will let you know after testing the GPS module.

mstrens
Posts: 1434
Joined: Fri Dec 27, 2013 7:49 pm
Country: -

Re: oxs gps BN-220

Post by mstrens » Sat Nov 21, 2020 6:43 pm

Note : to check if the Rx pin is defect, you have (with U-center) to send some commands to the GPS and not only listen to the data it sent.

At start up, oXs sent some commands to the gps in order to activate some types of messages and to change the baudrate.
It the Rx pin is defect, it could be that those commands are not executed by the GPS and so, oXs does not get the data it expects.


nesan
Posts: 22
Joined: Thu Nov 09, 2017 2:05 am
Country: -

Re: oxs gps BN-220

Post by nesan » Sat Nov 21, 2020 8:04 pm

mstrens wrote:
Sat Nov 21, 2020 6:43 pm
Note : to check if the Rx pin is defect, you have (with U-center) to send some commands to the GPS and not only listen to the data it sent.

At start up, oXs sent some commands to the gps in order to activate some types of messages and to change the baudrate.
It the Rx pin is defect, it could be that those commands are not executed by the GPS and so, oXs does not get the data it expects.
Hi I could not find my serial ttl anywhere. so ordered one, I will be back once I make sure the GPS unit is good by u-center. rather I do not want wast your time if it is a bad unit. thanks mstrens.

nesan
Posts: 22
Joined: Thu Nov 09, 2017 2:05 am
Country: -

Re: oxs gps BN-220

Post by nesan » Sat Nov 21, 2020 10:21 pm

Hello hello.! some good news! at least for me;
I need to know how. As I decide to give one more try, this time I connect the MPU6050 also gps and voila GPSs instant fix. How and why? what is the connection MPU5060 to GPS?. So the GPS unit is not defective; "although I ordered another one from amazon".
Could you please explain this mstrens ..!?
Attachments
20201121_164344.jpg
20201121_164327.jpg

User avatar
kalle123
Posts: 841
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: oxs gps BN-220

Post by kalle123 » Sun Nov 22, 2020 7:37 am

Get used to work with u-center before fussing around with oXs and GPS. ;)

And when no USB UART is around, just use your Arduino to connect your GPS to u-center.

https://create.arduino.cc/projecthub/Pa ... ter-475533

br KH

mstrens
Posts: 1434
Joined: Fri Dec 27, 2013 7:49 pm
Country: -

Re: oxs gps BN-220

Post by mstrens » Sun Nov 22, 2020 8:22 am

If your config declares that a mpu6050 is connected but the mpu is not connected, it can block oXs because there are some time out on the i2C bus.
Same issue exist with other I2C sensor (like MS5611).

This was perhaps the reason.

nesan
Posts: 22
Joined: Thu Nov 09, 2017 2:05 am
Country: -

Re: oxs gps BN-220

Post by nesan » Sun Nov 22, 2020 4:45 pm

kalle123 wrote:
Sun Nov 22, 2020 7:37 am
Get used to work with u-center before fussing around with oXs and GPS. ;)

And when no USB UART is around, just use your Arduino to connect your GPS to u-center.

https://create.arduino.cc/projecthub/Pa ... ter-475533

br KH
Yes I admit. I am kind of tight in my facilities the rc hobby made me big mess around me. could not find thing when i need it. I will as you suggest me get in used to u-center .
thanks for your direction
Nesan :)

nesan
Posts: 22
Joined: Thu Nov 09, 2017 2:05 am
Country: -

Re: oxs gps BN-220

Post by nesan » Sun Nov 22, 2020 4:52 pm

mstrens wrote:
Sun Nov 22, 2020 8:22 am
If your config declares that a mpu6050 is connected but the mpu is not connected, it can block oXs because there are some time out on the i2C bus.
Same issue exist with other I2C sensor (like MS5611).

This was perhaps the reason.
HI thanks mstrens ! I thought the same; but only now I assure that could be the Problem After your confirm it.
and sorry for my mistakes after all as a beginner here.

Thank again
Nesan :)


Post Reply

Return to “OpenXVario - an open source vario supported by the open source firmwares!!”