Sensor without Altimeter

Development & General Chat for the superb openxvario project.

Moderator: rainer

Post Reply
PeterB
Posts: 9
Joined: Tue Jan 07, 2020 6:40 pm
Country: -

Sensor without Altimeter

Post by PeterB » Tue Jan 07, 2020 7:05 pm

This issue may have been covered already, but I’m a newbie to this forum....
I’ve successfully made GPS & voltage/current sensors with MS5611 Altimeter/vario, but am now trying to exclude the MS5611 as I assume this would conflict with an Rx which has a built-in Altimeter.

I’ve tried changing the 1st vario from MS5611 to NO_BARO as instructed in the options, but this causes the compilation to fail as the output.cpp has a problem with references to MS5611.cpp in relation to Vario & Vspeed.
Has anyone managed to get a sensor working without an Altimeter/vario?


mstrens
Posts: 1292
Joined: Fri Dec 27, 2013 7:49 pm
Country: -

Re: Sensor without Altimeter

Post by mstrens » Tue Jan 07, 2020 7:23 pm

That is strange.
Normally it should work.
Can you put here your 2 config files?

PeterB
Posts: 9
Joined: Tue Jan 07, 2020 6:40 pm
Country: -

Re: Sensor without Altimeter

Post by PeterB » Tue Jan 07, 2020 8:36 pm

Hi,
The requested files are attached.
Note that I have changed the sketch #includes to point at the correct variants of the 2 h files.
The h files are renamed copies of a working GPS & Altimeter sensor project, with only the 1st vario option changed.
I am compiling the sketch to run on a 5V Mini Pro board.
I've also added a copy of the compiler error report if that helps
Peter
Attachments
OpenXError report.rtf
(1.22 KiB) Downloaded 9 times
oXs_config_advanced_GPS_No_Alt.h
(15.95 KiB) Downloaded 6 times
oXs_config_basic_GPS_No_Alt.h
(11.47 KiB) Downloaded 7 times

mstrens
Posts: 1292
Joined: Fri Dec 27, 2013 7:49 pm
Country: -

Re: Sensor without Altimeter

Post by mstrens » Tue Jan 07, 2020 9:49 pm

It is very strange.
I tried your 2 files and I have no compilation error.

Did you dowload the latest oXs version?

PeterB
Posts: 9
Joined: Tue Jan 07, 2020 6:40 pm
Country: -

Re: Sensor without Altimeter

Post by PeterB » Tue Jan 07, 2020 10:02 pm

I will double check, but I had a version which was last modified around 2months before.
If OpenXsensor has been updated more recently then I will get the latest & try again.


User avatar
kalle123
Posts: 761
Joined: Sat Mar 29, 2014 10:59 am
Country: -
Location: Moenchengladbach

Re: Sensor without Altimeter

Post by kalle123 » Wed Jan 08, 2020 6:59 am

Arduino 1.8.10, oXs 8.2.13.

No errors with those two config files here ...

br KH

PeterB
Posts: 9
Joined: Tue Jan 07, 2020 6:40 pm
Country: -

Re: Sensor without Altimeter

Post by PeterB » Wed Jan 08, 2020 9:24 am

Installed latest OpenXsensor from Github (same as I had previously installed end December 2019) but still have same problem.
Compiles ok if 1st Vario is MS5611 or BMP085. Fails if NO_BARO or GY86. Not tried other options yet.
Using Arduino 1.8.5. Maybe I need to update the IDE?
Cannot see where osX version No. is identified.

Just to confirm - when installing osX, I need to take the OpenXSensor folder from the OpenXsensor-master extracted set & put this in the top level of the libraries folder? Otherwise the sketch #includes cannot find the library files.

PeterB
Posts: 9
Joined: Tue Jan 07, 2020 6:40 pm
Country: -

Re: Sensor without Altimeter

Post by PeterB » Wed Jan 08, 2020 3:23 pm

Okay... now sorted.

I upgraded my IDE to 1.8.10 - no difference.
Then noticed that the compiler error report mentioned duplicate files, so I deleted all other unique named variants of the basic & advanced config files & renamed my non-Vario basic & advanced config files to the original default names (plus changed my sketch #include config filenames back to suit).
The 1st vario selected to NO_BARO option now compiles correctly.

Thus, I suspect that when you kind chaps had checked the issue out, you had probably renamed the config files to the default names & left the sketch file untouched.

Anyway, problem appears to be sorted, but interesting that the compiler doesn’t appear to like other unique config filenames with the 1st vario set to certain selections?

PeterB
Posts: 9
Joined: Tue Jan 07, 2020 6:40 pm
Country: -

Re: Sensor without Altimeter

Post by PeterB » Fri Jan 10, 2020 11:33 am

Just seen an interesting post from Carbo about setting up a GY86, but it also showed his project file structure which has separate copies of oXs for each project - thus separate versions of the config files, but all with the default names.
This means that my original issue with the NO-BARO option would not happen.

I was trying to follow the method of having all sketches & a single libraries folder at the same directory level - which then needed different config files for each project in the library folder.
Carbo’s method is cleaner - just uses more disc space - so I will change to that for openXsensor projects.


Post Reply

Return to “OpenXVario - an open source vario supported by the open source firmwares!!”