Turnigy 9XR Settings

tgy9x is a fork of er9x, and is the default firmware that is released by hobbyking on the Turnigy 9XR transmitter.
Post Reply
stilllearning
Posts: 10
Joined: Fri Feb 03, 2017 10:36 pm
Country: -

Turnigy 9XR Settings

Post by stilllearning » Thu Dec 28, 2017 10:52 pm

I would appreciate some assistance with my Tarot 680 PRO setup. I haven't had much luck since changing my DJT module and D series receiver to the module and receiver listed below.
TX: Turnigy 9XR Pro (XJT module) w/ersky9x-200, v. 1760-Mike
RX: FrSky X8R using SBUS
FC: Naza M V2

If anyone has the same setup I would appreciate information on the mixer settings and internal and external protocol settings. I have the DJI Naza software and eePe sky software. I've bound the receiver using jumpers on pins 1-2 and 3-4 then removed the jumpers. Motors won't respond. I think it is the TX settings. Again thanks for any help.

User avatar
MikeB
9x Developer
Posts: 15794
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Turnigy 9XR Settings

Post by MikeB » Fri Dec 29, 2017 12:31 am

If you have the XJT module and a "X" receiver, then you should change the external module settings to PXX (not PPM), then bind the Rx using the "Bind" option in the menu. The Rx then doesn't need any links at bind time.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

stilllearning
Posts: 10
Joined: Fri Feb 03, 2017 10:36 pm
Country: -

Re: Turnigy 9XR Settings

Post by stilllearning » Fri Dec 29, 2017 1:03 am

Thanks!! FYI the external module in my 9XR Pro doesn't show PXX as an option. I have read that XJT is the correct external protocol option and I have selected that. That may actually be the PXX choice you refer too. Also what does the internal module protocol settings need to be if any? Thanks again.

stilllearning
Posts: 10
Joined: Fri Feb 03, 2017 10:36 pm
Country: -

Re: Turnigy 9XR Settings

Post by stilllearning » Fri Dec 29, 2017 1:23 am

I followed your instructions and motors now work fine. Thanks again!!

Post Reply

Return to “tgy9xr”