MasterRadio TX16S

erskyTx runs on many radios and upgrade boards
ersky9x was a port of er9x for use on the sky9x board.
phil
Posts: 84
Joined: Thu Jan 14, 2016 7:03 am
Country: Germany
Location: München

Re: MasterRadio TX16S

Post by phil » Mon Mar 22, 2021 5:05 pm

I hit enter with the roller and suddenly the screen went black.
Power on does not work anymore, only the above characters are flashing. the power light does not burn at all anymore. When I let go of the power button, the blinking of the characters has gone out.
I have contact to the bootloader via the PC device manager.
Could the role have caused a black out? I didn't trust the part very much because the setting was not precise.


User avatar
MikeB
9x Developer
Posts: 17430
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: MasterRadio TX16S

Post by MikeB » Mon Mar 22, 2021 7:12 pm

Here are the instructions, from openTx, for using the STM bootloader:
http://open-txu.org/home/undergraduate- ... ing-zadig/

Follow these instructions and you should be able to get openTx back on, then we can go from there.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

phil
Posts: 84
Joined: Thu Jan 14, 2016 7:03 am
Country: Germany
Location: München

Re: MasterRadio TX16S

Post by phil » Tue Mar 23, 2021 4:45 am

Hy Mike

I checked and made it straight away. STM bootloader was always available.
The transmitter is "dead" no power lamp!
Presumably a case for warranty, I submitted. Let's see what comes out. I suspect the roller blacked out

phil

User avatar
MikeB
9x Developer
Posts: 17430
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: MasterRadio TX16S

Post by MikeB » Tue Mar 23, 2021 9:35 am

So did you managed to get openTx written to the radio, but it still doesn't work?

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

phil
Posts: 84
Joined: Thu Jan 14, 2016 7:03 am
Country: Germany
Location: München

Re: MasterRadio TX16S

Post by phil » Wed Mar 24, 2021 11:14 am

i make one video
20210323_191217_Trim.mp4
(6.02 MiB) Downloaded 23 times
phil


User avatar
MikeB
9x Developer
Posts: 17430
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: MasterRadio TX16S

Post by MikeB » Wed Mar 24, 2021 11:47 am

Just to be certain, is that after you flashed openTx after using Zadig and the power off method of flashing?

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

phil
Posts: 84
Joined: Thu Jan 14, 2016 7:03 am
Country: Germany
Location: München

Re: MasterRadio TX16S

Post by phil » Thu Mar 25, 2021 7:27 am

i was in opentx

phil
Posts: 84
Joined: Thu Jan 14, 2016 7:03 am
Country: Germany
Location: München

Re: MasterRadio TX16S

Post by phil » Fri Mar 26, 2021 4:47 pm

unfortunately I was unable to repair the transmitter. i watched help videos and tried everything.
the fault is probably in the motherboard.

phil
Posts: 84
Joined: Thu Jan 14, 2016 7:03 am
Country: Germany
Location: München

Re: MasterRadio TX16S

Post by phil » Fri Mar 26, 2021 7:26 pm

he is working again, has cost nerves!
i am happy

User avatar
MikeB
9x Developer
Posts: 17430
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: MasterRadio TX16S

Post by MikeB » Fri Mar 26, 2021 7:43 pm

What did you do to fix it?

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

phil
Posts: 84
Joined: Thu Jan 14, 2016 7:03 am
Country: Germany
Location: München

Re: MasterRadio TX16S

Post by phil » Fri Mar 26, 2021 8:02 pm

studying the video of bardwell, radiomaster bricked.
1. PC with driver for DFU, impulseRC
2. Transmitter without battery
3. Connection of PC to transmitter
4. loaded with companion software opentx

Very important The transmitter must be without a battery, no success with the battery connected. it took me a long time to get to this point

phil

phil
Posts: 84
Joined: Thu Jan 14, 2016 7:03 am
Country: Germany
Location: München

Re: MasterRadio TX16S

Post by phil » Sat Mar 27, 2021 7:15 am

Hi Mike,
my joy in experimenting is a little clouded. for me the software 223A9 in color with logical key assignment would be sufficient. This software is clear and quick to adapt and easy to use.
thank you phil

phil
Posts: 84
Joined: Thu Jan 14, 2016 7:03 am
Country: Germany
Location: München

Re: MasterRadio TX16S

Post by phil » Mon Mar 29, 2021 8:17 am

There are things that one does not understand.
before I could restart the transmitter I removed the erskyTx programs from the SD card. after the restart I loaded again via eePskye erskyTx.
There is no erskyTx on the bootloader, and there is no erskyTx on the SD card either, although I operate the transmitter with it!
where is the software hidden?

User avatar
Kilrah
Posts: 10870
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: MasterRadio TX16S

Post by Kilrah » Mon Mar 29, 2021 8:59 am

In the processor's built-in flash memory, the card doesn't hold firmware.

phil
Posts: 84
Joined: Thu Jan 14, 2016 7:03 am
Country: Germany
Location: München

Re: MasterRadio TX16S

Post by phil » Fri Apr 02, 2021 8:05 am

Hi Mike,
I noticed that the two lateral rotary valves SL and SR do not run synchronously. I've tried a lot but haven't made it. Do you have a guy there?
lovely Easter Phil

phil
Posts: 84
Joined: Thu Jan 14, 2016 7:03 am
Country: Germany
Location: München

Re: MasterRadio TX16S

Post by phil » Fri Apr 02, 2021 2:43 pm

there is always something new for me. Suddenly the power lamp from the Radiomaster shows "green" and not red. Firmware: erskyTx is from March 19, so the latest version. What has changed?
that's great!

User avatar
MikeB
9x Developer
Posts: 17430
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: MasterRadio TX16S

Post by MikeB » Sat Apr 03, 2021 10:22 am

I did fix a bug with the calibration of the SR slider being lost. You should have this fixed, but need to do a calibration to get the SR operating correctly.

I did change the power switch LED to be green for the TX16S. My Jumper T16 doesn't have a green LED.

Mike
erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

phil
Posts: 84
Joined: Thu Jan 14, 2016 7:03 am
Country: Germany
Location: München

Re: MasterRadio TX16S

Post by phil » Sun Apr 04, 2021 7:04 pm

Thanks for the information.
I noticed that with the A9r 223 software the RS signal was lost. The error was eliminated in the B3r 223 software. the slider
direction RS should be reversed so that when the button points upwards the bar also deflects upwards.
For the optics, it would be nice if some display images were placed more in the middle.
Thanks Mike

phil
Posts: 84
Joined: Thu Jan 14, 2016 7:03 am
Country: Germany
Location: München

Re: MasterRadio TX16S

Post by phil » Tue Apr 06, 2021 7:50 pm

attached are the screens with erskyTX.
LS and RS do not run in parallel
20210406_214025.mp4
(19 MiB) Downloaded 15 times
20210406_214221.mp4
(22.81 MiB) Downloaded 5 times


Post Reply

Return to “erskyTx (was ersky9x)”