Archer RS Receiver Register/Binding issues

Love the 9x? Use FRSky? Post your questions and answers here!
Post Reply
Malito77
Posts: 2
Joined: Sun Apr 10, 2022 7:10 pm
Country: United States

Archer RS Receiver Register/Binding issues

Post by Malito77 » Tue Apr 12, 2022 12:53 am

QX7S w/ Access
Betaflight F4 12A AIO
Archer RS Receiver

I have been having issues with this RS Receiver, it does not Register and Bind. I have updated both my Radio and Receiver with the newest firmwares.
I tried to Register it, did all the steps, tried it over and over about 50 times, nothing then on the 51st try it bound finally, Receiver popped up in radio monitor, hit the button, unplugged it from the battery, but never got to bound when turning the power back on, then it was like it lost the Register info and couldn't get to see the Receiver info anymore, always just chirped waiting and waiting again I could never get it back to that screen info where it Registered. so I tried the whole process again. tried another 30 times. nothing.
Help


Post Reply

Return to “The FRSKY Forum”