Experimenting er9xProv822u (19-Aug option to send "invert" cmd to MPM)

er9x is the best known firmware. It has a superb range of features and is well supported by the community. Well worth trying out.
Post Reply
Posts: 31
Joined: Sat Aug 15, 2020 8:45 am
Country: France

Experimenting er9xProv822u (19-Aug option to send "invert" cmd to MPM)

Post by nvd07 » Fri Aug 21, 2020 7:28 pm

Here are my tests with my Ytech STM32 multi protocol module and the new er9x test firmware that Mike posted on wednesday during the discussions on Timeless' MPM / AFHDS 2A thread https://openrcforums.com/forum/viewtopi ... 30#p151392

Previously with v822s i had tried to get my MPM module to talk inverted and uninverted by flashing it with the MPM INV and NOINV firmwares
https://openrcforums.com/forum/viewtopi ... 30#p151362

but in both cases the telemetry sent by the module was idling High / so always uninverted as explained here https://openrcforums.com/forum/viewtopi ... 84#p151360

So I can report that the new option/tickbox does show up in the menu as intended.

I tried both options, powering down/up between both tests.
So I do not see any change in the signal. Note that I had left my MPM module flashed with the same NOINV firmware in both the above cases (pic from the last flashing is below).

To be honest I am confused as to what is the expected behavior and if there is any precedence or priority between the MPM firmware compiling option and the bit command from this er9x menu... Mike is the command bit from er9x intended to override the compiling option of the MPM firmware? Or would I need to both change the state of the tickbox AND change the MPM firmware at the same time so that they remain in agreement ?

Last, it is also entirely possible that this behaviour is specific to my Ytech module only, as so far we have never managed to get it to invert the telemetry signal in any of the previous attempts.

However the good news is that the new option does show up in the er9x menu !

User avatar
Posts: 10742
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Experimenting er9xProv822u (19-Aug option to send "invert" cmd to MPM)

Post by Kilrah » Fri Aug 21, 2020 8:40 pm

Never heard of a "Ytech" module so it might be a new/weird unit and lack the inverter gate that others have. You should probably post in the multiprotocol module thread on rcgroups first.

User avatar
9x Developer
Posts: 17277
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Experimenting er9xProv822u (19-Aug option to send "invert" cmd to MPM)

Post by MikeB » Fri Aug 21, 2020 10:18 pm

Yes, the command bit will override the compile option (as long as the compile option "#define INVERT_TELEMETRY_TX" is enabled).
I just checked with my '2561 9X, with a 'scope on the telemetry signal from my DIY STM module and changing the "Invert" option in the menu causes the module to change the polarity of the telemetry signal immediately (no power cycle needed).

erskyTx/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

Posts: 31
Joined: Sat Aug 15, 2020 8:45 am
Country: France

Re: Experimenting er9xProv822u (19-Aug option to send "invert" cmd to MPM)

Post by nvd07 » Sat Aug 22, 2020 6:50 am

Ok, with your reply and by looking at the comments in the MPM config.h I am getting and idea of how it is intended to work

Below is the code I downloaded but have not yet compiled myself , ie it is not the config I am running, but good to look at the explanations.
For STM32 they recommend to COMMENT the compile option "#define INVERT_TELEMETRY_TX"
Most likely they followed this recommendation in their precompiled binaries (which I am using right now) made available for STM32.

So I suspect the precompiled binary I am using right now was configured to ignore the command bit option you just added in the er9x menu.

Next step, I will have a go at compiling my own MPM module binaries, hopefully this weekend, with the compile option "#define INVERT_TELEMETRY_TX" uncommented.

Posts: 31
Joined: Sat Aug 15, 2020 8:45 am
Country: France

Re: Experimenting er9xProv822u (19-Aug option to send "invert" cmd to MPM)

Post by nvd07 » Sat Aug 22, 2020 12:04 pm

Ok I am happy to report this is a success!

The MPM FW compilation and flashing with arduino IDE was not difficult.

I carefully looked at the _Config.h settings that they provide in the ZIP package of the project archive ( https://github.com/pascallanger/DIY-Mul ... master.zip ).
And I found out that it would not be necessary to have my own tweaked _MyConfig.h (like the one shown in _MyConfig.h.example ) ; it looked like I would be fine just compiling the Unzipped project as it is.
Then I flash/transferred it onto my Ytech MPM with CTRL+U.

First thing, my receiver and servos still work with the MPM.

Next, a look at the invert telemetry option of er9x prov822u:
- When unticked, it works as it did in my previous post, MPM module version showing up in the protocol menu, so communications between er9x and MPM working good.

- When I tick 'invert' , this time the module accepts the command from er9x, and I see the inverting / idling low on the oscilloscope trace ( which did not happen when I was using precompiled multi-stm-opentx-aetr-noinv-v1.3.1.49.bin ):
So it is now working as it should: user selectable from er9x.
It is great to be able to select this from the menu.

So from here it means I have the option to reconnect my hardware NPN inverter circuit and then I would be able to use the two modules I have, ie I could swap my stock FrsKy XJT module and this 4-in-1 MPM module back and forth and still get all the telemetry functionnalities unaffected.

Thank you Mike for this option you added to er9x, and for your help and patience with the troubleshooting.
:D :D

(side note: as we were able to look at the PCB and markings of my Ytech-badged 4-in-1 MPM during this week in the other thread, there is not much difference with the more common iRangeX-badged Banggood IRX4 Plus referrenced from https://github.com/pascallanger/DIY-Mul ... TX-Module/ ; the PCBs look like they come from the same factory. I noticed i have a PCB ARM_v1.3 while Banggood is currently picturing ARM_v1.2)

Post Reply

Return to “er9x”