FRSKY R9M compatibility?

er9x is the best known firmware. It has a superb range of features and is well supported by the community. Well worth trying out.
User avatar
jhsa
Posts: 18683
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: FRSKY R9M compatibility?

Post by jhsa » Tue Oct 16, 2018 6:30 pm

If it was that long ago, it might be the Megasound module Mike...

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW


volumax
Posts: 210
Joined: Tue Feb 12, 2013 12:21 pm
Country: -

Re: FRSKY R9M compatibility?

Post by volumax » Wed Oct 17, 2018 2:37 am

yes I think it was the megasound from a guy from hungary. How do I fix the THR and AIL switches situation ? I tried reversing my rudder and ail direction on eepe but I did not find a way to correct it. Maybe I did not explain it correctly but when I hit left rudder I get right rudder and same for aileron.

User avatar
MikeB
9x Developer
Posts: 16349
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FRSKY R9M compatibility?

Post by MikeB » Wed Oct 17, 2018 6:15 pm

First check the movement of the small circles in the square boxes on one of the main screens. They should move in the same direction as the stick movement.

What firmware file did you flash? The wrong choice could explain the THR and AIL switches not working.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

volumax
Posts: 210
Joined: Tue Feb 12, 2013 12:21 pm
Country: -

Re: FRSKY R9M compatibility?

Post by volumax » Thu Oct 18, 2018 1:43 am

I flashed mbtx-frsky.hex from mbtx5.zip . Yes the directions are reverse but I will fix that reversing the wires. Did I flash the wrong firmware?
Last edited by volumax on Thu Oct 18, 2018 1:52 am, edited 1 time in total.

User avatar
MikeB
9x Developer
Posts: 16349
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FRSKY R9M compatibility?

Post by MikeB » Thu Oct 18, 2018 8:11 am

Have you done the "Telemetry Mod", where you add wires to move those two switches and then connect a level shifter to provide a connection for telemetry data?

You should be able to reverse the sticks using the hardware tab in eepe, read the EEPROM into eepe, tick the LH and RH boxes then write the EEPROM back.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!


volumax
Posts: 210
Joined: Tue Feb 12, 2013 12:21 pm
Country: -

Re: FRSKY R9M compatibility?

Post by volumax » Thu Oct 18, 2018 8:40 am

no I have not done the telemetry mod

User avatar
MikeB
9x Developer
Posts: 16349
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FRSKY R9M compatibility?

Post by MikeB » Thu Oct 18, 2018 10:54 am

OK, I wasn't building the version you need. I've just posted a mbtx5a.zip. This includes "mbtx.hex" that is for radios without the telemetry mod and with a parallel voice module or no voice module.
This version will now be built as well when I build a release (test or otherwise).

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
MikeB
9x Developer
Posts: 16349
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FRSKY R9M compatibility?

Post by MikeB » Thu Oct 18, 2018 12:26 pm

I just checked the sticks may be reversed using eepeV2 on a M64 using er9xV2 (mbtx).
Run eepe, read the EEPROM, go into "General Settings" and go to the hardware tab. At the bottom are 4 check boxes for the sticks labelled LV, LH, RV and RH, for Left Vertical, Left Horizontal etc. Change the state of the LH and RH boxes, then write the EEPROM back to the radio. Your sticks should now work in the correct direction.
I removed most of the hardware settings from the M64 version of mbtx in order to save flash space. I felt these would not need to be changed on a regular basis, so needing to use eepeV2 to change them was OK.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

volumax
Posts: 210
Joined: Tue Feb 12, 2013 12:21 pm
Country: -

Re: FRSKY R9M compatibility?

Post by volumax » Thu Oct 18, 2018 6:43 pm

Thanks Mike I am away for the weekend but will test when I get back. Is the eepeV2.exe that is part of the zip file what I have to run or do I have to download it from somewhere and install it because I tried opening the one in your zip file but it gave me an error?

volumax
Posts: 210
Joined: Tue Feb 12, 2013 12:21 pm
Country: -

Re: FRSKY R9M compatibility?

Post by volumax » Tue Oct 23, 2018 8:03 pm

Thank you Mike and jsha, I was able to open eepev2 and get it all working, now I just have to test the module. Thanks for your help as always.

volumax
Posts: 210
Joined: Tue Feb 12, 2013 12:21 pm
Country: -

Re: FRSKY R9M compatibility?

Post by volumax » Fri Jan 11, 2019 2:57 am

Hey Mike. I am having a problem with the aurora 9 gimbals which I also had in the past with the taranis gimbals on my turnigy 9x. I uploaded a video showing the issue. Sometimes my channel 1 (aileron) stick doesnt move correctly to full stick deflection and when I let go it returns back to center slowly. Any ideas what this could be?

https://www.youtube.com/watch?v=O3RRCBknhX8

omegapr12
Posts: 1
Joined: Sun Jan 20, 2019 9:26 pm
Country: -

Re: FRSKY R9M compatibility?

Post by omegapr12 » Sun Jan 20, 2019 9:28 pm

Can anyone confirm one thing for me? I have a FlySky FS-TH9X with a ar9x board, will this work with the r9m?

User avatar
MikeB
9x Developer
Posts: 16349
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FRSKY R9M compatibility?

Post by MikeB » Sun Jan 20, 2019 11:36 pm

As long as you flash a recent test version of ersky9x then the R9M is fully supported, including with the flex firmware.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 18683
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: FRSKY R9M compatibility?

Post by jhsa » Sun Jan 20, 2019 11:58 pm

Ersky9x test versions can be found here. (Versões de teste no link abaixo ;) :) )

https://openrcforums.com/forum/viewtopic.php?f=7&t=4676

I believe "ersky9xProvR222d2.zip" is the latest one.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
Galand
Posts: 25
Joined: Tue Dec 27, 2011 8:19 pm
Country: -
Location: Long Island, NY USA

Er9x R9M compatibility?

Post by Galand » Thu Feb 28, 2019 12:27 am

I want to install the R9M module on one of my TH9X radios with the Smartieparts board. I have ER9x-r820 on the radio and Eep 422 on the PC.
I downloaded and tried to install mltx5a.zip with eepeV2.exe.
With double click it gives a System Error saying "cannot proceed because Qtcore4.dll, QtNetwork4.dll, Qtgui4.dll and Qtxml4.dll are missing.
Could this be a system issue with my PC with Windows 10, but I am not sure.
Can you help?
Last edited by Galand on Thu Feb 28, 2019 9:24 pm, edited 1 time in total.

User avatar
jhsa
Posts: 18683
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: FRSKY R9M compatibility?

Post by jhsa » Thu Feb 28, 2019 6:20 am

Try copying the eepeV2.exe file to the directory where normal eepe is installed. Or if you didn't install it yet, download it and do it..

João

Sent from my BLN-L21 using Tapatalk

My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
Galand
Posts: 25
Joined: Tue Dec 27, 2011 8:19 pm
Country: -
Location: Long Island, NY USA

Re: Er9x R9M compatibility?

Post by Galand » Thu Feb 28, 2019 9:23 pm

Does not seem to make a difference.
The old Eepe version re-installs normally but not this eepeV2.exe
The file size is much smaller, only 25% of the normal Eepe422.
I have manually downloaded and installed the dll's it says are missing. All of them seem to relate to C++.
It still can't find QtCore4.dll and QtXml4.dll and now it is missing in addition: mingwm.dll and libgcc_s_dw2-1.dll.
Maybe Mike has cut out too much :-)

User avatar
MikeB
9x Developer
Posts: 16349
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FRSKY R9M compatibility?

Post by MikeB » Fri Mar 01, 2019 12:43 am

It should work if you install the "old" eepe, then just copy the eepeV2.exe file to the eepe directory.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
Galand
Posts: 25
Joined: Tue Dec 27, 2011 8:19 pm
Country: -
Location: Long Island, NY USA

Re: FRSKY R9M compatibility?

Post by Galand » Sat Mar 02, 2019 8:09 pm

That worked. Thanks.
Shows version p423
What do I do next to activate the R9M?
Just plug the R9M module in the back?
Which HEX file should I flash to the 9X? mbtx-frskyi-sv.hex or mbtx-frsky.hex?

User avatar
MikeB
9x Developer
Posts: 16349
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FRSKY R9M compatibility?

Post by MikeB » Sat Mar 02, 2019 10:20 pm

The "sv" version is for use if you have a serial voice module fitted.
Both er9x and er9xV2 should support the R9M. Just go to the protocol menu, select XJT, then R9M as the type and set the power output.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
Galand
Posts: 25
Joined: Tue Dec 27, 2011 8:19 pm
Country: -
Location: Long Island, NY USA

Re: FRSKY R9M compatibility?

Post by Galand » Sun Mar 03, 2019 10:16 pm

Hi Mike,
Sorry to keep bothering you.
The Tx has SVN: er9xV2-pjr822 and MOD: FRSKY NT
Using both eepeV2 version p423 and eepe version 422, in the model set-up screen I can only select protocol option PXX/XJT and then as Type D16 or D8 or LR12.
R9M option does not show up.
Update:
Using the Tx to configure the Model set-up/protocol, the correct options show up. So I was able to bind the R9M Tx and Rx and make the servos move.
Success!!!
But why not on the eepe configuration screen?
Thanks
Last edited by Galand on Sun Mar 03, 2019 11:13 pm, edited 2 times in total.

User avatar
MikeB
9x Developer
Posts: 16349
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FRSKY R9M compatibility?

Post by MikeB » Sun Mar 03, 2019 10:45 pm

Does the Tx allow R9M as the type? If not, what date is showing in the version display?
I'm probably behind in updating eepe/eepeV2 for the R9M.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
Galand
Posts: 25
Joined: Tue Dec 27, 2011 8:19 pm
Country: -
Location: Long Island, NY USA

Re: FRSKY R9M compatibility?

Post by Galand » Sun Mar 03, 2019 11:15 pm

Sorry, I did not see your reply before I updated my post to indicate success when using the Tx to configure, not eepe or eepeV2, like you suggest.
Thanks

User avatar
MikeB
9x Developer
Posts: 16349
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FRSKY R9M compatibility?

Post by MikeB » Sun Mar 03, 2019 11:42 pm

I'll try to post updated eepe and eepeV2 tomorrow.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
Galand
Posts: 25
Joined: Tue Dec 27, 2011 8:19 pm
Country: -
Location: Long Island, NY USA

Re: FRSKY R9M compatibility?

Post by Galand » Mon Mar 04, 2019 3:29 am

That would be nice because configuring a moderately complex model on the Tx is laborious. As I just found out :-)

User avatar
MikeB
9x Developer
Posts: 16349
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FRSKY R9M compatibility?

Post by MikeB » Tue Mar 05, 2019 7:18 pm

A bit later than intended, but I have now posted (on the er9x test version thread) updated eepe and eepeV2 that support the R9M module.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

u3dreal
Posts: 4
Joined: Thu Mar 07, 2019 8:05 pm
Country: -

Re: FRSKY R9M compatibility?

Post by u3dreal » Thu Mar 07, 2019 8:13 pm

Hello everyone !!!!

Been upgrading my r9m to flex firmware for my 9xr ( 128 , no pro ,tel_mod ) and found that the flex options are not yet ported from ersky9x :?

Ist there any chance it will be added ?
So far I'm using er9x provk and the module worked fine. Trying mbtx5a ended in my LCD backlight turning
off permanently. Is there a way to switch it back on ?

Thanks a lot for all the work been put into this top firmware 8-)

regards u3dreal

I'm willing to test betas !

User avatar
MikeB
9x Developer
Posts: 16349
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FRSKY R9M compatibility?

Post by MikeB » Fri Mar 08, 2019 12:14 am

I'll see what I can do, give me a couple of days. There does seem to be a problem on this forum blocking attachments at present, so I may have trouble posting a test version.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

u3dreal
Posts: 4
Joined: Thu Mar 07, 2019 8:05 pm
Country: -

Re: FRSKY R9M compatibility?

Post by u3dreal » Fri Mar 08, 2019 1:12 am

Exellent News ! Of course take your time

User avatar
MikeB
9x Developer
Posts: 16349
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FRSKY R9M compatibility?

Post by MikeB » Fri Mar 08, 2019 3:22 pm

I've just posted a test version of er9x (V1) for the '128 that includes support for the R9M flex firmware.
As my R9M doesn't (currently) have the flex firmware installed, I haven't tested it with a module. The code should be correct as I just copied it from ersky9x.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!


Post Reply

Return to “er9x”